Microsoft Excel

Herbers Excel/VBA-Archiv

JETZT() | Herbers Excel-Forum


Betrifft: JETZT() von: Werner
Geschrieben am: 21.01.2010 09:42:49

Halli Ihr
Ich suche eine Formel für folgendes:
In Zelle D30 wird eine Zahl eingetragen,
in Feld K30 soll die Zeit des Eintrags erscheinen,
Zelle K30 soll sich, beim erneuten öffnen des Blattes, nicht aktuallisieren.
Ich hoffe mir kann jemand helfen.

Gruß
Werner

  

Betrifft: mit Iterative Berechnung und Hilfszelle. von: Tino
Geschrieben am: 21.01.2010 10:06:01

Hallo,
wenn Du in den Excel- Optionen die Iterative Berechnung aktivierst
kannst Du es mit einer Hilfszelle machen.

 DEFGHIJKL
29        Hilfszelle
3019      10:01:2719

Formeln der Tabelle
ZelleFormel
K30=WENN(L30<>D30;JETZT(); K30)
L30=WENN(D30<>L30;D30;L30)



Gruß Tino


  

Betrifft: AW: mit Iterative Berechnung und Hilfszelle. von: Werner
Geschrieben am: 22.01.2010 18:23:47

Hallo Tino
klappt soweit ganz gut.
Vielen Dank
Gruß
Werner


  

Betrifft: AW: JETZT() von: welga
Geschrieben am: 21.01.2010 10:08:42

Hallo Werner,

hinterlege folgenden Code im Tabellenblatt:

Sub worksheet_change(ByVal target As Range)
If Not Intersect(Range("D30"), target) Is Nothing Then
Range("K30") = Now
End If

End Sub



  

Betrifft: AW: JETZT() von: Werner
Geschrieben am: 21.01.2010 12:22:49

Hallo
vielen Dank für die rasche Antwort,
war leider weg.
Leider komme ich aber nicht weiter.
Ich habe den Code als Makro hinterlegt(eingegeben), aber bei de auswahl eines Makros ist keines vorhanden.
Für weitere Hilfe währe ich sehr dankbar,
Gruß
Werner


  

Betrifft: AW: JETZT() von: hary
Geschrieben am: 21.01.2010 13:04:02

Hallo Werner
nicht als Makro!!
Rechtsclick auf den Tabellenreiter/code anzeigen/da diesen Code rein.
gruss hary


  

Betrifft: AW: JETZT() von: Werner
Geschrieben am: 21.01.2010 15:10:04

Hallo hary
Vielen Dank,
klappt prima für Zelle K30
Wie verfahre ich jedoch, wenn die Zellen K5 - K29 ebenso berechnet werden Sollen?
Gruß
Werner


  

Betrifft: AW: JETZT() von: hary
Geschrieben am: 21.01.2010 16:34:25

Hallo Werner
Meinst Du bei eitragungen in SpalteD das in der selben Zeilein SpalteK der eintrag erfolgt?
dann so:


Private Sub Worksheet_Change(ByVal Target As Excel.Range)
If Not Intersect(Range("D5:D30"), Target) Is Nothing Then
Cells(Target.Row, 11) = Now
End If
End Sub

gruss hary


  

Betrifft: AW: JETZT() von: Werner
Geschrieben am: 22.01.2010 18:20:59

Hallo Hary
Zeit ist Geld, und mir fehlt beides.
Vielen Dank für deine bisherigen bemühungen.
Das Problem ist folgendes: für Zelle D30 bzw. K30 klappt das wunderbar,
jedoch soll dieses auch für Zelle D1 bzw. K1
weiter Zelle D2 bzw. K2
und so weiter bis zur Zelle D30 bzw. K30
In Zellen der Spalte D wird von mir für jeden Tag ein Wert eingegeben und in Spalte K soll immer die Eingabe-uhrzeit erscheinen.
Beim speichern und wieder öffnen der Tabelle soll sich der Wert in Spalte K jedoch nicht ändern(deshalb auch JETZT() nicht möglich),sondern nur wenn in Spalte D der Wert eingetragen(bzw. geändert) wird.
Für die weiteren bemühungen
VIELEN DANK

Gruß
Werner