datumsformatierung



Excel-Version: 2000
  

Re: datumsformatierung

von: MRR
Geschrieben am: 10.04.2002 - 12:22:16


Spricht etwas dagegen, dass Du auf die Datumszelle verweist und sie dann entsprechend formatierst?
Bsp.: In A1 steht 10.4.2002
In B1: =A1
B1 wird formatiert über Zellformatierung, Benutzerdefiniert, "TTTT"
Oder suchst Du was anderes?
Matthias

  

Re: datumsformatierung

von: sam
Geschrieben am: 10.04.2002 - 12:24:54


Hallo,

ich stimme kalle zu. Solltest du doch was anderes brauchen, versuchs damit:

=WAHL(WOCHENTAG(A1;2);"Montag";"Dienstag";"Mittwoch";"Donnerstag";"Freitag";"Samstag";Sonntag)

Gruß,
Sam

  

Re: datumsformatierung

von: Hermann
Geschrieben am: 10.04.2002 - 12:34:04


Hallo,
das geht mit einer verschachtelten WENN Funktion, ich hab hier ein Beispiel, das du übernehmen kannst indem du den Wert bei Wochentag(H10) beliebig abänderst.

hier das beispiel:

=WENN(WOCHENTAG(H10)=1;"Sonntag";WENN(WOCHENTAG(H10)=2;"Montag";WENN(WOCHENTAG(H10)=3;"Dienstag";WENN(WOCHENTAG(H10)=4;"Mittwoch";WENN(WOCHENTAG(H10)=5;"Donnerstag";WENN(WOCHENTAG(H10)=6;"Freitag";WENN(WOCHENTAG(H10)=7;"Samstag";0)))))))

Gruß
Hermann

  

Re: datumsformatierung

von: Hermann
Geschrieben am: 10.04.2002 - 12:43:41


Die Lösung ist super-elegant funktioniert aber nur in der Vergangenheit sprich ab heutigem Datum.

Gruß
Hermann

nach unten

Betrifft: datumsformatierung
von: kalle
Geschrieben am: 10.04.2002 - 12:17:23

Halloa,

ich habe folgendes Problem:

ich versuche aus einem vorgegebenen Datum den Wochentag zu Formatieren mit Wochentag(A1), nun liefert er mir den Tag, aber als Zahl. Wie muss ich jetzt fortfahren um aus dieser Zahl den Tag als Text auszugeben? Bsp.: 4 Ausgabe "Mittwoch"

Danke

nach oben   nach unten

Re: datumsformatierung
von: sam
Geschrieben am: 10.04.2002 - 13:05:49

hi,

kleiner Fehlerteufel hat sich eingeschlichen, funktioniert aber sicher mit jedem Datum ab 1.1.1900

=WAHL(WOCHENTAG(A1;2);"Montag";"Dienstag";"Mittwoch";"Donnerstag";"Freitag";"Samstag";"Sonntag")

Sam


nach oben   nach unten

Re: datumsformatierung
von: lexman
Geschrieben am: 10.04.2002 - 16:21:20

Die simpelste Lösung ohne lange Formelkritzelei ist die nachstehende Formel:

=WENN(A10>0;WOCHENTAG(A10);"")

Hierbei enthält die Spalte A das gewünschte Datum. In Spalte B (gleiche Zeile) wird die Formel eingefügt. (achte auf die richtige Zeilennummer! Bei mir ist das die Zeile 10). Sobald in einer Zelle von A ein beliebiges Datum eingetragen wird, wird die Wochentags-Nummer erzeugt. So kennst Du das ja schon. Die Spalte B muß nun noch formatiert werden.
Dazu wähle "Benutzerdefinierte Formate" und trage im Editierfeld dieser Dialogbox "TTTT" ein,wenn Du die volle Tagesangabe brauchst.
Trage "TTT" ein, wenn Dir der Tag in drei Buchstabenangabe genügt.
Nur "TT" ändert dann nichts mehr. Du solltest diese Formatierungen auch mal mit Monat (MMMM) oder Jahr (JJJJ) oder (JJ) ausprobieren.

K.-H.P.

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Nur 0-9 in String lassen"