Kopieren von Formeln



Excel-Version: 2000
nach unten

Betrifft: Kopieren von Formeln
von: Frank Kleinert (Neuling)
Geschrieben am: 12.04.2002 - 11:57:05

Hallo Leute,

wer kann mir helfen folgendes Problem zu lösen:
Ich habe z.B. eine Formel in A1 mit einem Zellbezug z.B. WENN(D4=X;Y;Z). Nun möchte ich die Formel in 20 SPALTEN (A2-A21) kopieren wobei allerdings nicht die "4" hochgezählt werden soll, sondern das "D". Also in A2 soll stehen: E4=X;Y;Z).
Wie mache ich das?

nach oben   nach unten

Re: Kopieren von Formeln
von: Peter
Geschrieben am: 12.04.2002 - 12:04:56

Schreib die Formel so:

wenn(D$4=X;Y;Z)

nach oben   nach unten

Re: Kopieren von Formeln
von: @lex
Geschrieben am: 12.04.2002 - 12:11:01

Hallo Frank !
In Excel gibt es einen absoluten und relativen Bezug.
Dieser wird durch das "$" im Zellbezug dargestellt.
Beim Kopieren von $A1 wird nur der Zeilenbezug "hochgezählt"
Bei A$1 nur die Spalte

In Deinem Fall würde die Formel heissen =Wenn(D$4=x";y;z)
Diese Formel kopierst Du in ein neues Blatt von A1 bis U1
Markierst diesen Bereich.
In Dein Blatt in dem Du die Berechnungen machen willst.
Zelle a1 wählen
Gehst über Inhalte einfügen-> Formeln -> transponieren

Und das wars

Alex


nach oben   nach unten

Re: Kopieren von Formeln
von: Marcello
Geschrieben am: 12.04.2002 - 12:11:35


=WENN($D4="X";"Y";"Z")

Versuch es mit dem "Dollar Zeichen".
cu
Marcello


nach oben   nach unten

Re: Kopieren von Formeln
von: Frank
Geschrieben am: 12.04.2002 - 12:34:38

Vielen Dank für die schnelle Antwort.
Nur leider funktioniert dies nicht, da Excel mir dann zwar nicht die "4" hochzählt, aber leider auch nicht das "D".

nach oben   nach unten

Re: Kopieren von Formeln
von: Frank
Geschrieben am: 12.04.2002 - 12:35:35

Vielen Dank für die schnelle Antwort.
Nur leider funktioniert dies nicht, da Excel mir dann zwar nicht die "4" hochzählt, aber leider auch nicht das "D".

nach oben   nach unten

Re: Kopieren von Formeln
von: Peter
Geschrieben am: 12.04.2002 - 12:45:18

hast du das $ NUR vor die 4 gesetzt, oder auch vor das D?
$D$4 hält beim Kopieren Zeile und Spalte fest
$D4 hält beim Kopieren nur die Spalte fest
D$4 hält beim Kopieren nur die Zeile fest

nach oben   nach unten

Re: Kopieren von Formeln
von: Frank
Geschrieben am: 12.04.2002 - 13:07:52

Ich glaube, wir reden (schreiben) aneinander vorbei. Ich möchte, dass "D" hochgezählt wird, während ich in SPALTEN kopiere. D.h., anstelle der Zahl soll der Buchstabe hochgezählt werden.

Gruß

Frank


nach oben   nach unten

Re: Kopieren von Formeln
von: Frank
Geschrieben am: 12.04.2002 - 13:39:56

Vielen Dank

Hat funktioniert, hatte mir allerdings die Lösung einfacher vorgestellt.


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Kopieren von Formeln"