autom. Datumergänzung



Excel-Version: 97
  

Re: autom. Datumergänzung

von: Micha*
Geschrieben am: 16.04.2002 - 13:04:49


A7=C4

A8=A7+1
A9=A8+1 usw (Autofill)

  

ohne Samstag/Sonntag ?!

von: MikeS
Geschrieben am: 16.04.2002 - 13:10:47


Hi Micha,

danke für den Tip aber soweit war ich auch schon gekommen.

Leider kann man es so nicht machen, da die Samstage/Sonntage in den einzelnen Monaten immer verschieden sind.

Vielleicht gibt es ja `ne Lösung per VBA.

Trotzdem vielen Dank.

Ciao MikeS

  

Autoausfüllen nur Wochentage

von: Sam
Geschrieben am: 16.04.2002 - 13:15:12


Hi,

Schreib das 1. Datum hin und geh auf den Autoausfüllpunkt. Nun ziehst du nicht mit der linken sondern mit der rechten Maustaste runter. Es erscheint beim Auslassen ein Kontextmenü in dem du "Wochentage" auswählen kannst.

Gruß,
Sam

  

benötige vollautomatisches Ausfüllen

von: MikeS
Geschrieben am: 16.04.2002 - 13:32:24


Hi Sam,

danke für Deinen Tip, diese Funktion kannte ich auch noch nicht.

Ich möchte aber einen Automatismuß erreichen, daß der Anwender praktisch nur den Monat auswählen muß und dann die zugehörigen Datumswerte automatisch ergänzt werden.

Vielleicht noch `ne Idee???

Geht wohl doch nur über VBA.

Trotzdem danke.

Ciao MikeS

  

Re: benötige vollautomatisches Ausfüllen

von: Otto
Geschrieben am: 16.04.2002 - 13:48:00


Hi Mike

wenn Du den Tip von Sam als Makro aufzeichnest, kommt folgendes raus:

Sub Makro3()
Range("C4").Select
Selection.Copy
Range("A7").Select
ActiveSheet.Paste
Application.CutCopyMode = False
Selection.NumberFormat = "m/d/yy"

Selection.AutoFill Destination:=Range("A7:A25"), Type:=xlFillWeekdays
Range("A7:A25").Select
End Sub

Dami werden alle Daten ohne die Wochenenden aufgelistet.


Gruß Otto

  

Re: benötige vollautomatisches Ausfüllen

von: sam
Geschrieben am: 16.04.2002 - 13:48:46


Hi,

tja, da hast du noch ein 2. Problem. Wenn du einen Wert per Kombinationsfeld auswählst, startet Excel nicht das Change-Ereignis, wo man sich normalerweise reinhängen kann.

die Lösung mit VB sieht so aus. Geht wie gesagt nur dann, wenn du den Wert z.B. "2002/02" oder "05/2001" händisch eingibst.
Den Code kopierst du ins Modul "Tabelle1".
Vielleicht kannst du es trotzdem brauchen.

Viel Spaß,
Sam

  

Upps: Fehlerteufel eingeschlichen ;-)

von: sam
Geschrieben am: 16.04.2002 - 13:52:18


so sollte es nun passen (Wochenenden wurden nicht berücksichtigt).
Gruß,
Sam

  

Re: benötige vollautomatisches Ausfüllen

von: Dede
Geschrieben am: 16.04.2002 - 14:27:34


Hallo,
ich versuche gerade eine Funktion für Dich zu basteln
=WENN(WOCHENTAG(Zelle)=6;Zelle+3;Zelle+1)
Zelle soll die vorangegangene Zelle sein. Schaut auch logisch aus. Hat nur irgendwo einen Denkfehler und ich ein Brett vorm Kopf. Ich habe nämlich auch Probleme mit der Summewenn-Funktion, deswegen bin ich überhaupt hier.

  

Hallo Sam, klappt leider nicht!!!?

von: MikeS
Geschrieben am: 16.04.2002 - 16:17:19


Hallo Sam,

habe Deinen zweiten Code in Tabelle1 eingefügt, doch wenn ich das Datum "händisch" z.B. 04/2002 in Zelle C4 eingebe, passiert in meiner Tabelle (A7:...) leider nichts. Noch nicht mal `ne Fehlermeldung???

Woran könnte das liegen?

Vielleicht noch einen Tip?

Vielen Dank MikeS

  

mit Formel klappts, aber nicht hundertprozentig

von: MikeS
Geschrieben am: 16.04.2002 - 16:49:28


Hallo liebe Helfer,

die funktionierende Formel habe ich in A8 stehen und einfach nach unten kopiert A8:A29.

=WENN(WOCHENTAG(A7)=6;A7+3;(WENN(WOCHENTAG(A7)=7;A7+2;A7+1)))

In A7 steht "=C4" , weil ich in C4 mit einer Gültigkeitsliste die gewünschten Monate auswähle.

Da die Anzahl der Wochentage je Monat variiert, stehen z.B. bei Auswahl April nach dem 30.04.02 in Zelle A29 das Datum 01.05.02.

Die Tabelle soll aber nur die Datumswerte des jeweiligen Monats enthalten und ich will nicht immer die überschüssigen Daten (z.B. 01.05.02) rauslöschen müssen!!!

Leider klappts mit dem VBA-Vorschlag von Sam bei mir nicht? (Bin halt keine Leuchte!!!)

Vielleicht noch `ne Idee?

Dankeschön MikeS

  

Re: Hallo Sam, klappt leider nicht!!!?

von: sam
Geschrieben am: 16.04.2002 - 20:26:36


Hallo,

nach deiner Angabe habe ich vermutet, dass das datum in zeile 1 steht. In welcher Zeile reagiert werden soll, steht in der 1. Anweisung. Wenn du es in Ziele 4 reinschreibst muss der Code folgendermaßen umgewandelt werden:

If Target.Row <> 4 Then Exit Sub

gecheckt?
Sam

nach unten

Betrifft: autom. Datumergänzung
von: MikeS
Geschrieben am: 16.04.2002 - 12:56:48

Hallo Leute,

in Zelle C4 kann ich über eine Gültigkeitsliste die Monate Jan 02, Feb 02, Mrz 02 usw. auswählen.

Nun soll nach Auswahl eines Monates in Zelle C4 die zugehörigen Datumswerte (ohne Samstage+Sonntage) ab Zelle A7 abwärts in meine Tabelle eingefügt werden.

Beispiel:

Auswahl in Zelle C4 = Apr 02

A7 = 01.04.02
A8 = 02.04.02
A9 = 03.04.02
A10= 04.04.02
A11= 05.04.02
A12= 08.04.02
A13= 09.04.02
A14= 10.04.02
A15= 11.04.02
A16= 12.04.02
A17= 15.04.02
usw.

Wie kann man das hinbekommen???

Vielen Dank
MikeS

nach oben   nach unten

Code funktioniert trotzdem nicht!?
von: MikeS
Geschrieben am: 17.04.2002 - 08:18:15

Hi Sam, der Monat (Zeile 4) kann man aus einer Gültigkeitsliste auswählen. Wenn sich der ändert sollen die Datumsangaben von A7:A30 gelöscht werden und die neuen Daten in A7:A30 reingeschrieben werden (ohne Samstag + Sonntag). Die Formeln ab A7 funktionieren perfekt, nur gibt es die Datumüberläufe. Wenn Du z.B. den Monat April auswählst, steht in A29 der 1.05.02 und genau das will ich nicht!!! Es sollen nur die jeweiligen Tage des Monats angezeigt werden. Ich komme mit Deinem Code irgendwie nicht klar (steht in Tabelle1). Muß ich denn die Formeln aus A7:A30 löschen, damit der Code funktioniert??? Vielleicht bist Du ja nochmal so nett... Dankeschön, ciao Mike

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "bedingte Formatierung"