Microsoft Excel

Herbers Excel/VBA-Archiv

Bedingte Formatierung klappt nicht | Herbers Excel-Forum


Betrifft: Bedingte Formatierung klappt nicht von: Juergen
Geschrieben am: 22.01.2010 20:54:39

Hallo
Ich brauche mal Hilfe.
Und zwar hab ich folgendes Problem mit der Bedingten Formatierung:
in zelle E12 ist eine Formel die ein Wert Zurückgebt.(1-25)
in zelle F12 ist ebenfalls eine Formel hinterlegt die auch ein Wert zurückgebt.(1-25)
Nun zu mein Problem Ich möchte, wenn der Wert in F12 kleiner ist als in E12 die zelle rot einfärben.
Und die Zelle grün wenn der Wert Gleich ist.
Ist soweit Ja auch kein Problem aber wenn ich die Zellen Runter kopier wo noch nichts in den Zellen steht ist dann auch alles grün weil die Zellen Ja auch Gleich sind.
Aber wo nichts ist soll auch noch nichts Farbig werden.
Hab schon einiges ausprobiert aber noch zu keinem ergebnis gekommen.
Vieleicht könnt Ihr mir Ja helfen.

Dank im Voraus sagt Juergen

  

Betrifft: AW: Bedingte Formatierung klappt nicht von: Josef Ehrensberger
Geschrieben am: 22.01.2010 21:00:10

Hallo Jürgen,

=UND(E12&F12<>"";E12=F12)
Gruß Sepp



  

Betrifft: AW: Bedingte Formatierung klappt nicht von: Daniel
Geschrieben am: 22.01.2010 21:01:53

Hi

dann musst du eine Bedinung ergänzen, so daß sie nicht für leere Zellen gilt, z.B. für grün so:
=Und(F12<>"";F12=E12)

Gruß,Daniel


  

Betrifft: AW: Bedingte Formatierung klappt nicht von: Juergen
Geschrieben am: 22.01.2010 21:13:04

Hallo,
Ich glaub so was habe ich auch schon probiert aber immer wenn Zelle E.. leer ist wird`s trotzdem grün.
Oder liegt das an der Zellformel:in E12 und F12
In E12 steht:=WENN(ISTFEHLER(INDIREKT("'"&$B12&"'!I46"));" ";INDIREKT("'"&$B12&"'!I46"))
In F12 steht:=WENN(ISTFEHLER(INDIREKT("'"&$B12&"'!j46"));" ";INDIREKT("'"&$B12&"'!j46"))

Das sind die beiden Formeln die mir die Werte zurückgeben.
Gruß
Juergen


  

Betrifft: "" statt " " o.T. von: Josef Ehrensberger
Geschrieben am: 22.01.2010 21:15:48

Gruß Sepp



  

Betrifft: AW: "" statt " " o.T. von: Juergen
Geschrieben am: 22.01.2010 21:31:05

Hallo,
kein Erfolg.Bereite eine Beispielmappe vor.

Gruß
Juergen


  

Betrifft: AW: "" statt " " o.T. von: Juergen
Geschrieben am: 22.01.2010 21:49:08

Hallo,
Hier ein abgespeckte Mappe zum Testen.

https://www.herber.de/bbs/user/67433.xls


Gruß
Juergen


  

Betrifft: AW: "" statt " " o.T. von: Daniel
Geschrieben am: 22.01.2010 21:57:14



Hi
du hast das in den falschen Formeln ausgetauscht.
in der bedingten Formatierung werden ja zur prüfung beide Felder verkettet, dh.
" " und " " ergibt "  " (1+1 = 2) wohingegen "" und "" wieder "" ergibt (0+0=0).
dh entweder in den Zellformeln und in der Bedingten Formatierung "" verwenden, oder in den  _
Zellformeln " " und dann in der Bedingten Formatierung wegen der Verkettung "  "

Gruß, Daniel



  

Betrifft: AW: "" statt " " o.T. von: Josef Ehrensberger
Geschrieben am: 22.01.2010 21:58:42

Hallo Jürgen,

das "" statt " " bezog sich natürlich auf alle Formeln! Bei "Excel gut" hättest
du das aber schon umsetzen können.

Werde sowieso nie begreifen, warum ihr immer ein Leerzeichen in eine
Zelle schreiben müsst, wenn nichts drin stehen soll.

Übersicht

 EFG
11   
12000
13   
14   

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
E121. / Formel ist =E12<>""Abc
F121. / Zellwert ist zwischen 1 und =E12-1Abc
F122. / Formel ist =UND(E12&F12<>"";E12=F12;E12+F12>0)Abc
G121. / Formel ist =UND(F12<>"";G12<>F12)Abc
G122. / Formel ist =UND(F12<>"";G12=F12)Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: "" statt " " o.T. von: Juergen
Geschrieben am: 22.01.2010 22:30:23

Hallo,

danke hat geklappt mit
=UND(E12&F12Ungleich"";E12=F12;E12+F12größer0)

Aber das mit dem leerzeichen kann ich nicht nachvollziehen das kommt doch von der Formel wegen Istfehler sonnst hätte ich doch #Bezug oder liege ich da falsch ??

Gruß und Danke für Deine Unterstützung sagt
Juergen


  

Betrifft: AW: "" statt " " o.T. von: Josef Ehrensberger
Geschrieben am: 22.01.2010 22:38:30

Hallo Jürgen,

wenn ich eine Formel habe, die unter Umständen eine Fehlerwert oder einen anderen
unerwünschten Wert zurückgibt, dann setze ich das "" im sonst-Teil der Formel ein
um eine leere Zelle anzuzeigen.
(die Zelle ist eigentlich nicht leer, weil ja "" drin steht, optisch wirkt sie aber leer)

Wenn ich statt "" das von dir verwendete " " einsstze, dann erscheint die Zelle
zwar auch leer, enthält aber ein Leerzeichen. Wenn ich an anderer Stelle auf ""
prüfe, wird das Ergebnis nicht stimmen, weil "" eben nicht gefunden wird.


Gruß Sepp



  

Betrifft: AW: "" statt " " o.T. von: Juergen
Geschrieben am: 22.01.2010 22:43:16

Na Logo weil ein Leerzeichen auch ein Zeichen ist denn laut Asci Zeichen ist 65=a u.s.w

Gruß
Juergen


  

Betrifft: 65 ist A, a ist 97, Mannomann...! owT von: Luc:-?
Geschrieben am: 23.01.2010 01:01:55

:-?


  

Betrifft: AW: 65 ist A, a ist 97, Mannomann...! owT von: Juergen
Geschrieben am: 23.01.2010 14:37:54

Hy Luc -????

Du bist ja ein richtiger Klugscheisser.Es kommen immer nur irgendwelche Kommentare von Dir und nichts Normales.
Immer überall sein Senf zu geben.

Schau dir doch mal die Ascii Tabelle an da wirst du feststellen das auch Dez.65 ein "A" ist Ok 97 ist auch ein "a"


  

Betrifft: Sei doch froh, dass ich mitunter nur... von: Luc:-?
Geschrieben am: 23.01.2010 15:46:30

...einen kurzen Kommentar schreibe... :->
Alles andere verstehst du doch eh' nicht (weshalb du das ja offensichtlich auch nicht liest!), nicht mal den gen. Kommentar. Wenn dir der code-technische Unterschied zwischen A (groß) und a (klein) egal ist, kannst du nicht wirklich xl-gut sein... Deine „xlProdukte“ möchte ich jedenfalls nicht sehen...!
Luc :-?


  

Betrifft: AW: 65 ist A, a ist 97, Mannomann...! owT von: Reinhard
Geschrieben am: 23.01.2010 19:42:17

hallo Juergen,

Luc hat geäußert daß A die Nummer 65 hat und a die Nummer 97.
Völlig zurecht.

Warum plusterst du dich jetzt darüber auf? Sage was du genau meinst bzw. dir daran nicht passt oder schweige.

Gruß
Reinhard


Beiträge aus den Excel-Beispielen zum Thema "Bedingte Formatierung klappt nicht"