Microsoft Excel

Herbers Excel/VBA-Archiv

Allternative zur überlangen Wenn-Funktion | Herbers Excel-Forum


Betrifft: Allternative zur überlangen Wenn-Funktion von: McFly_HL
Geschrieben am: 25.01.2010 23:43:03

Hallo Leute, ich erhoffe Eure Hilfe, leider ist es nen Weilchen her, und ich habe vergessen wie man das mit den IF, ELSE bzw. ELSEIF macht, kann mir einer mal auf die Sprünge helfen, oder mir eine einfache Lösung für mein Problem geben?

Die folgende Formel wäre korrekt wenn Sie nicht zu viele WENN-Funktionen hätte, war aber die einzige Art Euch zu zeigen was ich beabsichtige.

=WENN(ODER(H23="aa";H23="aa`in");"A6";(WENN(ODER(H23="ab";H23="ab'in");"A7";(WENN(ODER(H23="ac";  H23="ac'in");"A8";(WENN(ODER(H23="ad";H23="ad'in");"A9";(WENN(ODER(H23="ae";H23="ae'in");"A10";  (WENN(ODER(H23="af";H23="af'in");"A11";(WENN(ODER(H23="ag";H23="ag'in");"A12";(WENN(ODER(H23="ah";  H23="ah'in");"A13";(WENN(ODER(H23="ai";H23="ai'in");"A14";(WENN(ODER(H23="aj";H23="aj'in");"A15";  (WENN(ODER(H23="ak";H23="ak'in");"A16";(WENN(ODER(H23="al";H23="al'in");"A17";(WENN(ODER(H23="am";  H23="am'in");"A18";(WENN(ODER(H23="an";H23="an'in");"")))))))))))))))))))))))))))  
Also wenn ich "aa" oder "aa'in" in einer Zelle eingebe soll in der Zelle nebenan "A6" erscheinen, und wenn ich es mit "ab" mache halt A7 usw.

Ich weiß dass das auch irgendwie mit CASE geht, aber da bin ich nie durchgestiegen wie das funzt.

Danke schon mal für Eure Hilfe

Gruß Fly

  

Betrifft: AW: Allternative zur überlangen Wenn-Funktion von: Josef Ehrensberger
Geschrieben am: 26.01.2010 00:18:59

Hallo Fly,

ganügt da nicht das?

=WENN(H23<>"";"A"&CODE(TEIL(H23;2;1))-91;"")

Gruß Sepp



  

Betrifft: AW: Allternative zur überlangen Wenn-Funktion von: McFly_HL
Geschrieben am: 26.01.2010 20:28:02

Hi Sepp, danke für die schnelle und geniale Antwort.



Leider habe ich der Einfachheit halber nur Platzhalter verwendet, für aa oder ab usw werden jeweils eine männliche und eine weibliche Person namendlich eingetragen, und dann verschiedenen Projektgruppen zugeordnet. das Problem ist das es zwar immer Doppelgruppen sind, die Zahl der Gruppen aber bei etwa 20 liegt. ich habe also 20 männliche Namen und 20 weibliche Namen denen von A6 - A16 teilweise auch mal A15d und A15h dabei sind, und die restlichen in Projekten mit B1 - B?



Beispiel: Schreibe ich Tim oder Lisa ins Feld erscheint A6,

Schreibe ich Rudi oder Karen erscheint z.B. A15h. Wird Tim einmal A6 zugeordnet, bleibt er das auf ewig, der Eintrag soll sich erst wieder ändern wenn ein anderer Name eingetragen wird, also Rudi, dann soll dort A15h stehen. Schreibe ich dann wieder Tim hin, dann steht dort wieder A6.



Es soll eine Tabelle sein die es erleichtern soll nicht immer die Buchstabencodes aus der Liste zu suchen.





Thx nochmal Fly


  

Betrifft: AW: Allternative zur überlangen Wenn-Funktion von: Josef Ehrensberger
Geschrieben am: 26.01.2010 22:14:14

Hallo Fly,

dann war dein Beispiel unglücklich gewählt.

Meinst du so?

Tabelle1

 ABCDEFGH
1ProjektgruppeMitglied 1Mitglied 2   Name:Name 15_2
2A1Name 1_1Name 1_2   Projektgruppe:A15
3A2Name 2_1Name 2_2     
4A3Name 3_1Name 3_2     
5A4Name 4_1Name 4_2     
6A5Name 5_1Name 5_2     
7A6Name 6_1Name 6_2     
8A7Name 7_1Name 7_2     
9A8Name 8_1Name 8_2     
10A9Name 9_1Name 9_2     
11A10Name 10_1Name 10_2     
12A11Name 11_1Name 11_2     
13A12Name 12_1Name 12_2     
14A13Name 13_1Name 13_2     
15A14Name 14_1Name 14_2     
16A15Name 15_1Name 15_2     
17A16Name 16_1Name 16_2     

Formeln der Tabelle
ZelleFormel
H2{=INDEX(A2:A17;MIN(WENN(B2:C17=H1;ZEILE(1:16))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Sepp



  

Betrifft: AW: Allternative zur überlangen Wenn-Funktion von: McFly_HL
Geschrieben am: 31.01.2010 19:55:36

Hallo Sepp,

ja das ist eig genau die Lösung die ich brauche, allerdings funktioniert die Sache nicht ... ich weiß nicht recht warum.

Wenn ich das so schreibe:

{=INDEX(A42:A54;MIN(WENN(B42:C54=E39;ZEILE(42:54)))) } Also mit Strg+Shift+Enter abschließe bekomme ich immer "#BEZUG!" ausgeworfen.

Ich muss gestehen dass ich Deine Formel nicht komplett verstanden habe, und unter dem Link:"Matrix verstehen" stand leider auch nichts was mir weitergeholfen hätte, da Deine Formel ja etwas erweitert ist.

Auszug aus Deinem Beispiel:
Zelle Formel
H2 {=INDEX(A2:A17;MIN(WENN(B2:C17=H1;ZEILE(1:16))))}

A2:A17 soll ausgeworfen werden, wenn die Felder B2:C17=H1 ist, also auch wenn der Text identisch ist.
Was ich nicht zu 100% verstanden habe ist die ZEILE(1:16) das ist wohl der Bereich in welchen Zeilenbereich verglichen werden soll?Wäre das dann nicht doppelt, und müsste es dann nicht ZEILE(2:17) heißen?
Wenn ich richtig verstanden habe was ich grad nachgelesen habe, kann man in diesem Fall die "MIN-Funktion" nicht verwenden, weil ich ja teilweise Zeilen habe in denen eine Zahl doppelt vorkommt.

Beispiel:

A3 Name 1_1 Name 1_2
A4m Name 2_1 Name 2_2
A4g Name 3_1 Name 3_2
A5 Name 4_1 Name 4_2
A6g Name 5_1 Name 5_2
A6h Name 6_1 Name 6_2

usw.

Ich würde es ja gerne so machen das ich mir die Projektnamen aus einem anderen Tabellenblatt hole, also z.B. so:

{=INDEX(Tabelle2!A1:A17;MIN(WENN(Tabelle1!B42:C54=E39;ZEILE(42:54)))) } wie müsste ich das dann mit der ZEILE machen, damit ich das richtig ausgeworfen bekomme? Und was kann ich statt der MIN-Funktion verwenden, damit die doppelten Zahlen im Bezug sich nicht behaken?

Besten dank nochmal für den guten Ansatz.

gruß Fly


  

Betrifft: AW: Allternative zur überlangen Wenn-Funktion von: Josef Ehrensberger
Geschrieben am: 31.01.2010 20:01:54

Hallo Fly,


bevor wir hier rumraten, lade doch eine Beispieldatei hoch.

Zu Zeile() das muss immer von 1 bis Anzahl Zeilen im Bereich gehen.



Gruß Sepp



Beiträge aus den Excel-Beispielen zum Thema "Allternative zur überlangen Wenn-Funktion"