Microsoft Excel

Herbers Excel/VBA-Archiv

gegenseitige Beeinflussung von dynamischer Reihe | Herbers Excel-Forum


Betrifft: gegenseitige Beeinflussung von dynamischer Reihe von: Stu
Geschrieben am: 26.01.2010 12:22:41

Hallo alle zusammen,

ich beschäftige mich mit einem Problem für das ich leider keine Lösung finden kann... Wenn jemand eine gute Idee hat bin ich superhappy :)

Das Problem ist:
-ich habe eine Zahlenfolge, in der sich jede Zelle aus dem oberen Zellwert +- einem Wert (B2:B6) bildet
-über diese Zahlenfolge bilde ich mit einem Referenzwert A ein Verhältnis
-rutscht das Verhältnis unter den Wert 0,8, wird der Zahlenfolge eine 1 aufaddiert
-dadurch verändern sich alle folgenden Stellen der Zahlenfolge und damit ihr Verhältnis

Nun gilt es eine Lösung zu finden diesen Zirkelbezug zu umgehen....

Naja ich habe hier einmal eine Beispielexceldatei hochgeladen wo ich auch das Ergebnis schonmal dargestellt habe.

https://www.herber.de/bbs/user/67498.xlsx

Tausend Dank an alle

Stu

  

Betrifft: AW: gegenseitige Beeinflussung von dynamischer Reihe von: fcs
Geschrieben am: 26.01.2010 13:10:56

Hallo Stu,

sollte wie folgt funktionieren.

Gruß
Franz

Tabelle1

 ABCD
1Referenzwert AAbzügeZahlenfolgeVerhältnis der Zahlenfolge zu Wert A
24041,00
3 041,00
4 -130,75
5 -130,75
6 -220,50

Formeln der Tabelle
ZelleFormel
C2=WENN((A2+B2)/$A$2<0,6;1;0)+A2+B2
D2=C2/A$2
C3=WENN((C2+B3)/$A$2<0,6;1;0)+C2+B3
D3=C3/A$2
C4=WENN((C3+B4)/$A$2<0,6;1;0)+C3+B4
D4=C4/A$2
C5=WENN((C4+B5)/$A$2<0,6;1;0)+C4+B5
D5=C5/A$2
C6=WENN((C5+B6)/$A$2<0,6;1;0)+C5+B6
D6=C6/A$2


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


  

Betrifft: Funktioniert von: Stu
Geschrieben am: 26.01.2010 14:44:31

Vielen Dank!!


Beiträge aus den Excel-Beispielen zum Thema "gegenseitige Beeinflussung von dynamischer Reihe"