Microsoft Excel

Herbers Excel/VBA-Archiv

Zellen markieren | Herbers Excel-Forum


Betrifft: Zellen markieren von: Melanie
Geschrieben am: 28.01.2010 09:39:36

Guten Morgen liebe Excel Genies,
kann mir jemand weiter helfen???



Der Lagerbestand wird berechnet, wenn der Lagerbestand kleiner ist als der Verbrauch soll er 500 dazu rechnen.
Nun möchte ich aber:
a) das die Zeilen markiert (farblich) werden, wenn 500 dazu gerechnet wurden und
b) wie oft er diese Zeile markiert hat.

Weiß da jemand eine Lösung?????

Vielen Dank im Voraus.

Viele verschneite Grüße Melanie

  

Betrifft: AW: Zellen markieren von: Reinhard
Geschrieben am: 28.01.2010 10:04:44

Hallo Melanie,

"=Wenn(B1>A3;B1-A3;A3+$C$1)"

ergibt bei mir 510.

Und b) verstehe ich genausowenig.

Gruß
Reinhard


  

Betrifft: AW: Zellen markieren von: Melanie
Geschrieben am: 28.01.2010 10:13:21

Der Anfangsbestand ist 650 -10= 640, kann man leider nicht sehen.

Allerdings sollen alle Felder die Später kommen und 500 dazu gerechnet werden farblich markiert werden und dann brauche ich eine Formel in der berechnet wird wie oft eine Zeile farblich ist.

Vielen Dank!!


  

Betrifft: AW: Zellen markieren von: Reinhard
Geschrieben am: 28.01.2010 10:24:41

Hallo Melanie,

ohne Farben sehe das Formelmäßig bei mir so aus:

Tabellenblatt: [Mappe1]!Tabelle1
  │     A     │    B    │  C  │
--┼-----------┼---------┼-----┼
1 │ Verbrauch │ Bestand │ 500 │
--┼-----------┼---------┼-----┼
2 │ Übertrag  │     650 │     │
--┼-----------┼---------┼-----┼
3 │        10 │     640 │     │
--┼-----------┼---------┼-----┼
4 │       500 │     640 │     │
--┼-----------┼---------┼-----┼
5 │        10 │     630 │     │
--┼-----------┼---------┼-----┼
6 │        25 │     605 │     │
--┼-----------┼---------┼-----┼
7 │        30 │     575 │     │
--┼-----------┼---------┼-----┼
8 │        25 │     550 │     │
--┼-----------┼---------┼-----┼
9 │        25 │     525 │     │
--┴-----------┴---------┴-----┴
Benutzte Formeln:
B3: =B2-A3+$C$1*(A3>B2-A3)
B4: =B3-A4+$C$1*(A4>B3-A4)
B5: =B4-A5+$C$1*(A5>B4-A5)
B6: =B5-A6+$C$1*(A6>B5-A6)
B7: =B6-A7+$C$1*(A7>B6-A7)
B8: =B7-A8+$C$1*(A8>B7-A8)
B9: =B8-A9+$C$1*(A9>B8-A9)

A1:C9
haben das Zahlenformat: Standard

Gruß
Reinhard


  

Betrifft: AW: Zellen markieren von: hary
Geschrieben am: 28.01.2010 10:53:11

Hallo Melanie
mit Hilfsspalte ?? Dann kannst Du zaehlen und die bedingte Formatierung auch auf die Hilfsspalte(ausblenden) beziehen.


Tabelle1

 ABCDE
1      500 
2  650     
310640    2
4500140     
510130     
61356351   
730605     
8100505     
925480     
104909901   

verwendete Formeln
Zelle Formel
C2 =WENN((A2+$D$1)=B2;1;"")
B3 =WENN(B2>A3;B2-A3;A3+$D$1)
C3 =WENN((A3+$D$1)=B3;1;"")
E3 =ZÄHLENWENN(C2:C10;1)
B4 =WENN(B3>A4;B3-A4;A4+$D$1)
C4 =WENN((A4+$D$1)=B4;1;"")
B5 =WENN(B4>A5;B4-A5;A5+$D$1)
C5 =WENN((A5+$D$1)=B5;1;"")
B6 =WENN(B5>A6;B5-A6;A6+$D$1)
C6 =WENN((A6+$D$1)=B6;1;"")
B7 =WENN(B6>A7;B6-A7;A7+$D$1)
C7 =WENN((A7+$D$1)=B7;1;"")
B8 =WENN(B7>A8;B7-A8;A8+$D$1)
C8 =WENN((A8+$D$1)=B8;1;"")
B9 =WENN(B8>A9;B8-A9;A9+$D$1)
C9 =WENN((A9+$D$1)=B9;1;"")
B10 =WENN(B9>A10;B9-A10;A10+$D$1)
C10 =WENN((A10+$D$1)=B10;1;"")

Tabellendarstellung in Foren


gruss hary


  

Betrifft: AW: Zellen markieren von: Melanie
Geschrieben am: 28.01.2010 11:38:14

Hallo Hary,

vielen dank für die Antwort, mit einer kleinen Veränderung hat es geklappt, aber Deine Hilfe, war der dicke Stein, den ich für die Lösung brauchte. DANKE!!!!


Beiträge aus den Excel-Beispielen zum Thema "Zellen markieren"