Microsoft Excel

Herbers Excel/VBA-Archiv

Tipptabelle Punkte rechnen | Herbers Excel-Forum


Betrifft: Tipptabelle Punkte rechnen von: stutze
Geschrieben am: 29.01.2010 21:24:40

Hallo,

ich weiß, dass hier schon enige Beiträge, bezüglich meines Anliegens, gelaufen sind.
Habe schon längere Zeit diese Formel:
=WENN($M11="";"0";((($G11<>"")+($I11<>""))>0)*((VORZEICHEN($G11-$I11) =VORZEICHEN(M11-O11))*1+(($G11-$I11)=(M11-O11))*1+(($G11=M11)*($I11=O11))*1))
M und O ist der Tip
G und I das Ergebnis
Die Formel klappt auch wunderbar, jedoch will ich die Punkteverteilung ändern. Und zwar wie folgt:
Ergebnis: 2:1 Tip: 2:1 Punkte: 5 stimmt voll überein
Ergebnis: 2:1 Tip: 3:1 Punkte: 2 Tendenz stimmt
Ergebnis: 2:1 Tip: 1:2 Punkte: 0 keine Übereinstimmung
Ergebnis: 2:2 Tip: 2:2 Punkte: 5 Unentschieden stimmt voll überein
Ergebnis: 2:2 Tip: 1:1 Punkte: 3 Untentschieden stimmt "teilweise"

Könnte mir da jemand helfen, diese Verteilung in Form einer neuen Formel oder abändern meiner bestehenden hin zu bekommen?

Danke

  

Betrifft: AW: Tipptabelle Punkte rechnen von: joerg
Geschrieben am: 29.01.2010 21:44:00

Hallo,

Und was wäre zB bei Ergebnis 3:3, Tip 1:1? Oder Ergebnis 1:0. Tip 0:0?

Bzw noch besser: Kannst du definieren, was 'Tendenz stimmt' bedeutet? Und wie sich 'stimmt teilweise' von der Bedeutung her davon unterscheidet?

Gruss,
Jo


  

Betrifft: AW: Tipptabelle Punkte rechnen von: stutze
Geschrieben am: 29.01.2010 21:54:06

  • Tendenz: Sieg der gewonnenen Mannschaft getippt, jedoch nicht übereinstimmend mit dem eigentlichen Ergbnis
  • Unentschieden "teilweise": Tip und Ergebnis ist zwar unentschieden, jedoch weicht der Tip vom Ergebnis ab


  • Meine Ergebnisse und Tips sind nur Beisiele. Genauso könnte ich sagen, anhand deiner Frage:
    Ergebnis 1:0 Tip 0:0 sind dann Punkte: 0. Stimmt nichts überein. Weder Tendenz, noch Sieg, noch Unentschieden.

    stutze


      

    Betrifft: AW: Tipptabelle Punkte rechnen von: joerg
    Geschrieben am: 29.01.2010 22:03:07

    Probier mal:

    =WENN($M11="";0;WENN(UND($M11=$G11;$O11=$I11);5;WENN(UND($M11=$O11;$G11=$I11);3;WENN(VORZEICHEN( _
    $M11-$O11)=VORZEICHEN($G11-$I11);2;0))))
    
    ...Ist zwar ein bisschen brachial & geht womöglich eleganter, aber müsste funktionieren...

    Gruss,
    Jo


      

    Betrifft: AW: Tipptabelle Punkte rechnen von: stutze
    Geschrieben am: 29.01.2010 22:14:11

    DANKE
    eleganter kann ich es mir kaum vorstellen. Kaum länger als meine usprüngliche Formel, kann aber dafür mehr.
    Nochmals DANKE

    stutze


      

    Betrifft: elegant - na ja von: WF
    Geschrieben am: 30.01.2010 03:16:26

    siehe:
    http://www.excelformeln.de/formeln.html?welcher=40

    Salut WF


      

    Betrifft: AW: elegant - na ja von: stutze
    Geschrieben am: 02.02.2010 20:17:42

    Ich nochmal. Wie ich schon sagte, war die Formel perfekt. Perfekt für mich. Jetzt haben wir heiß diskutiert und ich soll mal fragen ob es auch mögliches folgendes in die Formel zu bekommen (Tips sind Beispiele).
    Ergebnis 1:1 Tip 1:1 Punkte 5 - richtiges unentschieden
    Ergebnis 1:1 Tip 0:0 Punkte 3 - falsches unentschieden
    Ergebnis 2:1 Tip 2:1 Punkte 5 - richtiges Ergebnis
    Ergebnis 2:1 Tip 2:0 Punkte 2 - nur Tendenz stimmt
    Ergebnis 2:1 Tip 4:3 Punkte 3 - Tendenz stimmt, aber auch die Differenz von 2-1=1 bzw. 4-3=1

    zum letzten Bsp.: wenn die Differenz vom Ergebnis gleich der Differenz vom Tip ist, dann 3 Punkte. Das Problem wird aber sein, dass das richtige unentschieden auch da mit reinzählt.

    Gruß
    stutze


      

    Betrifft: da musst Du nur den letzten Teil streichen von: WF
    Geschrieben am: 02.02.2010 20:53:55

    Hi,

    also:
    =(C1<>"")*(D1<>"")*(A1=C1)*(B1=D1)*2+(A1-B1-C1+D1=0)*1+(VORZEICHEN(A1-B1)=(VORZEICHEN(C1-D1)))*2

    Salut WF


    http://www.excelformeln.de/
    die ultimative Formelseite


    Beiträge aus den Excel-Beispielen zum Thema "Tipptabelle Punkte rechnen"