Microsoft Excel

Herbers Excel/VBA-Archiv

PLZ auswerten | Herbers Excel-Forum


Betrifft: PLZ auswerten von: Frank W.
Geschrieben am: 31.01.2010 16:02:04

Hallo zusammen,

in einer Tabelle stehen ca. 20.000 Kundeneinträge incl. einer PLZ. Die PLZ steht dabei im Bereich K5:K20000.
Jetzt soll ich diese PLZ auswerten nach der ersten Ziffer der PLZ (also alle PLZ mit 0 , 1, 2 usw).

Wie kann ich das am besten anstellen? Zählenwenn kriege ich nicht auf die Reihe, weil ich ja nur nach einer Ziffer zählen soll.

Vielen Dank !

Gruß
Frank W.

  

Betrifft: AW: PLZ auswerten von: Hajo_Zi
Geschrieben am: 31.01.2010 16:08:28

Hallo Frank,

ich hätte es mit SummenProdukt() und Links() versucht.

GrußformelHomepage


  

Betrifft: AW: PLZ auswerten von: Frank W.
Geschrieben am: 31.01.2010 16:12:10

Hallo Hajo,

sorry, das hilft mir nicht weiter. Wie meinst Du das?


  

Betrifft: AW: PLZ auswerten von: Hajo_Zi
Geschrieben am: 31.01.2010 16:17:06

Hallo Frank,


Tabelle1

 ABCDE
1Gränitz09636  mit 09
2Lichtenberg09638  mit 13
3Mittweida09641     
4Mittweida09642     
5Altmittweida09648     
6Hainichen09657     
7Arnsdorf09661     
8Frankenberg09665     
9Dittersbach09669     
10Berlin10001     
11Berlin10002     
12Berlin10003     

verwendete Formeln
Zelle Formel
E1 =SUMMENPRODUKT((LINKS(B1:B12;1)=RECHTS(D1;1))*1)
E2 =SUMMENPRODUKT((LINKS(B2:B13;1)=RECHTS(D2;1))*1)

Tabellendarstellung in Foren Version 5.6



GrußformelHomepage


  

Betrifft: Super, danke für die Formel von: Frank W.
Geschrieben am: 31.01.2010 17:47:26




Beiträge aus den Excel-Beispielen zum Thema "PLZ auswerten"