Microsoft Excel

Herbers Excel/VBA-Archiv

Feld auffüllen | Herbers Excel-Forum

  • Feld auffüllen von MarkusL vom 04.02.2010 11:40:06
    • ??? - von Ramses am 04.02.2010 11:45:55
      • AW: ??? - von MarkusL am 04.02.2010 11:55:27
        • Verweis - von Matthias5 am 04.02.2010 12:08:44
        • AW: ??? - von Ramses am 04.02.2010 12:10:38
        • AW: ??? - von MarkusL am 04.02.2010 12:17:55


Betrifft: Feld auffüllen von: MarkusL
Geschrieben am: 04.02.2010 11:40:06

Hallo ,

ich habe nachfolgende Tabelle:

Zeile Feld1 Feld2 Feld3
1___KSNR_020
2___PENR_1000
3___PENR_1009
4___PENR_1010
5___KSNR_030
6___PENR_2510
7___PENR_2511
8___KSNR_040
....

Das Feld3 soll bei Feld1 PENR mit dem letzten Wert von Feld1 KSNR gefüllt werden.

ERGEBNIS:
Zeile Feld1 Feld2 Feld3
1___KSNR_020
2___PENR_1000_020
3___PENR_1009_020
4___PENR_1010_020
5___KSNR_030
6___PENR_2510_030
7___PENR_2511_030
8___KSNR_040

Hat jemand einen Vorschlag wir man dieses mit einer Formel lösen kann?

MarkusL

  

Betrifft: ??? von: Ramses
Geschrieben am: 04.02.2010 11:45:55

Hallo

Was verstehst du unter Feld 3 ?
In deinem Beispiel sieht es so aus, als ob der Wert "PENR_1000_020" in einer Zelle steht ?
Nach deiner Frage solle aber nur der Wert "020" in der dritten Zelle stehen.

Was willst du nun genau ?

Gruss Rainer


  

Betrifft: AW: ??? von: MarkusL
Geschrieben am: 04.02.2010 11:55:27

Feld1 bis Feld3 sind einzelene Spalten. In Spalte 3 soll das Ergebnis stehen.

Gruß
MarkusL


  

Betrifft: Verweis von: Matthias5
Geschrieben am: 04.02.2010 12:08:44

Hallo Rainer,

=WENN(A2="PENR";VERWEIS(2;1/(A$2:A2="KSNR");B$2:B2);"")

Tabelle1

 ABC
1Feld1Feld2Feld3
2KSNR20 
3PENR100020
4PENR100920
5PENR101020
6KSNR30 
7PENR251030
8PENR251130
9KSNR40 

verwendete Formeln
Zelle Formel
C2 =WENN(A2="PENR";VERWEIS(2;1/(A$2:A2="KSNR");B$2:B2);"")

Tabellendarstellung in Foren Version 4.8

Gruß,
Matthias


  

Betrifft: AW: ??? von: Ramses
Geschrieben am: 04.02.2010 12:10:38

Hallo

meinst du so ?

Tabelle3

 ABC
1KSNR20 
2PENR100020
3PENR100920
4PENR101020
5KSNR30 
6PENR251030
7PENR251130
8KSNR40 
9PENR101040
10PENR101140

Formeln der Tabelle
ZelleFormel
C2=WENN(A2="KSNR";"";WENN(A1="KSNR";B1;C1))
C3=WENN(A3="KSNR";"";WENN(A2="KSNR";B2;C2))
C4=WENN(A4="KSNR";"";WENN(A3="KSNR";B3;C3))
C5=WENN(A5="KSNR";"";WENN(A4="KSNR";B4;C4))
C6=WENN(A6="KSNR";"";WENN(A5="KSNR";B5;C5))
C7=WENN(A7="KSNR";"";WENN(A6="KSNR";B6;C6))
C8=WENN(A8="KSNR";"";WENN(A7="KSNR";B7;C7))
C9=WENN(A9="KSNR";"";WENN(A8="KSNR";B8;C8))
C10=WENN(A10="KSNR";"";WENN(A9="KSNR";B9;C9))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruss Rainer


  

Betrifft: AW: ??? von: MarkusL
Geschrieben am: 04.02.2010 12:17:55

Danke!