Microsoft Excel

Herbers Excel/VBA-Archiv

Summe wenn Suchkriterien erfüllt | Herbers Excel-Forum


Betrifft: Summe wenn Suchkriterien erfüllt von: Günni
Geschrieben am: 04.02.2010 12:39:47

Mahlzeit!

Gegeben ist folgende Tabelle:

A1 = 10 und B1 =100
A2 = 20 und B2 = 110
A3 = 10 und B3 = 120
A4 = 50 und B4 = 130
A5 = 10 und B5 = 140
A6 = 50 und B6 = 150
A7 = 20 und B7 = 160

In D1 (=10) und D2 (=50) stehen die Suchkriterien aus denen in B8 nun die Summe ausgewiesen werden soll. Es sollen nur die Zeilen addiert werden, bei denen in Spalte A 10 oder 50 steht.

Wie löse ich das?

  

Betrifft: AW: Summe wenn Suchkriterien erfüllt von: Josef Ehrensberger
Geschrieben am: 04.02.2010 12:43:47

Hallo Günni,


das geht z.B. so.



Tabelle2

 ABCDEFG
110100 1050550 
220110     
310120     
450100     
530130     
620100     
710120     
850110     
9       

Formeln der Tabelle
ZelleFormel
F1=SUMMENPRODUKT((A1:A8=D1)+(A1:A8=E1); B1:B8)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



Gruß Sepp



  

Betrifft: AW: Summe wenn Suchkriterien erfüllt von: Günni
Geschrieben am: 04.02.2010 12:58:44

Was mache ich wenn die Angaben in Spalte A als Text formatiert sind, da es ein SAP-Download ist. Wollte nicht extra eine Hilfsspalte einfügen.


  

Betrifft: Formatier D1 & D2 auch als Text! (owT) von: Renee
Geschrieben am: 04.02.2010 13:03:54




  

Betrifft: AW: Summe wenn Suchkriterien erfüllt von: Hajo_Zi
Geschrieben am: 04.02.2010 12:44:31

Hallo Günni,

2x Summewenn()

GrußformelHomepage


  

Betrifft: Mit einem einfachen Summenprodukt.. von: Renee
Geschrieben am: 04.02.2010 12:45:55

Günni,

=SUMMENPRODUKT(ODER(A1:A7=$D$1;A1:A7=$D$2))*(B1:B7))
GreetZ Renée


  

Betrifft: sorry, quatsch mit sauce... von: Renee
Geschrieben am: 04.02.2010 13:01:57


2 x Summeprodukt (...nicht ODER!)

=SUMMENPRODUKT((A1:A7=D1)*(B1:B7))+SUMMENPRODUKT((A1:A7=D2)*(B1:B7))

oder nach Hajo 2 x Summewenn
=SUMMEWENN(A1:A7;D1;B1:B7)+SUMMEWENN(A1:A7;D2;B1:B7)

oder nach Sepp
=SUMMENPRODUKT(((A1:A7=D1)+(A1:A7=D2))*(B1:B7))
GreetZ Renée


  

Betrifft: OK - hast mich also ausgebremst :-) von: WF
Geschrieben am: 04.02.2010 13:12:54

Hi Renée,

das wollte ich gerade abschicken:
lady: "ODER" und "UND" funktionieren nicht in Arrays.

Salut WF


  

Betrifft: aber statt ODER + und statt UND * ;-) (owT) von: Renee
Geschrieben am: 04.02.2010 13:15:56




  

Betrifft: Die einfachste Lösung von: Rudi Maintaire
Geschrieben am: 04.02.2010 12:46:10

Hallo,
=SUMMEWENN(A1:A7;D1;B1:B7)+SUMMEWENN(A1:A7;D2;B1:B7)

Gruß
Rudi


  

Betrifft: AW: Die einfachste Lösung von: Günni
Geschrieben am: 04.02.2010 13:07:08

das ist echt das beste. danke


  

Betrifft: =SUMMENPRODUKT((A1:A7=N(INDIREKT({"D1"."D2"})))*(B von: NoNet
Geschrieben am: 04.02.2010 23:12:12

Hallo Günni,

hier noch ein Lösungsvorschlag :

=SUMMENPRODUKT((A1:A7=N(INDIREKT({"D1"."D2"})))*(B1:B7))

Falls die "Werte" in Spalte A Texte sind, dann :

=SUMMENPRODUKT((A1:A7=T(INDIREKT({"D1"."D2"})))*(B1:B7))

Gruß, NoNet


Beiträge aus den Excel-Beispielen zum Thema "Summe wenn Suchkriterien erfüllt"