Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

OP-Liste - gewichtetes Alter u Ältester auswerten

OP-Liste - gewichtetes Alter u Ältester auswerten
Peter
Guten Tag
Zu meiner OP-Liste möchte ich gerne zusätzliche Auswertungen mit Formeln errechnen, wie in der Beispieldatei [ https://www.herber.de/bbs/user/70880.xls ], resp. in der untenstehenden Darstellung aufgezeigt.
A) wie kann ich die Zellen F22, G22 und H22 mit einer Formel bestimmen?
B) Gibt es eine Möglichkeit, das gewichtete Alter der OPs ohne die Hilfsspalten J, K und L zu berechnen? Wenn ja, wie?
Bin für jeden Hinweis dankbar!
Gruss, Peter
Tabelle1

 ABCDEFGHIJKL
2DatumKundeBetragkum 131719 131719
3            
4OP - Liste    OP - Liste auf Kunden aufgeteilt   Berechnung mittleres Alter  
5            
6            
731.08.200913100100 10000 4005600  
815.10.200919200300 1000200   8020200
911.12.20091350350 1500200 2007900  
1003.01.2010177001050 150700200  28126700 
1105.01.2010192201270 150700420   8840260
1219.01.201013801350 230700420 3215760  
1317.02.2010191151465 230700535   4625990
14            
15Total        92292602812670021486450
16geteilt durch        230700535
17gewichtetes Alter        10.11.200903.01.201014.12.2009
18            
19Anteil in %    15.7%47.8%36.5%    
20Rang    312    
21Ältester Ausstand    31.08.200903.01.201015.10.2009    
22Gewichtetes Alter    10.11.200903.01.201014.12.2009    

Formeln der Tabelle
ZelleFormel
D7=D6+C7
F7=WENN(F$2=$B7;F6+$C7;F6)
G7=WENN(G$2=$B7;G6+$C7;G6)
H7=WENN(H$2=$B7;H6+$C7;H6)
J7=WENN(J$2=$B7;($A7)*$C7;"")
K7=WENN(K$2=$B7;($A7)*$C7;"")
L7=WENN(L$2=$B7;($A7)*$C7;"")
D8=D7+C8
F8=WENN(F$2=$B8;F7+$C8;F7)
G8=WENN(G$2=$B8;G7+$C8;G7)
H8=WENN(H$2=$B8;H7+$C8;H7)
J8=WENN(J$2=$B8;($A8)*$C8;"")
K8=WENN(K$2=$B8;($A8)*$C8;"")
L8=WENN(L$2=$B8;($A8)*$C8;"")
D9=D8+C9
F9=WENN(F$2=$B9;F8+$C9;F8)
G9=WENN(G$2=$B9;G8+$C9;G8)
H9=WENN(H$2=$B9;H8+$C9;H8)
J9=WENN(J$2=$B9;($A9)*$C9;"")
K9=WENN(K$2=$B9;($A9)*$C9;"")
L9=WENN(L$2=$B9;($A9)*$C9;"")
D10=D9+C10
F10=WENN(F$2=$B10;F9+$C10;F9)
G10=WENN(G$2=$B10;G9+$C10;G9)
H10=WENN(H$2=$B10;H9+$C10;H9)
J10=WENN(J$2=$B10;($A10)*$C10;"")
K10=WENN(K$2=$B10;($A10)*$C10;"")
L10=WENN(L$2=$B10;($A10)*$C10;"")
D11=D10+C11
F11=WENN(F$2=$B11;F10+$C11;F10)
G11=WENN(G$2=$B11;G10+$C11;G10)
H11=WENN(H$2=$B11;H10+$C11;H10)
J11=WENN(J$2=$B11;($A11)*$C11;"")
K11=WENN(K$2=$B11;($A11)*$C11;"")
L11=WENN(L$2=$B11;($A11)*$C11;"")
D12=D11+C12
F12=WENN(F$2=$B12;F11+$C12;F11)
G12=WENN(G$2=$B12;G11+$C12;G11)
H12=WENN(H$2=$B12;H11+$C12;H11)
J12=WENN(J$2=$B12;($A12)*$C12;"")
K12=WENN(K$2=$B12;($A12)*$C12;"")
L12=WENN(L$2=$B12;($A12)*$C12;"")
D13=D12+C13
F13=WENN(F$2=$B13;F12+$C13;F12)
G13=WENN(G$2=$B13;G12+$C13;G12)
H13=WENN(H$2=$B13;H12+$C13;H12)
J13=WENN(J$2=$B13;($A13)*$C13;"")
K13=WENN(K$2=$B13;($A13)*$C13;"")
L13=WENN(L$2=$B13;($A13)*$C13;"")
J15=SUMME(J7:J14)
K15=SUMME(K7:K14)
L15=SUMME(L7:L14)
J16=F13
K16=G13
L16=H13
J17=J15/J16
K17=K15/K16
L17=L15/L16
F19=F13/$D13
G19=G13/$D13
H19=H13/$D13
F20=RANG(F19;19:19)
G20=RANG(G19;19:19)
H20=RANG(H19;19:19)
F22=J17
G22=K17
H22=L17


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: OP-Liste - gewichtetes Alter u Ältester auswerten
04.08.2010 10:44:12
Matthias5
Hallo Peter,
meinst du das so?
Tabelle1
 ABCDEFGH
1DatumCodeBetragkumuliert  131719
2               
331.08.200913100100  10000
415.10.200919200300  1000200
511.12.20091350350  1500200
603.01.2010177001050  150700200
705.01.2010192201270  150700420
819.01.201013801350  230700420
917.02.2010191151465  230700535
10               
11Total             
12geteilt durch             
13gewichtetes Alter             
14               
15Anteil in %        15,7%47,8%36,5%
16Rang        312
17Ältester Ausstand        31.08.200903.01.201015.10.2009
18Gewichtetes Alter        10.11.200903.01.201014.12.2009

verwendete Formeln
Zelle Formel
D3 =D2+C3
F3 =WENN(F$1=$B3;F2+$C3;F2)
G3 =WENN(G$1=$B3;G2+$C3;G2)
H3 =WENN(H$1=$B3;H2+$C3;H2)
F15 =F9/$D9
G15 =G9/$D9
H15 =H9/$D9
F16 =RANG(F15;15:15)
G16 =RANG(G15;15:15)
H16 =RANG(H15;15:15)
F17 =INDEX($A3:$A9;VERGLEICH(F1;$B3:$B9;0))
G17 =INDEX($A3:$A9;VERGLEICH(G1;$B3:$B9;0))
H17 =INDEX($A3:$A9;VERGLEICH(H1;$B3:$B9;0))
F18 =SUMMENPRODUKT(($B3:$B9=F1)*$C3:$C9*$A3:$A9)/F9
G18 =SUMMENPRODUKT(($B3:$B9=G1)*$C3:$C9*$A3:$A9)/G9
H18 =SUMMENPRODUKT(($B3:$B9=H1)*$C3:$C9*$A3:$A9)/H9

Tabellendarstellung in Foren Version 4.8

Gruß,
Matthias
Anzeige
OT: Aus welchem Versteck kommst Du denn gekrochen
04.08.2010 11:01:12
NoNet
Moin Matthias,
schön, dass man Dich auch mal wieder liest - ist ja eine absolute Rarität geworden :-))
Salut, NoNet
OT: Von draus vom Walde...
04.08.2010 11:05:16
Matthias5
Hi NoNet,
stimmt, ist 'ne Ewigkeit her. Aber schön, dass man noch erkannt wird. Und dann gleich noch ein "Moin", dass ich inzwischen ja auch nur noch selten höre. Schööön! :-)
Viele Grüße,
Matthias
AW: OP-Liste - gewichtetes Alter u Ältester auswerten
04.08.2010 11:33:41
Peter
Hallo Matthias
Genau so! Super! Vielen Dank!
Gruss, Peter
Super! :-)
04.08.2010 11:40:35
Matthias5
Hallo Peter,
freut mich! Den ältestens Ausstand kannst du übrigens auch so ermitteln: =VERWEIS(F1;$B3:$B9;$A3:$A9)
Viele Grüße,
Matthias

338 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige