Formula



Excel-Version: 97
nach unten

Betrifft: Formula
von: Alfred
Geschrieben am: 08.05.2002 - 17:15:40

Hallo,
ich möchte mit VB / Formula eine Formel in z.B Zelle B1 schreiben, die folgendes bewirken soll: Zelle B1 = Text aus A1 zwischen den Zeichen '<' bis '>'.

Würde mich freuen, wenn mir da jemand helfen kann.

Gruß
Alfred

nach oben   nach unten

Re: Formula
von: MRR
Geschrieben am: 08.05.2002 - 18:09:21

Meinst Du so etwas:
=TEIL(A1;FINDEN("<";A1)+1;LÄNGE(A1)-FINDEN(">";A1)-1)
Matthias
nach oben   nach unten

Klappt noch nicht ganz
von: Alfred
Geschrieben am: 08.05.2002 - 19:10:18

Hallo Matthias,
der Anfang ist schon mal prima.

Aus '12<345>67890' macht er '345>'. Das Ende findet die Formel noch nicht richtig.

Kann mir da nochmal jemand helfen?

Gruß
Alfred


nach oben   nach unten

Aber so ...
von: Volker Croll
Geschrieben am: 08.05.2002 - 19:37:30

Hallo Alfred,

=TEIL(A1;FINDEN("<";A1)+1;FINDEN(">";A1)-(FINDEN("<";A1)+1))

Gruss Volker


nach oben   nach unten

Super; Zusatzfrage
von: Alfred
Geschrieben am: 09.05.2002 - 08:03:09

Hallo Volker,
die Formel ist perfekt. Jetzt habe ich gerade gemerkt, daß die Zelle auch leer sein kann. In diesem Falle kommt der Fehler #Wert!. Kann man diesen auch noch ausblenden?

Vielen Dank für die Hilfe
Gruß Alfred


nach oben   nach unten

Re: Super; Zusatzfrage
von: Sigi E.
Geschrieben am: 09.05.2002 - 11:00:26

Hallo Alfred,

die Formel liefert #Wert wenn in A1 die Zeichen "<" oder ">"
nicht vorhanden sind oder wenn A1 leer ist. Deine Formel muß
daher diese Fälle mit abprüfen:

"=WENN(ODER(ISTFEHLER(FINDEN("<";A1));ISTFEHLER(FINDEN(">";A1)));
"Sorry, geht so nicht!";
TEIL(A1;FINDEN("<";A1)+1;FINDEN(">";A1)-(FINDEN("<";A1)+1)))"

Gruß
Sigi

nach oben   nach unten

Re: Super; Zusatzfrage
von: Volker Croll
Geschrieben am: 09.05.2002 - 11:18:42

Hallo Alfred,

=WENN(A1="";"";TEIL(A1;FINDEN("<";A1)+1;FINDEN(">";A1)-(FINDEN("<";A1)+1)))

Gruss Volker


nach oben   nach unten

Kann man auch anders sehen ...
von: Volker Croll
Geschrieben am: 09.05.2002 - 11:26:04

Hallo Alfred, hallo Sigi,

sorry war gerade offline und hatte meine Antwort abgeschickt, bevor ich meinen Browser nochmals aktualisiert hatte.

Die fehlenden "<" und ">" sind mir auch durch den Kopf gegangen, habe sie aber bewusst nicht abgefangen.
Gehe davon aus, dass, wenn Daten vorhanden sind, diese ein "<" uns ">" muessten. Somit wuerden falsche Ausgangsdaten sofort auffallen.

Ist aber von der konkreten Situation anhaengig; Alfred hat ja jetzt die Auswahl.

Gruss Volker


nach oben   nach unten

Vielen Dank
von: Alfred
Geschrieben am: 10.05.2002 - 15:47:25

Vielen Dank für die Hilfe.

Gibt es da irgendwo eine Übersicht dieser Formeln. Möchte mich gerne mal schlauer über die Möglichkeiten machen.

Gruß
Alfred


nach oben   nach unten

Online-Hilfe / (Taschen-)Bücher / CD von Hans
von: Volker Croll
Geschrieben am: 10.05.2002 - 16:29:13

Hallo Alfred,

der erste Klick sollte immer der auf's Fragezeichen sein - die Excel-Online-Hilfe.
Zugegeben nicht immer optimal formuliert, aber schon sehr brauchbar.

Ansonsten gibt's auch gute und guenstige Taschenbuecher. Stoebere doch mal in der Mittagspause oder nach Feierabend in einer Buchhandlung.

Der beste Tipp (wenn auch nicht ganz zum Preis eines Taschenbuches) ist die CD von Hans:
http://www.excel-cd.de/bestellung.htm
Aber dieses Geld ist sehr, sehr gut angelegt.

Schoenes Wochenende!

Gruss Volker

nach oben   nach unten

Re: Online-Hilfe / (Taschen-)Bücher / CD von Hans
von: Alfred
Geschrieben am: 10.05.2002 - 18:04:56

Hallo Volker,
die Online-Hilfe habe ich bemüht, doch nichts konkretes gefunden. Die Onlinehilfe bietet mit nur 0815 Info. Die CD von Hans habe ich diesbezüglich nicht angeschaut. Wenn da was drauf ist, war das ein guter Tip. Ich sehe gleich mal nach.
Gruß
Alfred

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Formula"