Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1184to1188
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zahlenwerte per Formel absteigend sortieren

Zahlenwerte per Formel absteigend sortieren
Fritz_W
Hallo Forumsbesucher,
ich bitte um Hilfe in folgender Angelegenheit:
In meiner Tabelle stehen in der Spalte A (A2:A2001) unsortiert Zahlenwerte (die gleiche Zahl kann dabei mehrfach vorkommen). Ich möchte diese Zahlen nun in der Spalte B ab Zelle B2 absteigend aufgelistet haben, wobei jede Zahl in der Häufigkeit aufgeführt werden soll, in der diese im Zellbereich (A2:A2001) vorkommt.
Ist das per kopierfähiger Formel möglich?
Im Voraus besten Dank für eure Unterstützung
mfg
Fritz
AW: Zahlenwerte per Formel absteigend sortieren
11.11.2010 13:36:24
Hajo_Zi
Hallo Fritz,
Tabelle1
 ABC
1213
2224
3131
4141
5551
6771
7881
81   
93   
104   
112   
122   
132   

verwendete Formeln
Zelle Formel Bereich
B1 =MIN(A:A) 
C1 =WENN(B1="";"";ZÄHLENWENN(A1:A1000;B1)) 
B2 {=WENN(ODER(B1=MAX(A1:A100);B1="");"";MIN(WENN(A1:A1000>B1;A1:A1000)))} $B$2
C2 =WENN(B2="";"";ZÄHLENWENN(A2:A1001;B2)) 
B3 {=WENN(ODER(B2=MAX(A2:A101);B2="");"";MIN(WENN(A2:A1001>B2;A2:A1001)))} $B$3
C3 =WENN(B3="";"";ZÄHLENWENN(A3:A1002;B3)) 
B4 {=WENN(ODER(B3=MAX(A3:A102);B3="");"";MIN(WENN(A3:A1002>B3;A3:A1002)))} $B$4
C4 =WENN(B4="";"";ZÄHLENWENN(A4:A1003;B4)) 
B5 {=WENN(ODER(B4=MAX(A4:A103);B4="");"";MIN(WENN(A4:A1003>B4;A4:A1003)))} $B$5
C5 =WENN(B5="";"";ZÄHLENWENN(A5:A1004;B5)) 
B6 {=WENN(ODER(B5=MAX(A5:A104);B5="");"";MIN(WENN(A5:A1004>B5;A5:A1004)))} $B$6
C6 =WENN(B6="";"";ZÄHLENWENN(A6:A1005;B6)) 
B7 {=WENN(ODER(B6=MAX(A6:A105);B6="");"";MIN(WENN(A6:A1005>B6;A6:A1005)))} $B$7
C7 =WENN(B7="";"";ZÄHLENWENN(A7:A1006;B7)) 
B8 {=WENN(ODER(B7=MAX(A7:A106);B7="");"";MIN(WENN(A7:A1006>B7;A7:A1006)))} $B$8
C8 =WENN(B8="";"";ZÄHLENWENN(A8:A1007;B8)) 
B9 {=WENN(ODER(B8=MAX(A8:A107);B8="");"";MIN(WENN(A8:A1007>B8;A8:A1007)))} $B$9
C9 =WENN(B9="";"";ZÄHLENWENN(A9:A1008;B9)) 
B10 {=WENN(ODER(B9=MAX(A9:A108);B9="");"";MIN(WENN(A9:A1008>B9;A9:A1008)))} $B$10
C10 =WENN(B10="";"";ZÄHLENWENN(A10:A1009;B10)) 
B11 {=WENN(ODER(B10=MAX(A10:A109);B10="");"";MIN(WENN(A10:A1009>B10;A10:A1009)))} $B$11
C11 =WENN(B11="";"";ZÄHLENWENN(A11:A1010;B11)) 
B12 {=WENN(ODER(B11=MAX(A11:A110);B11="");"";MIN(WENN(A11:A1010>B11;A11:A1010)))} $B$12
C12 =WENN(B12="";"";ZÄHLENWENN(A12:A1011;B12)) 
B13 {=WENN(ODER(B12=MAX(A12:A111);B12="");"";MIN(WENN(A12:A1011>B12;A12:A1011)))} $B$13
C13 =WENN(B13="";"";ZÄHLENWENN(A13:A1012;B13)) 
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.30



Anzeige
AW: Zahlenwerte per Formel absteigend sortieren
11.11.2010 14:10:26
Fritz_W
Hallo Hajo,
vielen Dank für deine Unterstützung.
Aufgrund der Darstellung vermute ich, dass du mich missverstanden hast.
Ich wollte die Sortierung absteigend, beginnend mit Zeile 2.
Wenn es so sein sollte und es nicht viele Umstände macht, wäre ich froh, wenn Du die Formeln anpassen würdest.
mfg
Fritz
AW: Zahlenwerte per Formel absteigend sortieren
11.11.2010 14:12:38
Hajo_Zi
Hallo Fritz,
wo ist den da das Problem noch leere Zeile einzufügen.
Tabelle1
 ABC
12   
2213
3124
4131
5541
6751
7871
8181
93   
104   
112   
122   
132   

verwendete Formeln
Zelle Formel Bereich
B2 =MIN(A:A) 
C2 =WENN(B2="";"";ZÄHLENWENN(A1:A1000;B2)) 
B3 {=WENN(ODER(B2=MAX(A1:A100);B2="");"";MIN(WENN(A1:A1000>B2;A1:A1000)))} $B$3
C3 =WENN(B3="";"";ZÄHLENWENN(A2:A1001;B3)) 
B4 {=WENN(ODER(B3=MAX(A2:A101);B3="");"";MIN(WENN(A2:A1001>B3;A2:A1001)))} $B$4
C4 =WENN(B4="";"";ZÄHLENWENN(A3:A1002;B4)) 
B5 {=WENN(ODER(B4=MAX(A3:A102);B4="");"";MIN(WENN(A3:A1002>B4;A3:A1002)))} $B$5
C5 =WENN(B5="";"";ZÄHLENWENN(A4:A1003;B5)) 
B6 {=WENN(ODER(B5=MAX(A4:A103);B5="");"";MIN(WENN(A4:A1003>B5;A4:A1003)))} $B$6
C6 =WENN(B6="";"";ZÄHLENWENN(A5:A1004;B6)) 
B7 {=WENN(ODER(B6=MAX(A5:A104);B6="");"";MIN(WENN(A5:A1004>B6;A5:A1004)))} $B$7
C7 =WENN(B7="";"";ZÄHLENWENN(A6:A1005;B7)) 
B8 {=WENN(ODER(B7=MAX(A6:A105);B7="");"";MIN(WENN(A6:A1005>B7;A6:A1005)))} $B$8
C8 =WENN(B8="";"";ZÄHLENWENN(A7:A1006;B8)) 
B9 {=WENN(ODER(B8=MAX(A7:A106);B8="");"";MIN(WENN(A7:A1006>B8;A7:A1006)))} $B$9
C9 =WENN(B9="";"";ZÄHLENWENN(A8:A1007;B9)) 
B10 {=WENN(ODER(B9=MAX(A8:A107);B9="");"";MIN(WENN(A8:A1007>B9;A8:A1007)))} $B$10
C10 =WENN(B10="";"";ZÄHLENWENN(A9:A1008;B10)) 
B11 {=WENN(ODER(B10=MAX(A9:A108);B10="");"";MIN(WENN(A9:A1008>B10;A9:A1008)))} $B$11
C11 =WENN(B11="";"";ZÄHLENWENN(A10:A1009;B11)) 
B12 {=WENN(ODER(B11=MAX(A10:A109);B11="");"";MIN(WENN(A10:A1009>B11;A10:A1009)))} $B$12
C12 =WENN(B12="";"";ZÄHLENWENN(A11:A1010;B12)) 
B13 {=WENN(ODER(B12=MAX(A11:A110);B12="");"";MIN(WENN(A11:A1010>B12;A11:A1010)))} $B$13
C13 =WENN(B13="";"";ZÄHLENWENN(A12:A1011;B13)) 
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.30


Gruß Hajo
Anzeige
Unterschied auf-absteigend nicht bekannt?
11.11.2010 14:15:14
Rudi
AW: Zahlenwerte per Formel absteigend sortieren
11.11.2010 14:21:09
Fritz_W
Hallo Hajo,
auch bezüglich der Darstellung in Spalte C hast du mich wohl missverstanden.
Auf Dein Beispiel (bezogen auf Spalte A) sollte die Reihenfolge in Spalte B wie folgt aussehen:
B1=8, B2=7, B3=5, B4=4, B5=3, B6=2, B7=2, B8=2, B9=2, B10=2, B11=1, B12=1, B13=1
Ich hoffe, jetzt wird mein Anliegen verständlich.
mfg
Fritz
AW: Zahlenwerte per Formel absteigend sortieren
11.11.2010 14:26:41
Hajo_Zi
Hallo Fritz,
Tabelle1
 ABC
12   
2281
3171
4151
5541
6731
7823
8111
93   
104   
112   
122   
132   

verwendete Formeln
Zelle Formel Bereich
B2 =MAX(A:A) 
C2 =WENN(B2="";"";ZÄHLENWENN(A1:A1000;B2)) 
B3 {=WENN(ODER(B2=MIN(A1:A100);B2="");"";MAX(WENN(A1:A1000<B2;A1:A1000)))} $B$3
C3 =WENN(B3="";"";ZÄHLENWENN(A2:A1001;B3)) 
B4 {=WENN(ODER(B3=MIN(A2:A101);B3="");"";MAX(WENN(A2:A1001<B3;A2:A1001)))} $B$4
C4 =WENN(B4="";"";ZÄHLENWENN(A3:A1002;B4)) 
B5 {=WENN(ODER(B4=MIN(A3:A102);B4="");"";MAX(WENN(A3:A1002<B4;A3:A1002)))} $B$5
C5 =WENN(B5="";"";ZÄHLENWENN(A4:A1003;B5)) 
B6 {=WENN(ODER(B5=MIN(A4:A103);B5="");"";MAX(WENN(A4:A1003<B5;A4:A1003)))} $B$6
C6 =WENN(B6="";"";ZÄHLENWENN(A5:A1004;B6)) 
B7 {=WENN(ODER(B6=MIN(A5:A104);B6="");"";MAX(WENN(A5:A1004<B6;A5:A1004)))} $B$7
C7 =WENN(B7="";"";ZÄHLENWENN(A6:A1005;B7)) 
B8 {=WENN(ODER(B7=MIN(A6:A105);B7="");"";MAX(WENN(A6:A1005<B7;A6:A1005)))} $B$8
C8 =WENN(B8="";"";ZÄHLENWENN(A7:A1006;B8)) 
B9 {=WENN(ODER(B8=MIN(A7:A106);B8="");"";MAX(WENN(A7:A1006<B8;A7:A1006)))} $B$9
C9 =WENN(B9="";"";ZÄHLENWENN(A8:A1007;B9)) 
B10 {=WENN(ODER(B9=MIN(A8:A107);B9="");"";MAX(WENN(A8:A1007<B9;A8:A1007)))} $B$10
C10 =WENN(B10="";"";ZÄHLENWENN(A9:A1008;B10)) 
B11 {=WENN(ODER(B10=MIN(A9:A108);B10="");"";MAX(WENN(A9:A1008<B10;A9:A1008)))} $B$11
C11 =WENN(B11="";"";ZÄHLENWENN(A10:A1009;B11)) 
B12 {=WENN(ODER(B11=MIN(A10:A109);B11="");"";MAX(WENN(A10:A1009<B11;A10:A1009)))} $B$12
C12 =WENN(B12="";"";ZÄHLENWENN(A11:A1010;B12)) 
B13 {=WENN(ODER(B12=MIN(A11:A110);B12="");"";MAX(WENN(A11:A1010<B12;A11:A1010)))} $B$13
C13 =WENN(B13="";"";ZÄHLENWENN(A12:A1011;B13)) 
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.30


Gruß Hajo
Anzeige
AW: Zahlenwerte per Formel absteigend sortieren
11.11.2010 14:33:01
Fritz_W
Hallo Hajo,
es tut mir echt leid (!), aber es liegt wohl immer noch ein Missverständnis bezüglich meines Anliegens vor.
(siehe gewünschte Auflistung der Zahlenwerte in Spalte B in meinem letzter Betrag. Deine Spalte C ist nicht gewünscht, stattdessen mehrfache Werte entsprechend oft in Spalte B).
mfg
Fritz
dann ists ja ganz einfach
11.11.2010 17:12:12
Rudi
Hallo,
B2: =KGRÖSSTE(A:A;ZEILE(A1))
und runter damit.
Gruß
Rudi
AW: dann ists ja ganz einfach
11.11.2010 17:24:06
Fritz_W
Hallo Rudi,
Perfekt, so war's gemeint!
Danke!
mfg
Fritz
AW: Zahlenwerte per Formel absteigend sortieren
11.11.2010 17:17:48
Bernd
Hallo Fritz,
ich hoffe, ich habe Dich richtig verstanden. Gib in der Zelle B2 folgende Formel ein:
=KGRÖSSTE($A$2:$A$2001;Zeile()-1)
Die Formel dann bis unten ziehen.
Gruß Bernd
Anzeige
AW: Zahlenwerte per Formel absteigend sortieren
11.11.2010 17:25:06
Fritz_W
Hallo Bernd,
ja, du hast mich richtig verstanden und so klappt es auch wie gewünscht!
Danke!
mfg
Fritz

320 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige