Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Anzahl der Tage aus Text ermiteln

Anzahl der Tage aus Text ermiteln
Maris
Guten Mittag allerseits,
ich habe ein Textfeld das folgendermaßen auffgebaut ist 2011-02 und möchte daraus ermitteln wieviel Tage im laufenden Monat also Februar wir schon haben. Da heute der 03.02.2011 ist sollte ich den Wert 3 erhalten. Wie kann man das Formeltechnisch umsetzten, brauche ich da hilfsspalten?
Gruß
Maris
AW: Anzahl der Tage aus Text ermiteln
03.02.2011 11:40:22
Rudi
Hallo,
vom Prinzip her so:
=HEUTE()-(TextFeld &"-1")+1
Gruß
Rudi
Denk noch mal drüber nach, Rudi...! ;-) orT
03.02.2011 11:45:18
Luc:-?
Gruß Luc :-?
AW: Denk noch mal drüber nach, Rudi...! ;-) orT
03.02.2011 11:54:32
Rudi
geht doch!











  B C
2 2011-02 3
  Zur Formelanzeige mit der Maus auf die gelben Zellen gehen
C2: =HEUTE()-(TextFeld &"-1")+1


Gruß
Rudi
Anzeige
Ist doch aber Nonsense, weil unnötig! Der...
03.02.2011 18:07:22
Luc:-?
…Fragesteller hat einen Denkfehler begangen und ihr seid alle darauf reingefallen. Ob das geht oder nicht ist bei der Fragestellung doch völlig irrelevant! :-|
Gruß Luc :-?
AW: Anzahl der Tage aus Text ermiteln
03.02.2011 11:40:49
Dieter
Hallo Maris,
das müsste das sein, was Du suchst:
=HEUTE()-DATUM(WERT(LINKS(A1;4));WERT(TEIL(A1;6;2));0)
Gruß
Dieter
AW: Anzahl der Tage aus Text ermiteln
03.02.2011 11:51:42
Maris
fantastisch! Danke für die schnelle Hilfe :-D!!!
Nein! =TAG(HEUTE()) Dabei ist dein...
03.02.2011 11:43:18
Luc:-?
…Textfeld irrelevant, Maris,
da es ja nach deinen Worten um den lfd Monat geht. Etwas Anderes wäre ja auch nicht möglich bzw machte keinen Sinn…
Gruß Luc :-?
Vergangene Tage eines Monats im TEXT-Format
03.02.2011 11:52:50
NoNet
Hallo Maris,
vielleicht gibt es auch eine kürzere Variante, aber diese funktioniert zumindest auch :
AB
1
2
3
4
5
6

Funktionen im Tabellenblatt :
Zelle Formel 
B2   =WENN(HEUTE()>DATUM(JAHR(A2&"-01");MONAT(A2&"-01")+1;0);TAG(DATUM(JAHR(A2&"-01");MONAT(A2&"-01")+1;0));WENN(HEUTE()<DATUM(JAHR(A2&"-01");MONAT(A2&"-01");1);0;TAG(HEUTE()))
B3   =WENN(HEUTE()>DATUM(JAHR(A3&"-01");MONAT(A3&"-01")+1;0);TAG(DATUM(JAHR(A3&"-01");MONAT(A3&"-01")+1;0));WENN(HEUTE()<DATUM(JAHR(A3&"-01");MONAT(A3&"-01");1);0;TAG(HEUTE()))
B4   =WENN(HEUTE()>DATUM(JAHR(A4&"-01");MONAT(A4&"-01")+1;0);TAG(DATUM(JAHR(A4&"-01");MONAT(A4&"-01")+1;0));WENN(HEUTE()<DATUM(JAHR(A4&"-01");MONAT(A4&"-01");1);0;TAG(HEUTE()))
B5   =WENN(HEUTE()>DATUM(JAHR(A5&"-01");MONAT(A5&"-01")+1;0);TAG(DATUM(JAHR(A5&"-01");MONAT(A5&"-01")+1;0));WENN(HEUTE()<DATUM(JAHR(A5&"-01");MONAT(A5&"-01");1);0;TAG(HEUTE()))
B6   =WENN(HEUTE()>DATUM(JAHR(A6&"-01");MONAT(A6&"-01")+1;0);TAG(DATUM(JAHR(A6&"-01");MONAT(A6&"-01")+1;0));WENN(HEUTE()<DATUM(JAHR(A6&"-01");MONAT(A6&"-01");1);0;TAG(HEUTE()))

Funktion nur in B2 eingeben und nach unten kopieren !!
Gruß, NoNet
Anzeige
Wenn du da mal nicht mehr hineininterpretierst,...
03.02.2011 18:12:35
Luc:-?
…NoNet,
als Maris eigentl will...? :-/
Gruß Luc :-?
@Luc : Hatte die Frage aber so verstanden !! _oT
03.02.2011 23:34:58
NoNet
_oT
PS : gut gemeint ist manchmal wohl doch "Zuviel des Ganzen" ;-))

333 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige