Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Datums- Zeitdifferenz ohne Sa/So und Feiertage

Datums- Zeitdifferenz ohne Sa/So und Feiertage
dani
Vordefinitionen
Bsp. 2 Zeilen mit Start- und Endzeit:
07:00
17:00
Zeilen mit Angabe der Feiertage:
01.01.2011
02.01.2011
usw.
Nun zu den Ein-Ausgaben:
Bsp. Eingabe:
23.12.2011 10:00
25.12.2011 09:00
Ausgabe sollte dann sein:
07:00 (also 7 Stunden)
23.12.2011 von 10:00 bis 17:00 sind 07:00 Stunden
24.12.2011 zählt er nicht, da Samstag
25.12.2011 zählt er nicht, da Feiertag
Kann man dies "relativ einfach" in eine Formel packen oder einfacher mit VBA? Danke für Tipps....

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Datums- Zeitdifferenz ohne Sa/So und Feiertage
11.04.2011 18:19:17
Wilfried
Hallo!
Hilft Dir das weiter? 5 Tagewoche a 8 Stunden
Tabelle8

 ABCDEFGHIJK
2Nettoarbeitstage ohne Sa, So, und Feiertage          
3           
4 Sa 01.01.2011Neujahr         
5 Do 06.01.2011Heilige 3 Könige         
6 So 24.04.2011Ostersonntag         
7 Mo 25.04.2011Ostermontag         
8 So 01.05.2011Tag der Arbeit         
9 Do 02.06.2011Christi Himmelfahrt         
10 So 12.06.2011Pfingstsonntag         
11 Mo 13.06.2011Pfingstmontag         
12 Do 23.06.2011Fronleichnam         
13 Mo 15.08.2011Mariahimmelfahrt         
14 Mi 26.10.2011Nationalfeiertag         
15 Di 01.11.2011Allerheiligen         
16 Do 08.12.2011Maria Empfängnis         
17 So 25.12.2011Christtag         
18 Mo 26.12.2011Stefanitag         
19           
20        WievieleWievieleStunden
21Datum monatlich oh.Sa,So GesamttageFreie Tageoh Sa,SoWievieleWievieleFeiertageFeiertage an5 Tagewoche
22  oh Feiertage   SaSogesamtWerktagea 8 Stunden
23Fr 23.12.2011 Mo 26.12.2011143211218 Stunden

Formeln der Tabelle
ZelleFormel
C23=SUMMENPRODUKT((WOCHENTAG(ZEILE(INDIREKT(A23&":"&B23)); 2)<6)*1)-SUMMENPRODUKT(($A$4:$A$18>=A23)*($A$4:$A$18<=B23)*(WOCHENTAG($A$4:$A$18;2)<6))
D23=B23-A23+1
E23=D23-C23
F23=SUMMENPRODUKT((WOCHENTAG(ZEILE(INDIREKT(A23&":"&B23)); 2)<6)*1)
G23=SUMMENPRODUKT(--(WOCHENTAG(ZEILE(INDIREKT(A23&":"&B23)); 2)=6))
H23=SUMMENPRODUKT(--(WOCHENTAG(ZEILE(INDIREKT(A23&":"&B23)); 2)=7))
I23=SUMMENPRODUKT(($A$4:$A$18>=A23)*($A$4:$A$18<=B23))
J23=F23-C23
K23=C23*8&" Stunden"


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß
Wilfried
Anzeige
AW: Datums- Zeitdifferenz ohne Sa/So und Feiertage
12.04.2011 15:22:00
dani
hallo wilfried
besten dank, hat mir weiter geholfen....

315 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige