Mehrfachformel



Excel-Version: 9
nach unten

Betrifft: Mehrfachformel
von: joe
Geschrieben am: 11.05.2002 - 13:25:40

Wie kann ich folgende formel eingeben:
wenn Zelle a1 wert von 1000 bis 1500 in Zelle b1 wert 10, wenn a1 wert von 1501 bis 200 b1 wert 25 usw. bis zu 40 verschiedenen werten in zelle b1.

vielen Dank
Joe

nach oben   nach unten

Re: Mehrfachformel
von: Silvio
Geschrieben am: 11.05.2002 - 13:47:03

Ich würde es auf die "schnelle" mit Sverweis machen...
Bin aber sicher das es noch bessere Lösungen gibt!
Schreibe z.B. in einen neuen Tabellenblatt: Bei A1 angefangen alle Werte auf und in Zelle B1 den dazu passenden Gegenwert:
z.B: A1: 1000 B1: 10
A2: 1001 B2: 10
A3: 1002 B2: 10 ...
A1501: 1501 B1501: 25...usw.
Wenn du alle Werte und Gegenwerte aufgeschrieben hast , dann markiere alle Werte und Gegenwerte in diesem Tabellenblatt und gehe auf "Einfügen" - "Namen" - "Namen definieren"
Gibt hier jetzt zum Bsp. den Namen "Werte" an.

Jetzt gehe in dein altes Tabellenblatt zurück und schreibe in der Zelle B1 folgende Formel ein:
=SVERWEIS(A1;Werte;2)
in Zelle B2 folgende Formel:
=SVERWEIS(A2;Werte;2)
usw.
Hoffe mal das Hilft erstmal bis eine neue Formel gefunden wird.

nach oben   nach unten

Auswertung von Zahlenbereichen
von: WF
Geschrieben am: 11.05.2002 - 15:06:44

Hey Joe,

auszuwertende Zahl in A1.

In A3 bis A?? stehen die Untergrenzen der Zahlenbereiche: 0 1000 1501 2001 2501 3001 etc.
In B3 bis B?? die gewünschten Rückgabewerte.
Zeilen 3 bis ?? ausblenden.

Das Ergebnis:
=INDEX(B3:B100;VERGLEICH(A1;A3:A100;1))

trapp, trapp, trapp, trapp, trapp, brrrrr
WF

http://www.excelformeln.de/
die ultimative Formelseite

nach oben   nach unten

Re: Mehrfachformel
von: GraFri
Geschrieben am: 11.05.2002 - 15:23:05

Hallo

Code in dei Dekleration der entsprechenden Tabelle. Tabellenname anpassen.


Sub Worksheet_Change(ByVal Target As Excel.Range)
Dim dB  As Worksheet
Dim B   As Single

Set dB = Worksheets("Tabelle1")

On Error GoTo Fehler
Application.EnableEvents = False
If Target.Column = 1 Then
    If IsNumeric(dB.Range(Target.Address).Value) Then   'Abfrage, ob Zahl
        Select Case Range(Target.Address).Value
            Case Is < 1500: B = 10
            Case Is < 2000: B = 25
            'usw.
            'usw.
            'usw:
        End Select
        dB.Range(Target.Address).Offset(0, 1).Value = B   'Ausgabe in Nachbarzelle
    Else
        dB.Range(Target.Address) = vbNullString
        dB.Range(Target.Address).Offset(0, 1) = vbNullString
    End If
End If
Application.EnableEvents = True
Exit Sub

Fehler:
Application.EnableEvents = True
End Sub

mfg, GraFri

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Speichern"