negatives Vorzeichen im Textformat



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: negatives Vorzeichen im Textformat
von: Frantic
Geschrieben am: 14.05.2002 - 17:53:17

Hallo Excel-Cracks!

Aus einer Anwendung heraus bekomme ich Zahlen leider als Text geliefert. Bei den negativen Werten kommt das Vorzeichen dummerweise rechtsbündig ... und das ist mein Problem! Ich brauche das Vorzeichen aber links um mit den Werten rechnen zu können...

Bsp. für eine fiktive Spalte A:
11,83-
0
159,25
0
159,25-
8
11,83


Ich habe es folgendermaßen probiert:
=WENN(FINDEN("-";A1)>1;-(ERSETZEN(A1;(FINDEN("-";A1;1));1;""));Wert(A1))

Das klappt für die negativen Werte ganz gut, ist der Wert aber positiv oder Null bekomme ich "#WERT!" angezeigt.

Wer kann helfen?? Danke schön im voraus!

nach oben   nach unten

Re: negatives Vorzeichen im Textformat
von: Joachim L.
Geschrieben am: 14.05.2002 - 17:59:32

Hatte das gleiche Problem. Hier mein Makro. Bereich mit den Zahlen Markieren und Makro starten.

Sub Minus_von_hinten_nach_vorne()
'
With Selection

Selection.Find(What:="-", After:=ActiveCell, LookIn:=xlValues, LookAt:= _
xlPart, SearchOrder:=xlByRows, SearchDirection:=xlNext, MatchCase:=False) _
.Activate
ersteAdresse = ActiveCell.Address
ActiveCell.Replace What:="-", Replacement:="", LookAt:=xlPart, _
SearchOrder:=xlByRows, MatchCase:=False
ActiveCell = ActiveCell.Value * -1
Do
Selection.Find(What:="-", After:=ActiveCell, LookIn:=xlFormulas, LookAt:= _
xlPart, SearchOrder:=xlByRows, SearchDirection:=xlNext, MatchCase:=False) _
.Activate
ActiveCell.Replace What:="-", Replacement:="", LookAt:=xlPart, _
SearchOrder:=xlByRows, MatchCase:=False
ActiveCell = ActiveCell.Value * -1
Loop While ActiveCell.Address <> ersteAdresse

End With
End Sub

Gruß Joachim

nach oben   nach unten

Re: Einfache Formel-Lösung
von: Klaus K.
Geschrieben am: 14.05.2002 - 18:19:39

=WENN(ISTFEHL(SUCHEN("-";A1;1))=WAHR;A1;0-WECHSELN(A1;"-";""))*1

nach oben   nach unten

Re: Einfache Formel-Lösung
von: Frantic
Geschrieben am: 15.05.2002 - 17:20:16

Hallo Klaus,

klappt super, vielen Dank!


nach oben   nach unten

Re: negatives Vorzeichen im Textformat
von: Frantic
Geschrieben am: 15.05.2002 - 17:22:47

Hallo Joachim,

vielen dank, klappt auch bestens!!!


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Pagesetup Fehler 1004"