Matrixformel



Excel-Version: 10.0 (Office XP)
nach unten

Betrifft: Matrixformel
von: Der André
Geschrieben am: 14.05.2002 - 23:44:31

Hallo liebe Excel-Freunde,

ich möchte mit SVERWEIS bis zu sechs nebeneinander liegende Werte (D4:I4) in einer anderen Übersicht "LK" nachschlagen (2. Spalte) und summieren. Nehme ich ne Matrixformel, habe ich gedacht und folgendes ausgeknobelt:

{=SUMME(SVERWEIS(D4:I4; LK; 2; FALSCH))}

Jetzt macht XL aber nicht das, was ich will. Es schlägt zwar den Wert in D4 nach, summiert aber nicht den von E4, F4 usw. Was mache ich falsch?

Ich will das mit der Matrixformel unbedingt hinkriegen, da ich keine Lust habe,

=SVERWEIS(D4; LK; 2; FALSCH)+SVERWEIS(E4; LK; 2; FALSCH)+..

zu notieren, zumal ich dann jede einzelne Anweisung noch in eine WENN-Abfrage packen muss für den Fall, dass nur Werte in D4 und E4 existieren, diese aber trotzdem summiert werden sollen.

Bin für jede Hilfe bereits im voraus dankbar,
Der André

nach oben   nach unten

Re: Matrixformel
von: snickers
Geschrieben am: 15.05.2002 - 12:47:08

Hi André

folgende Matrixformel hat bei mir Funktioniert:
{=SUMME(SVERWEIS(A7;A1:F5;{2.3.4};0))}
Matrix (ARRAY-) Formel: die geschweifte Klammer nicht eingeben, sondern die Formeleingabe abschließen mit Strg + Umsch+ Enter

Die Spalten 2, 3 und 4 wurden addiert

nach oben   nach unten

Re: Matrixformel - Fast richtig
von: Der André
Geschrieben am: 15.05.2002 - 18:51:57

Hi snickers,

leider nicht ganz richtig - zugegeben, ich habe mich dumm ausgedrückt.

Deine Formel schlägt EINEN Wert A7 in A1:F5 nach und summiert 3 Spalten aus A1:F5.

Meine Nachschlagematrix besteht aus nur 2 Spalten: Kriterien A und zugehörige Werte B.
Ich will nicht nur einen Wert A7, sondern MEHRERE Werte A7:A12 in den Kriterien A nachschlagen und jeden zugehörigen Wert B addieren. Also erst A7 nachschlagen, zu Nachschlagewert von A8 hinzuaddieren, zu Nachschlagewert von A9 hinzuaddieren usw.

Vielleicht hast du auch hierfür eine Idee.

Danke für deine Hilfe,
Der André

nach oben   nach unten

Lösung gefunden
von: Der André
Geschrieben am: 15.05.2002 - 22:51:04

Hi snickers,

habe die Lösung mittlerweile selbst gefunden. Sie lautet

{=SUMME((Konstanten!A1:A20=C4:H4)*Konstanten!B1:B20)}

XL vergleicht die Werte in C4:H4 nacheinander mit allen in A1:A20 und liefert das gewünschte Ergebnis.

Vielen Dank für die Mühe,
Der André

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Matrixformel"