Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summewenn/ Anzahl bedingt formatierter Zellen

Summewenn/ Anzahl bedingt formatierter Zellen
Thorsten
Hallo zusammen,
Folgendes Problem. Ich will die Anzahl der grünen/roten Zellen zählen. Nur irgendwie klappt es bei mir auch über die Bedingung nicht.
Kann mir wer weiterhelfen?
Vielen Dank im Voraus,
Gruß, Thorsten
Und der Link:
https://www.herber.de/bbs/user/75716.xls

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Summewenn/ Anzahl bedingt formatierter Zellen
15.07.2011 09:18:32
oberschlumpf
Hi Thorsten
Vielleicht tut es ja diese Formel:
=ZählenWenn(Bereich;DeineFormelFürBedingteFormatierung)
Für DeineFormelFürBedingteFormatierung trägst du halt die gleiche Formel ein, die die Zellen grün oder rot macht.
Hilfts?
Ciao
Thorsten
AW: Summewenn/ Anzahl bedingt formatierter Zellen
15.07.2011 09:32:53
Matthias
Hallo
vielleicht gehts ja so?
Tabelle1

 CDEFGHIJKLMNO
4113,19,33,85,40,41,97,71,52,64,41,2 
524,15,25,73,10,60,63,40,61,32,35,2 
634,95,29,83,11,11,33,31,31,71,82,5 
7416,715,112,05,43,11,62,63,53,95,92,6 
854,15,211,42,00,81,12,23,14,72,32,5 
9610,915,16,20,42,41,80,713,02,014,61,1 
10Max16,715,112,05,43,11,97,713,04,714,65,2 
11Min4,15,23,80,40,40,60,70,61,31,81,1gesamt
12Anzahl MAX1212111111113
13Anzahl MIN2311111111114

Formeln der Tabelle
ZelleFormel
D10=MAX(D4:D9)
E10=MAX(E4:E9)
F10=MAX(F4:F9)
G10=MAX(G4:G9)
H10=MAX(H4:H9)
I10=MAX(I4:I9)
J10=MAX(J4:J9)
K10=MAX(K4:K9)
L10=MAX(L4:L9)
M10=MAX(M4:M9)
N10=MAX(N4:N9)
D11=MIN(D4:D9)
E11=MIN(E4:E9)
F11=MIN(F4:F9)
G11=MIN(G4:G9)
H11=MIN(H4:H9)
I11=MIN(I4:I9)
J11=MIN(J4:J9)
K11=MIN(K4:K9)
L11=MIN(L4:L9)
M11=MIN(M4:M9)
N11=MIN(N4:N9)
D12=ZÄHLENWENN(D$4:D$9;D10)
E12=ZÄHLENWENN(E$4:E$9;E10)
F12=ZÄHLENWENN(F$4:F$9;F10)
G12=ZÄHLENWENN(G$4:G$9;G10)
H12=ZÄHLENWENN(H$4:H$9;H10)
I12=ZÄHLENWENN(I$4:I$9;I10)
J12=ZÄHLENWENN(J$4:J$9;J10)
K12=ZÄHLENWENN(K$4:K$9;K10)
L12=ZÄHLENWENN(L$4:L$9;L10)
M12=ZÄHLENWENN(M$4:M$9;M10)
N12=ZÄHLENWENN(N$4:N$9;N10)
O12=SUMME(D12:N12)
D13=ZÄHLENWENN(D$4:D$9;D11)
E13=ZÄHLENWENN(E$4:E$9;E11)
F13=ZÄHLENWENN(F$4:F$9;F11)
G13=ZÄHLENWENN(G$4:G$9;G11)
H13=ZÄHLENWENN(H$4:H$9;H11)
I13=ZÄHLENWENN(I$4:I$9;I11)
J13=ZÄHLENWENN(J$4:J$9;J11)
K13=ZÄHLENWENN(K$4:K$9;K11)
L13=ZÄHLENWENN(L$4:L$9;L11)
M13=ZÄHLENWENN(M$4:M$9;M11)
N13=ZÄHLENWENN(N$4:N$9;N11)
O13=SUMME(D13:N13)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias
Anzeige
AW: Summewenn/ Anzahl bedingt formatierter Zellen
15.07.2011 09:44:03
Thorsten
Hallo,
Es sind verschiedene Teile (1-6) und die sollen EINZELN ausgewertet werden. Es geht darum, dass es mehrere Versuche mit 6 Teilen sind und ich herausfinden will, an welcher Stelle die besten Teile liegen.
Z.B.: Teil 3 hat (fast) immer die besten Werte.
Trotzdem danke!
AW: Summewenn/ Anzahl bedingt formatierter Zellen
15.07.2011 10:30:59
Matthias
Hallo
eine Auswertung könnte vielleicht auch so aussehen:
Tabelle1

 CDEFGHIJKLMNO
4113,19,33,85,40,41,97,71,52,64,41,2 
524,15,25,73,10,60,63,40,61,32,35,2 
634,98,79,83,11,11,33,31,31,71,82,5 
7416,715,112,01,23,11,62,63,53,95,92,6 
858,110,111,42,00,81,12,23,14,72,32,5 
9610,99,26,20,42,41,80,713,02,014,61,1 
10Max16,715,112,05,43,11,97,713,04,714,65,2 
11Min4,15,23,80,40,40,60,70,61,31,81,1 
12             
13             
14            Auswertung
151001111100005
162110001011016
173000000000101
184111010000004
195000000001001
206000100110115

Formeln der Tabelle
ZelleFormel
D10=MAX(D4:D9)
E10=MAX(E4:E9)
F10=MAX(F4:F9)
G10=MAX(G4:G9)
H10=MAX(H4:H9)
I10=MAX(I4:I9)
J10=MAX(J4:J9)
K10=MAX(K4:K9)
L10=MAX(L4:L9)
M10=MAX(M4:M9)
N10=MAX(N4:N9)
D11=MIN(D4:D9)
E11=MIN(E4:E9)
F11=MIN(F4:F9)
G11=MIN(G4:G9)
H11=MIN(H4:H9)
I11=MIN(I4:I9)
J11=MIN(J4:J9)
K11=MIN(K4:K9)
L11=MIN(L4:L9)
M11=MIN(M4:M9)
N11=MIN(N4:N9)
D15=SUMME(WENN(D4=D$10;1;0); WENN(D4=D$11;1;0))
E15=SUMME(WENN(E4=E$10;1;0); WENN(E4=E$11;1;0))
F15=SUMME(WENN(F4=F$10;1;0); WENN(F4=F$11;1;0))
G15=SUMME(WENN(G4=G$10;1;0); WENN(G4=G$11;1;0))
H15=SUMME(WENN(H4=H$10;1;0); WENN(H4=H$11;1;0))
I15=SUMME(WENN(I4=I$10;1;0); WENN(I4=I$11;1;0))
J15=SUMME(WENN(J4=J$10;1;0); WENN(J4=J$11;1;0))
K15=SUMME(WENN(K4=K$10;1;0); WENN(K4=K$11;1;0))
L15=SUMME(WENN(L4=L$10;1;0); WENN(L4=L$11;1;0))
M15=SUMME(WENN(M4=M$10;1;0); WENN(M4=M$11;1;0))
N15=SUMME(WENN(N4=N$10;1;0); WENN(N4=N$11;1;0))
O15=SUMME(D15:N15)
D16=SUMME(WENN(D5=D$10;1;0); WENN(D5=D$11;1;0))
E16=SUMME(WENN(E5=E$10;1;0); WENN(E5=E$11;1;0))
F16=SUMME(WENN(F5=F$10;1;0); WENN(F5=F$11;1;0))
G16=SUMME(WENN(G5=G$10;1;0); WENN(G5=G$11;1;0))
H16=SUMME(WENN(H5=H$10;1;0); WENN(H5=H$11;1;0))
I16=SUMME(WENN(I5=I$10;1;0); WENN(I5=I$11;1;0))
J16=SUMME(WENN(J5=J$10;1;0); WENN(J5=J$11;1;0))
K16=SUMME(WENN(K5=K$10;1;0); WENN(K5=K$11;1;0))
L16=SUMME(WENN(L5=L$10;1;0); WENN(L5=L$11;1;0))
M16=SUMME(WENN(M5=M$10;1;0); WENN(M5=M$11;1;0))
N16=SUMME(WENN(N5=N$10;1;0); WENN(N5=N$11;1;0))
O16=SUMME(D16:N16)
D17=SUMME(WENN(D6=D$10;1;0); WENN(D6=D$11;1;0))
E17=SUMME(WENN(E6=E$10;1;0); WENN(E6=E$11;1;0))
F17=SUMME(WENN(F6=F$10;1;0); WENN(F6=F$11;1;0))
G17=SUMME(WENN(G6=G$10;1;0); WENN(G6=G$11;1;0))
H17=SUMME(WENN(H6=H$10;1;0); WENN(H6=H$11;1;0))
I17=SUMME(WENN(I6=I$10;1;0); WENN(I6=I$11;1;0))
J17=SUMME(WENN(J6=J$10;1;0); WENN(J6=J$11;1;0))
K17=SUMME(WENN(K6=K$10;1;0); WENN(K6=K$11;1;0))
L17=SUMME(WENN(L6=L$10;1;0); WENN(L6=L$11;1;0))
M17=SUMME(WENN(M6=M$10;1;0); WENN(M6=M$11;1;0))
N17=SUMME(WENN(N6=N$10;1;0); WENN(N6=N$11;1;0))
O17=SUMME(D17:N17)
D18=SUMME(WENN(D7=D$10;1;0); WENN(D7=D$11;1;0))
E18=SUMME(WENN(E7=E$10;1;0); WENN(E7=E$11;1;0))
F18=SUMME(WENN(F7=F$10;1;0); WENN(F7=F$11;1;0))
G18=SUMME(WENN(G7=G$10;1;0); WENN(G7=G$11;1;0))
H18=SUMME(WENN(H7=H$10;1;0); WENN(H7=H$11;1;0))
I18=SUMME(WENN(I7=I$10;1;0); WENN(I7=I$11;1;0))
J18=SUMME(WENN(J7=J$10;1;0); WENN(J7=J$11;1;0))
K18=SUMME(WENN(K7=K$10;1;0); WENN(K7=K$11;1;0))
L18=SUMME(WENN(L7=L$10;1;0); WENN(L7=L$11;1;0))
M18=SUMME(WENN(M7=M$10;1;0); WENN(M7=M$11;1;0))
N18=SUMME(WENN(N7=N$10;1;0); WENN(N7=N$11;1;0))
O18=SUMME(D18:N18)
D19=SUMME(WENN(D8=D$10;1;0); WENN(D8=D$11;1;0))
E19=SUMME(WENN(E8=E$10;1;0); WENN(E8=E$11;1;0))
F19=SUMME(WENN(F8=F$10;1;0); WENN(F8=F$11;1;0))
G19=SUMME(WENN(G8=G$10;1;0); WENN(G8=G$11;1;0))
H19=SUMME(WENN(H8=H$10;1;0); WENN(H8=H$11;1;0))
I19=SUMME(WENN(I8=I$10;1;0); WENN(I8=I$11;1;0))
J19=SUMME(WENN(J8=J$10;1;0); WENN(J8=J$11;1;0))
K19=SUMME(WENN(K8=K$10;1;0); WENN(K8=K$11;1;0))
L19=SUMME(WENN(L8=L$10;1;0); WENN(L8=L$11;1;0))
M19=SUMME(WENN(M8=M$10;1;0); WENN(M8=M$11;1;0))
N19=SUMME(WENN(N8=N$10;1;0); WENN(N8=N$11;1;0))
O19=SUMME(D19:N19)
D20=SUMME(WENN(D9=D$10;1;0); WENN(D9=D$11;1;0))
E20=SUMME(WENN(E9=E$10;1;0); WENN(E9=E$11;1;0))
F20=SUMME(WENN(F9=F$10;1;0); WENN(F9=F$11;1;0))
G20=SUMME(WENN(G9=G$10;1;0); WENN(G9=G$11;1;0))
H20=SUMME(WENN(H9=H$10;1;0); WENN(H9=H$11;1;0))
I20=SUMME(WENN(I9=I$10;1;0); WENN(I9=I$11;1;0))
J20=SUMME(WENN(J9=J$10;1;0); WENN(J9=J$11;1;0))
K20=SUMME(WENN(K9=K$10;1;0); WENN(K9=K$11;1;0))
L20=SUMME(WENN(L9=L$10;1;0); WENN(L9=L$11;1;0))
M20=SUMME(WENN(M9=M$10;1;0); WENN(M9=M$11;1;0))
N20=SUMME(WENN(N9=N$10;1;0); WENN(N9=N$11;1;0))
O20=SUMME(D20:N20)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias
Anzeige
AW: Summewenn/ Anzahl bedingt formatierter Zellen
15.07.2011 11:24:23
Thorsten
Theoretisch sollten die roten dann "-1" sein [sind Abweichungen vom Normmaß]. Das könnte man mit einem Vorzeichen machen.
Letztendlich ist die Lösung aber leider ein wenig aufwendig, aber es scheint wohl nicht anders zu gehen.
In der Zeit hab ich das Locker per Hand ausgezählt (mehr Spalten gibt es nicht).
Wollte das nur mal für die Zukunft wissen. Dachte es gebe eine smarte Lösung, die man in die Zelle hinter den Werten machen kann.
Trotzdem danke!
das ärgert mich
15.07.2011 11:51:57
oberschlumpf
Hi Thorsten
Wie wäre es denn, wenn du mal eine Bsp-Datei mit IST-Zustand und vor allem mit SOLL-Zustand zeigst?
Denn jedes mal, wenn du geantwortet hast, kam immer stückchenweise eine weitere Bedingung, die beachtet werden sollen.
Hättest du all das gleich im ersten Thread beschrieben, dann hätten die Antworter ihre Zeit nicht "verplempern" müssen, da die Lösungen ja nicht passten.
Ciao
Thorsten
Anzeige
AW: das ärgert mich
15.07.2011 13:15:39
Thorsten
Den Ärger kann ich nachvollziehen. Da ich mich (wie angegeben) mit Excel nicht auskenne, fiel es mir halt schwer das Problem zu definieren.
Ich versuch das ganze nochmal:
Es sollen zeilenweise die grünen und (jedoch unabhängig voneinander) roten gezählt werden. Diese sollen nachher miteinander verrechnet werden. So hat ein gutes Teil einen hohen positiven Wert, ein schlechtes Teil (was weit vom Normmaß abweicht) eventuell sogar einen negativen Wert.
Dadurch soll heraus gefunden welcher Teile typischerweise beim Versuch besser/schlechter sind um so Rückschlüsse auf den Versuch zu ziehen.
Allerdings arbeiten in der Tabelle mehrere Leute, also sollte es übersichtlich und ohne viele Zwischenschritte auskommen. Auf den ersten Blick sollten solche Sachen ersichtlich sein und die Pflege der Liste soll praktisch von jedem durchgeführt werden.
Ich dachte es gebe sowas wie =ZÄHLENWENN(D4:N4;D4=D11) und das läuft dann für jede Stelle einzeln durch und zählt dir Argumente, wo es wahr ist.
Deswegen hatte ich auf eine einfache Lösung gehofft (weil ich kaum Funktionen kenne).
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige
Archiv - Verwandte Themen
Forumthread
Beiträge