Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Problem beim Ausführen eines Makros (Hyperlinks)

Problem beim Ausführen eines Makros (Hyperlinks)
Christian
Es geht um unten stehendes Makro. Beim Ausführen wird der Text Call Worksheet_Change markiert _ und es kommt die Fehlermeldung: Fehler beim Kompilieren:

Sub oder 

Function nicht definiert.
Kann mir da jemand bitte weiterhelfen?
Gruß
Christian

Sub RunOnce()
Dim row As Long
Application.ScreenUpdating = False
For row = 1 To Cells.SpecialCells(xlCellTypeLastCell).row
If Cells(row, 3)  "" Then
Call Worksheet_Change(Cells(row, 3))
End If
Next
Application.ScreenUpdating = True
End Sub

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Problem beim Ausführen eines Makros (Hyperlinks)
21.12.2011 11:23:43
Dirk
Hallo!
Funktioniert in 2007, wenn Blatt nicht gesperrt ist.
Gruss
Dirk aus Dubai
AW: Problem beim Ausführen eines Makros (Hyperlinks)
21.12.2011 11:28:53
Christian
nur dass ich inzwischen Excel 2010 nutze
Danke erstmal für die Hilfe
Christian
AW: Problem beim Ausführen eines Makros (Hyperlinks)
21.12.2011 11:38:30
Christian
Habe den Fehler gefunden,
hatte versucht eine alte, versehentlich gelöschte Arbeitsmappe zu rekonstruieren und dabei vergessen, dass damals noch ein zweites Makro existierte, welches da eine Rolle gespielt hatte.
Das Makro ist jetzt auch rekonstruiert und jetzt klappt es auch.
Trotzdem danke für die Mühe
Christian
Anzeige

327 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige