Microsoft Excel

Herbers Excel/VBA-Archiv

SVerweis | Herbers Excel-Forum


Betrifft: SVerweis von: ottgunter
Geschrieben am: 01.01.2012 19:05:27

Hallo

Wünsche allen ein gesundes neues Jahr 2012

Wie kann ich die Bestellung automatisch ausfüllen lassen
Habe 2 Blätter Bestellung und Medikamente

Bestellung

 ABC
21HandelsnamePZNInhalt
22   
23   
24   
25   
26   
27   
28   
29   
30   
31   
32   
33   
34   
35   
36   
37   
38   
39   
40   
41   
42   


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Medikamente

 ABC
5HandelsnamePZNInhalt
6a63247266x2ml
7s400038510x1ml
8d00222085x2ml
9f34885745x5ml
10g311308720x10ml


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß gunter

  

Betrifft: AW: SVerweis von: hary
Geschrieben am: 01.01.2012 19:12:38

Hallo Gunter
ebenso ein frohes neues.
Problem: Woher soll Excel wissen was Du bestellen willst??
Was traegst Du in Bestellung ein?
gruss hary


  

Betrifft: AW: SVerweis von: ottgunter
Geschrieben am: 01.01.2012 19:28:17

Hallo Hary
Wenn ich in der Bestellungsliste ( Zelle a22) z.B eine 3 eingeben würde, soll aus der Medikamentenliste
das 3. medikament ( in diesem Fall d ) automatich mit PZN und Inhalt eingegeben werden.
Vieleicht ist es besser wenn ich in der Medikamentenliste noch eine Spalte D einfüge, und diese mit lft. Nummern ausfülle 1 bis ....

Gruß Gunter


  

Betrifft: AW: SVerweis von: hary
Geschrieben am: 01.01.2012 19:36:19

Hallo
nimm doch in SpalteA eine Gueltigkeisliste. Oder mit dem Doppelklickereigniss des Listenblattes die Medikamente rueberkopieren.
Denn bei 400 Medikamenten weisst Du aus dem Kopf nicht an welcher Stelle das Medikament ist. Problem 2 (aus jetziger Erfahrung) es gibt ja auch Medikamente gleichen Namens mit anderen Inhalten.
gruss hary


  

Betrifft: AW: SVerweis von: ottgunter
Geschrieben am: 01.01.2012 19:46:57

Hallo Hary

Erst mal zum 2 Problem: Genau umgekehrt ist es. Die Bezeichnung des Inhaltstoffs bleib gleich, und der Handelsname kann verschieden sein. :)
Leider verstehe ich deine Lösung nicht. Könntest du ein Beispiel darstellen.

Gruß Gunter


  

Betrifft: mein Bsp. gefällt Dir nicht? oT von: Matthias L
Geschrieben am: 01.01.2012 19:49:20




  

Betrifft: AW: so sollte es sein ;-) von: hary
Geschrieben am: 01.01.2012 19:52:24

hallo Matthias
hab erst jetzt Deine Mappe geladen, das meinte ich.
gruss hary


  

Betrifft: SVerweis - hier ein Beispiel ... von: Matthias L
Geschrieben am: 01.01.2012 19:25:46

Hallo Gunter

Bestellung

 ABCDE
1HandelsnamePZNInhalt Liste
2a63247266x2ml a
3g311308720x10m s
4f34885745x5ml d
5    f
6    g

Formeln der Tabelle
ZelleFormel
B2=WENN(ISTFEHLER(SVERWEIS($A2;Medikamente!$A$2:$C$6;SPALTE();0));"";SVERWEIS($A2;Medikamente!$A$2:$C$6;SPALTE();0))
C2=WENN(ISTFEHLER(SVERWEIS($A2;Medikamente!$A$2:$C$6;SPALTE();0));"";SVERWEIS($A2;Medikamente!$A$2:$C$6;SPALTE();0))
B3=WENN(ISTFEHLER(SVERWEIS($A3;Medikamente!$A$2:$C$6;SPALTE();0));"";SVERWEIS($A3;Medikamente!$A$2:$C$6;SPALTE();0))
C3=WENN(ISTFEHLER(SVERWEIS($A3;Medikamente!$A$2:$C$6;SPALTE();0));"";SVERWEIS($A3;Medikamente!$A$2:$C$6;SPALTE();0))
B4=WENN(ISTFEHLER(SVERWEIS($A4;Medikamente!$A$2:$C$6;SPALTE();0));"";SVERWEIS($A4;Medikamente!$A$2:$C$6;SPALTE();0))
C4=WENN(ISTFEHLER(SVERWEIS($A4;Medikamente!$A$2:$C$6;SPALTE();0));"";SVERWEIS($A4;Medikamente!$A$2:$C$6;SPALTE();0))
B5=WENN(ISTFEHLER(SVERWEIS($A5;Medikamente!$A$2:$C$6;SPALTE();0));"";SVERWEIS($A5;Medikamente!$A$2:$C$6;SPALTE();0))
C5=WENN(ISTFEHLER(SVERWEIS($A5;Medikamente!$A$2:$C$6;SPALTE();0));"";SVERWEIS($A5;Medikamente!$A$2:$C$6;SPALTE();0))
B6=WENN(ISTFEHLER(SVERWEIS($A6;Medikamente!$A$2:$C$6;SPALTE();0));"";SVERWEIS($A6;Medikamente!$A$2:$C$6;SPALTE();0))
C6=WENN(ISTFEHLER(SVERWEIS($A6;Medikamente!$A$2:$C$6;SPALTE();0));"";SVERWEIS($A6;Medikamente!$A$2:$C$6;SPALTE();0))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Beispiel:
https://www.herber.de/bbs/user/78167.xls

Gruß Matthias


  

Betrifft: AW: Danke an beide von: ottgunter
Geschrieben am: 01.01.2012 20:07:48

Habt recht vielen Dank


Beiträge aus den Excel-Beispielen zum Thema "SVerweis "