Microsoft Excel

Herbers Excel/VBA-Archiv

Summe ermitteln zwischen zwei Datumswerten | Herbers Excel-Forum


Betrifft: Summe ermitteln zwischen zwei Datumswerten von: Niko
Geschrieben am: 04.01.2012 15:44:11

Hallo zusammen,

ich habe in einer Tabelle fortlaufende Datumswerte stehen und in der Spalte rechts daneben Beträge. Für die Matrix habe ich einen Namen definiert.

Wie kann ich die Summe der Beträge zwischen zwei Datumswerten ermitteln - wenn möglich, ohne dass ich das Ausgangsdatum und Enddatum in zusätzlichen Hilfszellen ausgeben muss.

Danke schonmal für eure Hilfe und schönen Feierabend.

Gruß
Niko

  

Betrifft: AW: Summe ermitteln zwischen zwei Datumswerten von: Josef Ehrensberger
Geschrieben am: 04.01.2012 16:01:09


Hallo Niko,

das geht mit SUMMENPRODUKT()

=SUMMENPRODUKT((Datumsbereich>=Datum1)*(Datumsbereich<=Datum2)*Wertebereich)




« Gruß Sepp »



  

Betrifft: Danke es funktioniert (oT) von: Niko
Geschrieben am: 04.01.2012 16:21:11

Hi


  

Betrifft: AW: Summe ermitteln zwischen zwei Datumswerten von: Niko
Geschrieben am: 04.01.2012 20:45:23

Hallo Sepp,

du hast mir heute auf meine Frage die obige Formel gepostet. Wie müsste die Formel aussehen, wenn ich nicht alle Datumswerte addieren, sondern nur die Datumswerte bestimmter Wochentage summieren wollte?

Wäre nett wenn du dazu noch einen Tipp hättest.

Gruß Niko


  

Betrifft: AW: Summe ermitteln zwischen zwei Datumswerten von: Josef Ehrensberger
Geschrieben am: 04.01.2012 22:10:14


Hallo Niko,

das geht z. B. so.

Tabelle5

 ABCDEFGH
1DatumWert  VonBisWochentageSa=0, So=1, Mo=2, …
2Sonntag, 1. Januar 20129  05.01.201229.01.20122Montag
3Montag, 2. Januar 20126    4Mittwoch
4Dienstag, 3. Januar 201216    6Freitag
5Mittwoch, 4. Januar 201219      
6Donnerstag, 5. Januar 201225      
7Freitag, 6. Januar 201213  Summe   
8Samstag, 7. Januar 201217  137   
9Sonntag, 8. Januar 20128      
10Montag, 9. Januar 201220      
11Dienstag, 10. Januar 201212      
12Mittwoch, 11. Januar 201210      
13Donnerstag, 12. Januar 201224      
14Freitag, 13. Januar 201221      
15Samstag, 14. Januar 201220      
16Sonntag, 15. Januar 20126      
17Montag, 16. Januar 20125      
18Dienstag, 17. Januar 201223      
19Mittwoch, 18. Januar 201223      
20Donnerstag, 19. Januar 201216      
21Freitag, 20. Januar 201216      
22Samstag, 21. Januar 201220      
23Sonntag, 22. Januar 201219      
24Montag, 23. Januar 201219      
25Dienstag, 24. Januar 20126      
26Mittwoch, 25. Januar 20125      
27Donnerstag, 26. Januar 201224      
28Freitag, 27. Januar 20125      
29Samstag, 28. Januar 201225      
30Sonntag, 29. Januar 201212      
31Montag, 30. Januar 20126      
32Dienstag, 31. Januar 201219      

Formeln der Tabelle
ZelleFormel
E8=SUMMENPRODUKT((A2:A32>=E2)*(A2:A32<=F2)*ISTZAHL(VERGLEICH(REST(A2:A32;7); G2:G4;0))*B2:B32)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Summe ermitteln zwischen zwei Datumswerten von: Niko
Geschrieben am: 05.01.2012 08:27:48

Hallo Sepp,

vielen Dank für deine Hilfe.

Wenn ich deine Tabelle in Excel einfüge, erhalte ich als Ergebnis allerdings 0 angezeigt - sehe jedoch keinen Fehler in deiner Syntax. Außerdem müsste das Ergebnis bei den angegebenen Bereichen doch 168 lauten?

Gruß
Niko


  

Betrifft: AW: Summe ermitteln zwischen zwei Datumswerten von: Josef Ehrensberger
Geschrieben am: 05.01.2012 10:24:30


Hallo Niko,

wenn du die Tabelle von hier kopierst, dann steht in Spalte A statt einem Datum wahrscheinlich Text.

Gib dort mal ein Datum ein, dann funktioniert auch die Formel.

Auf 168 kommst du bei allen (Mo-Mi-Fr) im Datumsbereich, es wird aber nur vom 5.1 bis 29.1 Summiert (E2-F2) und dann stimmen die 137



« Gruß Sepp »



  

Betrifft: Du hast recht - vielen Dank und schönen Tag! (oT) von: Niko
Geschrieben am: 05.01.2012 11:00:00

Hi


Beiträge aus den Excel-Beispielen zum Thema "Summe ermitteln zwischen zwei Datumswerten"