Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema RefEdit
BildScreenshot zu RefEdit RefEdit-Seite mit Beispielarbeitsmappe aufrufen

Bereich verketten per Formel | Herbers Excel-Forum


Betrifft: Bereich verketten per Formel von: ludicla
Geschrieben am: 26.01.2012 14:08:33

Hallo Profis,

ich habe über das Forum schon Makros erhalten die Bereiche verketten.

Bei eine Tabell hab ich z. B. in Spalte A einen 33-stelligen Zählpunkt in jedem Monat einmal.
In der Spalte B das dazugehörige Monat. Um die Einzigartigkeit eines Zählpunktes zu ermitteln,
verknüpfe ich in Spalte C den Zählpunkt aus A mit dem Monat aus B und prüfe dann mit
Zählenwenn.

Schritt 1 in Spalte C Verketten(A1;B1)
Schritt 2 in Spalte D Zählenwenn(C:C;C1)

Geht das auch mit einer Formellösung in einer Zelle - und wenn wie ?

Gruss Ludicla.

  

Betrifft: per Summenprodukt von: Matthias5
Geschrieben am: 26.01.2012 14:20:13

Hallo Ludicla,

meinst du das so?


Tabelle1

 ABC
11234512
22345611
31234521
43456721
52354621
61234512

verwendete Formeln
Zelle Formel
C1 =SUMMENPRODUKT(N(A$1:A$6&B$1:B$6=A1&B1))

Tabellendarstellung in Foren Version 4.8

Gruß,
Matthias


  

Betrifft: AW: per Summenprodukt von: ludicla
Geschrieben am: 26.01.2012 14:38:10

Hallo Matthias5,

herzlichen Dank für deine Hilfe.

Hätte darandenken können - aber mit Summenprodukt hab ich noch wenig gemacht.

Was bewirkt eigentlich das N in der Formel ??

Sehe schon das muss ich ändern!!


Danke

Gruss Ludicla


  

Betrifft: AW: per Summenprodukt von: ludicla
Geschrieben am: 26.01.2012 14:40:30

Hallo Matthias5,

ich glaub ich habs - in den Funktionen wandelt N einen nicht numerischen Wert um.

ist es das ?

Gruss Ludicla


  

Betrifft: Ja : aus WAHR/FALSCH wird 1/0 _oT von: NoNet
Geschrieben am: 26.01.2012 14:46:14

_oT = "ohne Text"


Beiträge aus den Excel-Beispielen zum Thema "Bereich verketten per Formel"