Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn A2 leer, dann Wert A1 füllen | Herbers Excel-Forum


Betrifft: Wenn A2 leer, dann Wert A1 füllen von: Karl-Heinz
Geschrieben am: 26.01.2012 16:35:42

Hallo,
ich komme einfach nicht dahinter....

In einer Spalte sind Zellen mit Werten gefüllt und auch LEER. Ich möchte nun, dass immer die nächste leere Zelle gefunden wird und dorthin der Wert der Zelle darüber gefüllt wird. Also z.B. wenn A2=leer, dann A1. A2 hätte dann den Wert von A1. Solange in Spalte A leere Zellen folgen, fülle diese immer mit dem Wert darüber auf.

Beim Auffinden einer Zelle in Spalte A, die nicht leer ist, lass diesen Wert in der Zelle stehen. Finde die nächste leere Zelle und fülle diese wiederrum mit dem Wert der Zelle darüber auf.

Nun, ich finde hierzu keine Formel. Möglicherweise geht dies nur über ein Makro.

Hier ist mal eine Beispieltabelle mit dem gewünschten Ergebnis in der Spalte "Nachher".
https://www.herber.de/bbs/user/78609.xls

Habt Ihr da eine Lösung.
Besten Dank
Karl-Heinz

  

Betrifft: AW: Wenn A2 leer, dann Wert A1 füllen von: Josef Ehrensberger
Geschrieben am: 26.01.2012 16:41:15


Hallo Karl-Heinz,

Spalte A markieren > F5 > Inhalte > Leerzellen > OK

Anschließend tippst du die Adresse der Zelle oberhalb der ersten markierten Zelle ein ( z. B. =A1) und bestätigst die Eingabe mit Strg+Enter.

Ggf, kannst du dann mit Strg+C > Einfügen > Inhalte > Werte die Formeln durch die Werte ersetzen.




« Gruß Sepp »



  

Betrifft: AW: Wenn A2 leer, dann Wert A1 füllen von: Matthias L
Geschrieben am: 26.01.2012 17:06:00

Hallo

Nur weil Du schreibst, Du findest dafür keine Formel
So ginge es auch

Tabelle1

 ABCD
1A1B1C1D1
2VorherNachherVorherNachher
300150015MüllerMüller
4 0015 Müller
5 0015 Müller
600160016MaierMaier
7 0016 Maier
8 0016 Maier
9 0016 Maier
10 0016 Maier
11 0016 Maier
12 0016 Maier
13 0016 Maier
14 0016 Maier
15 0016 Maier
16 0016 Maier
17 0016 Maier
18 0016 Maier
19 0016 Maier
2000200020BeckerBecker
2100270027LangLang
22 0027 Lang

Formeln der Tabelle
ZelleFormel
B3=WENN(A3="";B2;A3)
D3=WENN(C3="";D2;C3)
B4=WENN(A4="";B3;A4)
D4=WENN(C4="";D3;C4)
B5=WENN(A5="";B4;A5)
D5=WENN(C5="";D4;C5)
B6=WENN(A6="";B5;A6)
D6=WENN(C6="";D5;C6)
B7=WENN(A7="";B6;A7)
D7=WENN(C7="";D6;C7)
B8=WENN(A8="";B7;A8)
D8=WENN(C8="";D7;C8)
B9=WENN(A9="";B8;A9)
D9=WENN(C9="";D8;C9)
B10=WENN(A10="";B9;A10)
D10=WENN(C10="";D9;C10)
B11=WENN(A11="";B10;A11)
D11=WENN(C11="";D10;C11)
B12=WENN(A12="";B11;A12)
D12=WENN(C12="";D11;C12)
B13=WENN(A13="";B12;A13)
D13=WENN(C13="";D12;C13)
B14=WENN(A14="";B13;A14)
D14=WENN(C14="";D13;C14)
B15=WENN(A15="";B14;A15)
D15=WENN(C15="";D14;C15)
B16=WENN(A16="";B15;A16)
D16=WENN(C16="";D15;C16)
B17=WENN(A17="";B16;A17)
D17=WENN(C17="";D16;C17)
B18=WENN(A18="";B17;A18)
D18=WENN(C18="";D17;C18)
B19=WENN(A19="";B18;A19)
D19=WENN(C19="";D18;C19)
B20=WENN(A20="";B19;A20)
D20=WENN(C20="";D19;C20)
B21=WENN(A21="";B20;A21)
D21=WENN(C21="";D20;C21)
B22=WENN(A22="";B21;A22)
D22=WENN(C22="";D21;C22)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Am Ende könntest Du die Hilfsspalte nach der Orginalspalte kopieren und duch die Werte ersetzen.

Gruß Matthias


  

Betrifft: war für Karl Heinz, sorry ;o) oT von: Matthias L
Geschrieben am: 26.01.2012 17:07:17




  

Betrifft: Danke für die Super-Hilfe von: Karl-Heinz
Geschrieben am: 27.01.2012 11:17:44

Hallo,
Euch beiden vielen Dank für die "Nachhilfe" in Excel. So einfach geht das. Habe etwas neues gelernt von Josef und Matthias hat mir meinen Denkfehler bei der Wenn-Abfrage aufgezeigt.
Vielen Dank und ein schönes Wochenende.
Karl Heinz


  

Betrifft: Danke für die Super-Hilfe von: Karl-Heinz
Geschrieben am: 27.01.2012 11:25:24

Hallo,
Euch beiden vielen Dank für die "Nachhilfe" in Excel. So einfach geht das. Habe etwas neues gelernt von Josef und Matthias hat mir meinen Denkfehler bei der Wenn-Abfrage aufgezeigt.
Vielen Dank und ein schönes Wochenende.
Karl Heinz


Beiträge aus den Excel-Beispielen zum Thema "Wenn A2 leer, dann Wert A1 füllen"