Microsoft Excel

Herbers Excel/VBA-Archiv

Auswertung mit Datenbankfunktionen | Herbers Excel-Forum


Betrifft: Auswertung mit Datenbankfunktionen von: Hühnerfuß
Geschrieben am: 08.02.2012 16:46:05

Guten Tag,

kann mir jemand bei der Lösung der folgenden Problemstellung helfen?

Ich habe einen Datenbestand von etwa 3000 Zeilen und u.a. die Spalten

Kriterium | Anzahl | Stunden

In Spalte 'Kriterium' stehen Werte zwischen 1 und 3, in Spalte 'Anzahl' Ganzzahlen und in Spalte 'Stunden' Zeitwerte als Dezimalzahlen.

Die Werte in Spalte 'Anzahl' und 'Stunden' sollen multipliziert und eine Gesamtsumme gebildet werden.
Unterschieden werden soll nach den Kriterien, d.h. es sollen 3 Endsummen entstehen.

Anders gesagt, ich suche eine Funktion, die die Spalte 'Kriterium' nach '1' durchsucht, bei Treffer 'Anzahl' und 'Stunden' multipliziert und dann die Summe aller für '1' durchgeführten Multiplikationen liefert.

Kann man so etwas mit den EXCEL-Datenbankfunktionen bewerkstelligen oder hat jemand eine andere Lösung?

Ich könnte natürlich mit Hilfsspalten in der Tabelle arbeiten und dort zunächst die Berechnungen machen, aber das würde mir nicht so sehr gefallen.

Vielen Dank schon mal für das Lesen und ggf. Nachdenken :-)

Ich freue mich auf Antworten

Mike

  

Betrifft: AW: Auswertung mit Datenbankfunktionen von: Rudi Maintaire
Geschrieben am: 08.02.2012 17:11:02

Hallo,
einfach mit Summenprodukt.
=SUMMENPRODUKT((A2:A3000=1)*B2:B3000*C2:C3000)

Gruß
Rudi


  

Betrifft: AW: Auswertung mit Datenbankfunktionen von: Josef Ehrensberger
Geschrieben am: 08.02.2012 17:14:46


Hallo Mike,

SUMMENPRODUKT() ist dein Freund, der Pivot.

Tabelle2

 ABCDEFGHI
1KriteriumAnzahlStunden   KriteruimSumme 
2325,611,2  136 
3334,413,2  251 
4322,44,8  3113,2 
5221020     
6123,26,4     
73122     
8129,418,8     
91133     
10319,29,2     
11236,619,8     
121133     
13334,814,4     
14314,84,8     
15114,84,8     
16216,86,8     
17329,418,8     
18222,24,4     
1933824     
20333,610,8     
21         

Formeln der Tabelle
ZelleFormel
H2=SUMMENPRODUKT(($A$2:$A$20=G2)*$B$2:$B$20*$C$2:$C$20)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Auswertung mit Datenbankfunktionen von: Oberschlumpf
Geschrieben am: 08.02.2012 17:18:55

Hi Mike

versuch mal (ungetestet):

Sub sbSummen()

    Dim ldbSum1 As Double, ldbSum3 As Double, ldbSum3 As Double, liRow As Integer

        For liRow = 1 To Cells(Rows.Count, KRITERIENSPALTE).End(xlUp).Row
            If Range("KRITERIENSPALTE" & liRow).Value = 1 Then
                ldbSum1 = ldbSum1 + ldbSum1
            End If
            If Range("KRITERIENSPALTE" & liRow).Value = 2 Then
                ldbSum2 = ldbSum2 + ldbSum2
            End If
            If Range("KRITERIENSPALTE" & liRow).Value = 3 Then
                ldbSum3 = ldbSum3 + ldbSum3
            End If
        Next

    Range("ZIELZELLE").Value = ldbSum1
    Range("ZIELZELLE").Value = ldbSum2
    Range("ZIELZELLE").Value = ldbSum3

End Sub
KRITERIENSPALTE = die Spaltenzahl, in der die Kriterien stehen
ZIELZELLE = die Zellen, in denen die Summen stehen sollen

Hilfts?
Ich konnte nicht testen, da du keine Bsp-Datei zeigst.

Ciao
Thorsten


  

Betrifft: dafür brauchts aber sicher kein VBA! o.T. von: Josef Ehrensberger
Geschrieben am: 08.02.2012 17:20:28

« Gruß Sepp »



  

Betrifft: funzt aber auch ;-) owT von: Oberschlumpf
Geschrieben am: 08.02.2012 17:24:40




  

Betrifft: Auswertung mit PIVOT-Tabelle von: NoNet
Geschrieben am: 08.02.2012 17:23:01

Hallo Mike,

verwende dazu eine PIVOT-Tabelle :

- Gib in Spalte D ("Produkt") eine Formel zum Multilpizieren der Anzahl*Stunden ein : =B2*C2 (nach unten kopieren)
- Erstelle per "Daten - PivotTable" eine PIVOT-Tabelle
- Ziehe in Schritt3 ("Layout") das Feld "Kriterium" in den ZEILEN-Bereich, das Feld "Produkt" in den DATEN-Bereich

Ergebnis : PIVOT-Tabelle in Spalte F:G


Gruß, NoNet


  

Betrifft: AW: Auswertung mit Datenbankfunktionen von: Hühnerfuß
Geschrieben am: 08.02.2012 17:48:07

Hallo Leute,

ich bin begeistert!

Vielen Dank für die schnellen und kompetenten Antworten.

Rudis Lösung mit Summenprodukt funzt einfach, schlicht und schnell. Auch die anderen Lösungen werde ich mir noch zu Gemüte führen.

Auf jeden Fall nochmals besten Dank, ihr habt mir sehr weitergeholfen und ich habe wieder eine Menge dazu gelernt.

Bis demnächst mal wieder

Mike


Beiträge aus den Excel-Beispielen zum Thema "Auswertung mit Datenbankfunktionen"