Microsoft Excel

Herbers Excel/VBA-Archiv

Funktion ==> variabler Bereich | Herbers Excel-Forum


Betrifft: Funktion ==> variabler Bereich von: Burghard
Geschrieben am: 11.02.2012 22:13:27

Hallo,

wie kann ich die u.g. Formel so ändern, dass nicht der feste Wert von Spalte B mit B69 und von Spalte C mit C69 vorgegeben ist, sondern die letzte benutzte Zelle in Spalte B bzw in Spalte C in der Formel genommen wird?

Die Formel funktioniert, allerdings nur bis zum festen Zeilenwert von B69 bzw. C69. Dies würde ich gerne variabel haben.

Ausgangsformel: (Matrix) funktioniert:

=WENN(ZEILE(A1)>ZÄHLENWENN($C$2:$C$69;"x")/2;"";KGRÖSSTE(KGRÖSSTE(WENN($C$2:$C$69="x"; $B$2:$B$69+$B$2:$B$69*10^-5);ZEILE(INDIREKT("1:"&ZÄHLENWENN($C$2:$C$69;"x")))) +KKLEINSTE(WENN($C$2:$C$69="x";$B$2:$B$69+$B$2:$B$69*10^-10); ZEILE(INDIREKT("1:"&ZÄHLENWENN($C$2:$C$69;"x"))));(ZEILE(A1)-1)*2+1))
~f~

Idee (funktioniert aber nicht): (auch als Matrix)

~f~
=WENN(ZEILE(A1)>ZÄHLENWENN($C$2:lSpalte(C1);"x")/2;"";KGRÖSSTE(KGRÖSSTE(WENN($C$2:lSpalte(C1)="x"; $B$2:lSpalte(B1)+$B$2:lSpalte(B1)*10^-5);ZEILE(INDIREKT("1:"&ZÄHLENWENN($C$2:lSpalte(C1);"x")))) +KKLEINSTE(WENN($C$2:lSpalte(C1)="x";$B$2:lSpalte(B1)+$B$2:lSpalte(B1)*10^-10); ZEILE(INDIREKT("1:"&ZÄHLENWENN($C$2:lSpalte(C1);"x"))));(ZEILE(A1)-1)*2+1))

Hilfe wäre nett.

Schönen Gruß

Burghard

  

Betrifft: AW: Funktion ==> variabler Bereich von: Josef Ehrensberger
Geschrieben am: 11.02.2012 22:17:24


Hallo Burghard,

vergib doch für B2:Bx und C2:Cx dynamische Namen.

Für B2:Bx z.B. Name _B Bezieht sich auf =$B$2:INDEX($B:$B);ANZAHL2($B:$B))




« Gruß Sepp »



  

Betrifft: AW: von: Burghard
Geschrieben am: 12.02.2012 14:28:46

Hallo Sepp,

vielen Dank für den Tipp und Lösungsweg. Ich werde mir die Sache mal in Ruhe anschauen.

Schönen Gruß

Burghard


Beiträge aus den Excel-Beispielen zum Thema "Funktion ==> variabler Bereich"