Live-Forum - Die aktuellen Beiträge
Datum
Titel
19.07.2024 18:36:17
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Bestimmte Daten aus einer Tabelle ausgeben

Bestimmte Daten aus einer Tabelle ausgeben
Christian
Hallo zusammen,
bevor ich weiter rätsel und irgendwie heute eh alles ein wenig schwer fällt, frag ich mal in die Runde. Vielleicht hat ja einer eine super Idee ;)
Folgendes: Ich habe eine Tabelle mit 2 Spalten. In Spalte 1 steht mehrfach "Apfel" und "Birne" und in Spalte 2 "A" und "B". Jetzt möchte ich in einer anderen Tabelle eine Formel, die aus der ersten Tabelle nach "Apfel" sucht (das wäre mein Suchkriterium) und jede Zeile ausgibt, in der "Apfel" steht. Ich brauche also eine Formel oder ein VBA, das ich in mehrere Zeilen der Tabelle 2 reinschreibe und das, je nach Suchkriterium, mir die richtigen Daten dann auflistet. Ungefähr klar? :( Ist heute nicht mein Tag ...
Viele Grüße und danke vorab!

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Bestimmte Daten aus einer Tabelle ausgeben
14.02.2012 16:35:57
Rudi
Hallo,
alter Hut.
 ABCDEF
1AB ApfelAB
2ApfelA  ApfelA
3BirneB  ApfelD
4PflaumeC  ApfelG
5ApfelD    
6BirneE    
7PflaumeF    
8ApfelG    
9BirneH    
10PflaumeI    

ZelleFormel
E2{=WENN(ZEILE(A1)>ZÄHLENWENN(A$1:A$1000;$D$1);"";INDEX($A$1:$A$1000;KKLEINSTE(WENN($A$1:$A$1000=$D$1;ZEILE($1:$1000);"");ZEILE(A1))))}
F2{=WENN(ZEILE(A1)>ZÄHLENWENN(A$1:A$1000;$D$1);"";INDEX($B$1:$B$1000;KKLEINSTE(WENN($A$1:$A$1000=$D$1;ZEILE($1:$1000);"");ZEILE(B1))))}
E3{=WENN(ZEILE(A2)>ZÄHLENWENN(A$1:A$1000;$D$1);"";INDEX($A$1:$A$1000;KKLEINSTE(WENN($A$1:$A$1000=$D$1;ZEILE($1:$1000);"");ZEILE(A2))))}
F3{=WENN(ZEILE(A2)>ZÄHLENWENN(A$1:A$1000;$D$1);"";INDEX($B$1:$B$1000;KKLEINSTE(WENN($A$1:$A$1000=$D$1;ZEILE($1:$1000);"");ZEILE(B2))))}
Achtung, Matrixformel!
Die geschweiften Klammern{} nicht eingeben,
sondern die Zelle mit
Shift + Strg + Enter
verlassen statt Enter alleine.

Gruß
Rudi
Anzeige
AW: Bestimmte Daten aus einer Tabelle ausgeben
14.02.2012 16:41:43
Christian
Sieht gut aus. Probiere ich dann mal :) Vielen Dank!
AW: Bestimmte Daten aus einer Tabelle ausgeben
15.02.2012 11:44:49
ludicla
Hallo Christian,
warum nicht mit einer Pivot-Tabelle ?
Gruss Ludicla

205 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige