Microsoft Excel

Herbers Excel/VBA-Archiv

Zeitdarstellung für Räume pro Woche | Herbers Excel-Forum


Betrifft: Zeitdarstellung für Räume pro Woche von: Andre´
Geschrieben am: 16.02.2012 16:13:30

Hallo alle zusammen,

Es gibt ein Blatt "Erfassung" wo der Raum, Datum und die Zeit von/ bis eingetragen wird.
Nun soll im Blatt "Auswertung" im Bereich B6:P26 überall eine 1 stehen, wenn die Bedingung erfüllt ist.
Kriterien wären, Raum, Jahr mit KW, Wochentag und die Zeit.

Ich habe es bereits mit Summenprodukt probiert, hat aber nicht funktioniert.

Ich würde mich sehr freuen, wenn mir jemand eine Formel liefern könnte.

Im angehängten Bsp.: habe ich manuell die Einsen eingetragen, so wie die Bedingungen gegeben sind.

https://www.herber.de/bbs/user/78951.xls

Vielen Dank im Voraus!

MFG Andre

  

Betrifft: AW: Zeitdarstellung für Räume pro Woche von: Rudi Maintaire
Geschrieben am: 16.02.2012 16:30:27

Hallo,
SUMMENPRODUKT ist schon richtig.

=SUMMENPRODUKT((Erfassung!$F$2:$F$6=$B$1)*(Erfassung!$E$2:$E$6=B$5)*(Erfassung!$G$2:$G$6<=$A6) *(Erfassung!$H$2:$H$6>=$A6)*(Erfassung!$A$2:$A$6=$B$3))

$B$3 jeweils an den Raum anpassen.

Gruß
Rudi


  

Betrifft: AW: Zeitdarstellung für Räume pro Woche von: Andre´
Geschrieben am: 16.02.2012 18:24:08

Hallo Rudi,
danke für die schnelle Antwort, es funktioniert wie gewünscht!

Hatte mit der Klammer und dem Größergleich-Zeichen Probleme:-((

MFG Andre


Beiträge aus den Excel-Beispielen zum Thema "Zeitdarstellung für Räume pro Woche"