Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt mit Bedingung Zellen nicht DIV/0 | Herbers Excel-Forum


Betrifft: Summenprodukt mit Bedingung Zellen nicht DIV/0 von: Uli
Geschrieben am: 17.02.2012 13:30:03

Hallo Experten,
habe ein kleines Problemchen mit einem Summenprodukt. In einer Spalte, die ein Ergebnis einer Division ist, stehen folgende Werte:

DIV/0
DIV/0
DIV/0
2
5

Nun möchte ich mit Summenprodukt die Zahlen in dieser Spalte addieren. Also das Ergebnis 5+2 = 10 erhalten.
Was mir schon geglückt ist, ist die Anzahl der Zellen, die eine ZAhl enthalten, zu ermitteln:

=SUMMENPRODUKT((NICHT(ISTFEHLER(A1:A5)))*1)

Ich würde das Problen gerne über ein Summenprodukt lösen, auch wenn es vielleicht mit Kanonen auf Spatzen.... ist, damit ich Eure eventuelle Hilfe auch für andere Summenprodukt-Formeln verwenden kann.
Aus gleichem Grund möchte ich den DIV/0-Fehler auch nicht vorher schon abfangen.
Ist im Moment meine Lieblingsformel.... :)

Hoffe Ihr könnt mir weiterhelfen.

Gruß
Uli

  

Betrifft: AW: Summenprodukt mit Bedingung Zellen nicht DIV/0 von: Rudi Maintaire
Geschrieben am: 17.02.2012 13:46:01

Hallo,
schließ div/0 doch in der Formel aus, die den Fehler verursacht.

Gruß
Rudi


  

Betrifft: AW: Summenprodukt mit Bedingung Zellen nicht DIV/0 von: Uli
Geschrieben am: 17.02.2012 13:55:02

Hallo Rudi,

das wäre mit Sicherheit eine Möglichkeit.
Zum einen ist die die Formel, die als Ergebnis #DIV/0 ergibt, jetzt schon extrem lang (4 Zeilen im Formel-Fenster aufgrund von vielen wenn/dann Verschachtelungen) und durch das Abfangen des Fehlers mit wenn(istfehler(formel);0;Formel) würde sich die Länge ja verdoppeln und zum anderen suche ich nach einer generellen Lösung.
Falls es keine Möglichkeit in der Summenprodukt-Formel gibt, werde ich allerdings auf diese Lösung zurückkommen.
Das Einfügen einer weiteren Spalte möchte ich allerdings grundsätzlich vermeiden.

Gruß
Uli


  

Betrifft: AW: Summenprodukt mit Bedingung Zellen nicht DIV/0 von: Rudi Maintaire
Geschrieben am: 17.02.2012 13:58:07

Hallo,
...würde sich die Länge ja verdoppeln...
in 2007 gibt's doch die Funktion WENNFEHLER()
=WENNFEHLER(lange Formel;0)

Gruß
Rudi


  

Betrifft: AW: Summenprodukt mit Bedingung Zellen nicht DIV/0 von: Uli
Geschrieben am: 17.02.2012 14:06:43

Hallo Rudi,
das kannte ich noch nicht, vielen Dank!
Macht viele Sachen einfacher.
Gruß
Uli


  

Betrifft: AW: Summenprodukt mit Bedingung Zellen nicht DIV/0 von: Reinhard
Geschrieben am: 18.02.2012 11:54:14

Hallo Uli,

zeig doch mal die komplette Formel.

Gruß
REinhard


  

Betrifft: AW: Summenprodukt mit Bedingung Zellen nicht DIV/0 von: JoWE
Geschrieben am: 17.02.2012 14:00:37

Hallo Uli,

so geht*s doch:
=SUMMENPRODUKT(A1:A5)
Aus der Excelhilfe zur Funktion:
Matrixelemente, die keine numerischen Ausdrücke sind,
behandelt SUMMENPRODUKT so, als wären sie mit 0 belegt
.

Gruß
Jochen


  

Betrifft: AW: Summenprodukt mit Bedingung Zellen nicht DIV/0 von: Uli
Geschrieben am: 17.02.2012 14:17:58

Hallo Jochen,

das funktioniert bei mir nicht.
Es funktioniert, wenn ich z.B. in einer Spalte Text und Werte stehen habe. Dann werden nur die Werte berücksichtigt.
Bei Fehlern in Zellen habe ich kein Ergebnis erhalten

Gruß
Uli


  

Betrifft: AW: Summenprodukt mit Bedingung Zellen nicht DIV/0 von: Josef Ehrensberger
Geschrieben am: 17.02.2012 13:47:59


Hallo Uli,

nicht mit SUMMENPRODUKT().

Tabelle1

 ABCD
15  21
2#DIV/0!   
37   
4#DIV/0!   
59   
6#DIV/0!   

Formeln der Tabelle
ZelleFormel
D1{=SUMME(WENN(ISTZAHL(A1:A6); A1:A6;0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Summenprodukt mit Bedingung Zellen nicht DIV/0 von: Uli
Geschrieben am: 17.02.2012 14:11:28

Hallo Sepp,

wenn es mit einem Summenprodukt nicht geht, werde ich es so machen. Vielen Dank.
Habe eine Lösung über ein Summenprodukt gesucht, um theoretisch noch mehrere Bedingungen abzufragen und die Werte eventuell noch mit anderen, aus nebenstehenden Zellen, zu multiplizieren.

Gruß
Uli


  

Betrifft: das geht doch mit dieser Formel auch! o.T. von: Josef Ehrensberger
Geschrieben am: 17.02.2012 14:14:32

« Gruß Sepp »



  

Betrifft: AW: das geht doch mit dieser Formel auch! o.T. von: Uli
Geschrieben am: 17.02.2012 17:20:33

Hallo Sepp,
hab ein bisschen probiert, es allerdings nicht hinbekommen.
folgendes Beispiel:

#DIV/0___1
#DIV/0___2
#DIV/0___3
2________4
5________5
7________6

Du hast ja für mein erstes Problem folgende Formel vorgeschlagen:

{=SUMME(WENN(ISTZAHL(A1:A6); A1:A6;0))}

Diese würde ich jetzt gerne um eine zusätzliche Bedingung (A1:A6 > 3) erweitern und dann ein Summenprodukt aus den beiden Spalten ausrechnen lassen.
Das Ergebnis sollte dann sein: 5x5+7x6=67
Geht das mit dieser Formel?

Gruß
Uli


  

Betrifft: AW: das geht doch mit dieser Formel auch! o.T. von: Rudi Maintaire
Geschrieben am: 17.02.2012 21:03:20

Hallo,
das ist doch mal ein konkretes Beispiel

{=SUMME(WENN(ISTZAHL(A1:A6); (A1:A6>3)*(A1:A6)*(B1:B6);0))}

Gruß
Rudi


  

Betrifft: AW: das geht doch mit dieser Formel auch! o.T. von: Uli
Geschrieben am: 18.02.2012 00:58:01

Hallo Rudi,
vielen Dank. Wäre nie darauf gekommen, dass die zweite Bedingung in den "dann-Teil" der Formel muss.
Habe es mit "Wenn(und(" versucht, bin aber kläglich gescheitert.
Morgen versuche ich mal die Lösung zu verstehen... :)
Gruß
Uli


  

Betrifft: AW: AW: 2 + 5 = 10 ??? oT von: JoWE
Geschrieben am: 17.02.2012 13:55:45




  

Betrifft: AW: AW: 2 + 5 = 10 ??? oT von: Uli
Geschrieben am: 17.02.2012 14:18:47

da siehste mal, warum ich Excel rechnen lassen will....:)


Beiträge aus den Excel-Beispielen zum Thema "Summenprodukt mit Bedingung Zellen nicht DIV/0"