Microsoft Excel

Herbers Excel/VBA-Archiv

Schnittmenge zweier Zeiträume | Herbers Excel-Forum


Betrifft: Schnittmenge zweier Zeiträume von: TCO99
Geschrieben am: 17.02.2012 22:28:30

Hallo zusammen,

nach langer Zeit habe ich doch wieder ein Problem was ich nicht gelöst bekomme.

Ich habe zwei Zeiträume. Ich brauche als Ergebnis die Antwort, ob die beiden Zeiträume eine Schnittmenge besitzen oder nicht. Mit Hilfsspalten bekäme ich es hin aber eine Formellösung wäre viel schöner. Weiß jemand eine Lösung für mich?

Dazu habe ich eine Beispielmappe gemacht:
https://www.herber.de/bbs/user/78974.xls

Ich danke im voraus.

Freundliche Grüße
Erdogan

PS: Feedback ist selbstverständlich!

  

Betrifft: Wenn man jetzt noch wüsste, welcher Zeitraum ... von: Luc:-?
Geschrieben am: 17.02.2012 22:58:35

…mit welchem anderen die gemeinsame Schnittmenge haben soll, Erdogan…? ;->
Gruß+schöWE, Luc :-?


  

Betrifft: AW: Wenn man jetzt noch wüsste, welcher Zeitraum ... von: TCO99
Geschrieben am: 18.02.2012 12:39:08

Hi Luc,

ich dachte, die Überschriften wären aussagekräftig.
Daher jetzt eine bessere Erläuterung:

in den ersten beiden Spalten stehen das Einstellungsdatum und eventuell das Kündigungsdatum des Mitarbeiters. In den folgenden zwei Spalten steht das Start- und das Enddatum des Zeitraumes für den ich wissen möchte, ob der Mitarbeiter in diesem Zeitraum angestellt war.

Viele Grüße
Erdogan


  

Betrifft: AW: Schnittmenge zweier Zeiträume von: Josef Ehrensberger
Geschrieben am: 18.02.2012 13:03:14


Hallo Erdogan,

so?

Tabelle1

 ABCDEFG
1       
2 EintrittsdatumAustrittsdatumStartzeitEndzeitErgebnisOder
3 02.05.2005 01.05.200531.05.200530Überschneidung
4 01.01.200128.10.200101.05.200531.05.20050 
5 01.01.2002 01.05.200531.05.200531Überschneidung
6 01.01.2003 01.05.200531.05.200531Überschneidung
7 01.01.2004 01.05.200531.05.200531Überschneidung
8 01.01.2005 01.05.200531.05.200531Überschneidung
9 01.01.200628.10.200601.05.200531.05.20050 
10 01.01.2007 01.05.200531.05.20050 
11 01.01.200827.10.200801.05.200531.05.20050 
12 01.01.2009 01.05.200531.05.20050 
13 01.01.2010 01.05.200531.05.20050 
14 01.01.201128.10.201101.05.200531.05.20050 
15 01.01.2012 01.05.200531.05.20050 

Formeln der Tabelle
ZelleFormel
F3=MAX(;MIN(WENN(C3<>"";C3;HEUTE()); E3)+1-MAX(B3;D3))
G3=WENN(MAX(;MIN(WENN(C3<>"";C3;HEUTE()); E3)+1-MAX(B3;D3)); "Überschneidung";"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Schnittmenge zweier Zeiträume von: TCO99
Geschrieben am: 18.02.2012 13:25:42

Hallo Josef,

ich verstehe die Formel zwar nicht aber sie funktioniert genauso wie ich es mit gewünscht habe :-)
Ich habe die Formel in meine Datei eingebaut was mir viele Hilfsspalten erspart hat.

Ich danke dir ganz herzlich!!!

Viele Grüße
Erdogan


Beiträge aus den Excel-Beispielen zum Thema "Schnittmenge zweier Zeiträume "