Microsoft Excel

Herbers Excel/VBA-Archiv

Wertigkeit? | Herbers Excel-Forum


Betrifft: Wertigkeit? von: Snewi
Geschrieben am: 17.02.2012 23:50:34

Hallo ich habe folgende Werte:

        AnzahlWerte	Mittelwert
Jan 12	620	446,8
Feb 12	540	438,3
Mrz 12	340	430,8
Apr 12	639	433,7
Mai 12	450	417,9
Jun 12	610	427,1
Jul 12	540	437,3
Aug 12	555	433,4
Sep 12	578	430,2
Okt 12	600	435,8
Nov 12	546	416,2
Dez 12	250	427,0
der Wert für z.B. Januar ist der Mittelwert der 620 Werte!
Jetzt kann ich für das Jahr doch schlecht den Mittelwert vom Mittelwert nehmen!
Gibt es in Excel was um das nach Wertigkeit der aufgelaufenen Werte zu ermitteln!
Oder bin ich vielleicht auf dem Holzweg und ich muss es komplett anders machen?

gruß

  

Betrifft: AW: Wertigkeit? von: Thommes
Geschrieben am: 18.02.2012 02:56:54

Hi Snewi,

du musst für jeden Monat die Anzahl der Werte mit dem Mittelwert multiplizieren, diese 12 Werte zusammenzählen und durch die Summe aller Werte dividieren.
Also Jan 12 = 620 * 446,8 = 227016, Feb 12 = 540 * 438,3 usw.
Das ergibt aufaddiert 2706700,1 und es sind 6268 Werte, d.h. der Gesamt-Mittelwert ist 431,828350350989

Gruß


  

Betrifft: Mittelwert gesamt - SUMMENPRODUKT von: Erich G.
Geschrieben am: 18.02.2012 07:22:06

Hi,
Thommes hat schon beschrieben, was man machen müsste. Das geht einfach und schnell mit der Formel in C15:

 ABC
1MonatAnzahlWerteMittelwert
2Jan 12620446,8
3Feb 12540438,3
4Mrz 12340430,8
5Apr 12639433,7
6Mai 12450417,9
7Jun 12610427,1
8Jul 12540437,3
9Aug 12555433,4
10Sep 12578430,2
11Okt 12600435,8
12Nov 12546416,2
13Dez 12250427
14   
15Jahr 20126268431,8283504

Formeln der Tabelle
ZelleFormel
B15=SUMME(B2:B13)
C15=SUMMENPRODUKT(B2:B13;C2:C13)/B15

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Mittelwert gesamt - SUMMENPRODUKT von: Snewi
Geschrieben am: 18.02.2012 11:34:19

Danke sowas hab ich gesucht :-)

Gruß


  

Betrifft: AW: Mittelwert gesamt - SUMMENPRODUKT von: Snewi
Geschrieben am: 18.02.2012 11:37:15

Aber was ist wenn ich die 12 Monate als festen Bereich nehmen und es aber noch keine Werte für die letzten drei Monate gibt?

Gruß


  

Betrifft: drei Monate fehlen noch - na und? von: Erich G.
Geschrieben am: 18.02.2012 12:17:01

Hi,
dann ist das:

 ABC
1MonatAnzahlWerteMittelwert
2Jan 12620446,8
3Feb 12540438,3
4Mrz 12340430,8
5Apr 12639433,7
6Mai 12450417,9
7Jun 12610427,1
8Jul 12540437,3
9Aug 12555433,4
10Sep 12578430,2
11Okt 12  
12Nov 12  
13Dez 12  
14   
15Jahr 20124872433,3384442

Formeln der Tabelle
ZelleFormel
B15=SUMME(B2:B13)
C15=SUMMENPRODUKT(B2:B13;C2:C13)/B15

Aber wo ist jetzt das Problem?

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: drei Monate fehlen noch - na und? von: Snewi
Geschrieben am: 18.02.2012 12:20:56

Hatte natürlich die Werteanzahl nicht gelöscht :-)

Danke