Live-Forum - Die aktuellen Beiträge
Datum
Titel
15.07.2024 16:00:57
15.07.2024 15:41:38
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Anzahl Tage je Monat pro Artikel

Anzahl Tage je Monat pro Artikel
Fuxxx
Hallo,
ich habe das Tabellenblatt "Daten" mit verschiedenen Artikeln in Spalte A gefüllt (ca. 10000 Zeilen).
Die Artikel kommen in Spalte A mehrfach vor. Der eine Artikel eben mehr der andere Artikel eben weniger.
In Spalte B habe ich quasi hinter den Artikeln das "Abgangsdatum" stehen,....folglich ebenfalls ca. 10000 Zeilen.
Nun möchte ich in dem Tabellenblatt "Ergebnis" pro Artikel und dje Monat die Anzahl der "Versand- bzw. Abgangstage" haben.
Diese Tabelle habe ich wie folgt aufgebaut:
1.) A2 bis A5000 die Artikel, (A1 = "Artikelbezeichnung")
2.) ab B1 bis M1 die Monate in Form von 1, 2, 3, usw. bis 12
3.) in Zelle B2 müsste dann eine Formel, die sich auf B1 (=Monat) und A2 (=Artikel) bezieht und dann im anderen Tabellenblatt ("Daten") in Abhängigkeit davon die Anzahl der Abgangstage im Januar angibt.
Hab das schon irgendwie mit Summenprofukt und Zählenwenn versucht,...bekomme es aber nicht hin.
Wenn ich einmal die Basisformel hätte, dann könnte ich es schön auf die anderen Zellen verteilen.
Vielen Dank für Eure Hilfe!
Gruß,
Fuxx

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Anzahl Tage je Monat pro Artikel
21.02.2012 12:55:21
Rudi
Hallo,
=SUMMENPRODUKT((Daten!$A$2:$A$10000=$A2)*(MONAT(Daten!$B$2:$B$10000)=B$1)*(Daten!$B$2:$B$10000""))
Gruß
Rudi
AW: Anzahl Tage je Monat pro Artikel
21.02.2012 13:25:28
Fuxx
Hallo Rudi,
vielen Dank für die schnelle Antwort.
Dieses Ergebnis habe ich auch schon über PIVOT hinbekommen.
Jedoch werden dabei insgesamt die Anzahl der aufgeführten Datum ermittelt.
Wenn ich z.B. den Artikel A am 15.01.2012 verschickt habe und dann in der Tabelle der Artikel A weiter unten noch mal am 15.01.2012 vorkommt, dann wird durch Deine Formel das Ergebnis 2 ermittelt. Genauso wie bei PIVOT.
Ich möchte jedoch, dass dies als 1 gezählt wird, da ja auch nur 1 Tag betroffen ist.
Es soll also die Anzahl "verschiedener Tage" ermittelt werden.
Hat dafür jemand eine Idee?
Viele Güße,
Fuxx
Anzeige
AW: Anzahl Tage je Monat pro Artikel
21.02.2012 15:26:59
Rudi
Hallo,
da fällt mir nur was mit Hilfspalte ein.
 ABCDEFGH
1ArtikelDatumTest   12
2a15. Jan15.01.2012  a11
3b16. Jan16.01.2012  b30
4c17. Jan17.01.2012  c30
5d18. Jan18.01.2012  d10
6e19. Jan19.01.2012  e10
7a15. Jan      
8b21. Jan21.01.2012     
9c22. Jan22.01.2012     
10a15. Feb15.02.2012     
11b24. Jan24.01.2012     
12c25. Jan25.01.2012     

ZelleFormel
C2=WENN(SUMMENPRODUKT((A$2:A2=A2)*(B$2:B2=B2))=1;B2;"")
G2{=SUMME(WENN(ISTZAHL($C$2:$C$12);($A$2:$A$12=$F2)*(MONAT($C$2:$C$12)=G$1);0))}
Achtung, Matrixformel!
Die geschweiften Klammern{} nicht eingeben,
sondern die Zelle mit
Shift + Strg + Enter
verlassen statt Enter alleine.

Gruß
Rudi
Anzeige
AW: Anzahl Tage je Monat pro Artikel
22.02.2012 10:20:20
Fuxx
Hallo Rudi,
das passt,....vielen Dank!

315 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige