Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen mehrerer Kriterien



Excel-Version: 10.0 (Office XP)

Betrifft: Zählen mehrerer Kriterien
von: Gerald
Geschrieben am: 07.06.2002 - 07:27:43

Hallo, folgendes Problem:

In Spalte A stehen verschiedene Namen, die auch mehrmals vorkommen können (z.B. der name KLAUS)
In Spalte B stehen verschiedene Werte zu den einzelnen namen (zahlen zwischen 1 und 2000).
Excel soll nun in einer nächsten Spalte ausdrücken, wie oft z.B. der Name Klaus in Spalte A mit einem Wert in Spalte B >42 vorhanden ist.

  

Re: Zählen mehrerer Kriterien
von: Harald Kapp
Geschrieben am: 07.06.2002 - 07:41:33

Hallo Gerald,
zum Beispiel so:

MS Excel von Harald Kapp an Gerald
 ABCD
1Klaus100Klaus3
2Klaus10Peter0
3Peter40Günther1
4Peter12 
5Klaus105 
6Günther88 
7Peter17 
8Klaus53 
9   

In D1 steht:
=SUMME(WENN($A$1:$A$8=$C1;1;0)*WENN($B$1:$B$8>42;1;0))
Als Matrixformel eingeben, also nicht mit ENTER abschließen, sondern mit SHIFT-CTRL-ENTER beenden. Excel setzt dann automatisch geschweifte Klammern um die Formel.

Gruß Harald

P.S.: Ich weiß, es gibt auch andere Lösungen, aber diese hier war gearde zur Hand.

  

Re: Zählen mehrerer Kriterien
von: Gerald
Geschrieben am: 07.06.2002 - 08:30:29

Hallo Harald,
danke für die schnelle Hilfe.
Noch eine frage, wie mache ich es wenn die lösung von Spalte C und D in einer neuen Arbeitsmappe stehen sollen ?

 

Beiträge aus den Excel-Beispielen zum Thema "Zählen mehrerer Kriterien"