Microsoft Excel

Herbers Excel/VBA-Archiv

Summe getrennt nach Euro und Cent



Excel-Version: 10.0 (Office XP)

Betrifft: Summe getrennt nach Euro und Cent
von: Mike
Geschrieben am: 09.06.2002 - 20:01:35

Hallo zusammen,
ich habe im Zellbereich B20:B33 Euro-Beträge und in C20:C33 die Cent-Beträge.
Wie kann ich nun erreichen, dass in C34 die Summe der Cent-Beträge gebildet wird und in B34 die Summe der Euro-Beträge.
Natürlich müssten die normalen Additionsregeln beachtet werden.
Wenn also die Summe der Cent-Beträge z.B. 120 ist, soll nur 20 stehen und der eine Euro der Euro-Betrag-Summe hinzuaddiert werden.

Gruß

Mike

  

Re: Summe getrennt nach Euro und Cent
von: Hajo
Geschrieben am: 09.06.2002 - 20:16:55

Hallo Mike

Euro
=SUMME(B2:B33)+GANZZAHL(SUMME(C2:C33)/100)

Cent
=SUMME(C2:C33)-GANZZAHL(SUMME(C2:C33)/100)*100

Gruß Hajo

  

Re: Summe getrennt nach Euro und Cent
von: Mike
Geschrieben am: 09.06.2002 - 20:24:36

Hallo Hajo,
danke für deine Hilfe. Klappt prima.

Gruß
Mike


  

Re: zu langsam
von: M@x
Geschrieben am: 09.06.2002 - 20:25:26

Hi
dafür alternativ und die Centformel kürzer
=SUMME(B20:B33)+GANZZAHL(SUMME(C20:C33)/100)
=REST((SUMME(C20:C33))/100;1)*100

Gruss

M@x

  

Re: zu langsam
von: Mike
Geschrieben am: 09.06.2002 - 21:42:12

Danke M@x,
auch mit deiner Formel klappt's.

 

Beiträge aus den Excel-Beispielen zum Thema "Summe getrennt nach Euro und Cent"