Microsoft Excel

Herbers Excel/VBA-Archiv

Bedingte Formatierung, Rechnen mit Stunden



Excel-Version: 8.0 (Office 97)

Betrifft: Bedingte Formatierung, Rechnen mit Stunden
von: Joachim
Geschrieben am: 11.06.2002 - 14:39:28

Hallo unbekannte Helfer,
mein Prblem:
Tabelle steht auf 1904-Datumswerte
Format von A1,B1,C1=[hh]:mm
Bedingte Formatierung von C1
1. C1=0 dann Schrift=gruen
2. C1<0 dann Schrift=rot
3. C1>0 dann Schrift=blau

Inhalt der Zellen:
A1=00:00 B1=00:00 C1=Summe(A1-B1) Ergebnis C1: 00:00 (gruen)-ok
A1=07:00 B1=08:00 C1=Summe(A1-B1) Ergebnis C1:-01:00 (rot) -ok
A1=07:00 B1=06:00 C1=Summe(A1-B1) Ergebnis C1: 01:00 (blau) -ok
A1=07:00 B1=07:00 C1=Summe(A1-B1) Ergebnis C1:-00:00 (rot) falsch

kann mir jemand sagen, was ich falsch gemacht habe!

  

Re: Bedingte Formatierung, Rechnen mit Stunden
von: Harald Kapp
Geschrieben am: 11.06.2002 - 14:57:33

Hallo Joachim,
folgendes machst Du falsch: Du verlässt Dich darauf, dass 0=0 ist.

Im Ernst: Beim Berechnen von A1-B1 sollte im 4. fall theoretisch genau 0 herauskommen, aber bedingt durch die Zahldarstellung mit begrenzter Genauigkeit kann es vorkommen, dass in der x-ten Stelle hinter dem Komma eben doch nicht genau 0 herauskommt. Bzw. sind da Sekunden "versteckt", die wegen der Formatierung [hh]:mm nicht angezeigt werden.

Ich vermute, wenigstens einer der beiden Werte ist berechnet (A1 oder B1 oder beide). Schreibe doch testweise mal von Hand 7:00 in beide Zellen. Bei mir kommt dann auch genau 0 heraus.

Wenn das Problem sich darin also zeigt, dann kannst DU mit etwas Runden nachhelfen:
=RUNDEN(24*60*(A1-B1);0)/(24*60)

Gruß Harald

 

Beiträge aus den Excel-Beispielen zum Thema "Bedingte Formatierung, Rechnen mit Stunden"