Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summenprodukt mit leerer Bedingung

Summenprodukt mit leerer Bedingung
Heinz
Liebe Excellenten,
einen schönen Abend an alle.
Ich arbeite gerne mit der Summenprodukt Formel
Jetzt möchte ich zu einer Datentabelle eine Abfrage mit der
Summenprodukt-Formel erstellen.
Dabei kann es sein, dass einzelne Bedingungen nicht belegt sind.
In diesem Fall soll die Formel diese Bedingung nicht berücksichtigen,
also "alles durchlassen".
Sobald ich etwas eintrage, soll sich die Formel am Eintrag orientieren.
Weil sich das schlecht erklären lässt, anbei die Datei dazu.
https://www.herber.de/bbs/user/79296.xlsx
Daneben ich ich in Worten mal geschrieben, was die Formel machen sollte ;-)
Vielleicht gibt es auch eine Lösung mit einem Platzhalter in der Zelle,
in welcher die Bedingung drin steht, also sowas wie "*" (=ist egal, was drin steht).
Ich freue mich auf Eure Vorschläge.
Heinz

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Summenprodukt mit leerer Bedingung
08.03.2012 21:59:27
Josef

Hallo Heinz,
Tabelle1

 ABCDEFG
1Summenprodukt mit leerer Bedingung      
2       
3       
4Muster1Muster2Muster3Wert1Wert2  
5TestBlau12417  
6TestGelb22622  
7KontrollBlau32834  
8KontrollGrün43031  
9ohneSilber53023  
10       
11       
12Abfragebereich      
13Muster1Muster2Muster3Wert1Wert2  
14 Blau 5251  
15KontrollBlau 2834  
16KontrollBlau200  
17       
18       

Formeln der Tabelle
ZelleFormel
D14=SUMMENPRODUKT(((Muster1=A14)+(A14=""))*((Muster2=B14)+(B14=""))*((Muster3=C14)+(C14=""))*Wert1)
E14=SUMMENPRODUKT(((Muster1=A14)+(A14=""))*((Muster2=B14)+(B14=""))*((Muster3=C14)+(C14=""))*Wert2)
Namen in Formeln
ZelleNameBezieht sich auf
D14Muster1=Tabelle1!$A$5:$A$9
D14Muster2=Tabelle1!$B$5:$B$9
D14Muster3=Tabelle1!$C$5:$C$9
D14Wert1=Tabelle1!$D$5:$D$9
E14Muster1=Tabelle1!$A$5:$A$9
E14Muster2=Tabelle1!$B$5:$B$9
E14Muster3=Tabelle1!$C$5:$C$9
E14Wert2=Tabelle1!$E$5:$E$9
Namen verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

« Gruß Sepp »

Anzeige
Super Sepp, genial und einfach oT
09.03.2012 21:08:01
Heinz

326 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige