Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt - ich dreh durch ... | Herbers Excel-Forum


Betrifft: Summenprodukt - ich dreh durch ... von: Andreas
Geschrieben am: 24.07.2012 22:02:04

Hallo Excel-Meister,

sicher wieder nur eine Kleinigkeit, aber ich sitze bereits seit Stunden und komme einfach nicht drauf:

Wie bekomme ich das Ergebnis in I2 ohne die Hilfsspalte hin?

Danke für jeden erlösenden Tip!

Gruß, Andreas.

Tabelle1

 ABCDEFGHI
1KATbelegtfrei Pauschale Hilfsspalte Ergebnis
2A274 30,4167 30,4167 59,4167
3A290   29  
4B240   24  

Spreadsheet Formulas
CellFormula
G2=MIN(SUMME(B2:C2); $E$2)*1
I2=SUMMENPRODUKT(($A$2:$A$4="A")*($G$2:$G$4))
G3=MIN(SUMME(B3:C3); $E$2)*1
G4=MIN(SUMME(B4:C4); $E$2)*1


Excel tables to the web >> Excel Jeanie HTML 4

  

Betrifft: AW: Summenprodukt - ich dreh durch ... von: Josef Ehrensberger
Geschrieben am: 24.07.2012 22:36:49


Hallo Andreas,

was hast du gegen Hilsspalten?

Tabelle1

 ABCDEFGHIJ
1KATbelegtfrei Pauschale   Ergebnis 
2A274 30,4167   59,4167 
3A290       
4B240       

Formeln der Tabelle
ZelleFormel
I2{=SUMME(WENN((A2:A4="A")*(B2:B4+C2:C4<E2); B2:B4+C2:C4;E2*(A2:A4="A")))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Summenprodukt - ich dreh durch ... von: Andreas
Geschrieben am: 24.07.2012 22:59:47

Hi Sepp,

vielen vielen Dank für die Rettung zu so später Stunde!

Naja, und abgesehen davon, dass ich im konkreten Fall das Layout der Datei nicht verändern darf, haftet 'Hilfsspalten' für mich immer der 'Makel' an, dass 'man es wohl einfach nicht besser hinbekommen hat' (vielleicht auch ein kleiner Spleen von mir) ...

Jedenfalls stelle ich mal wieder fest, dass ich mich noch intensiver mit der Funktionweise von Matrix-Formeln beschäftigen muss.

Nochmals Danke & gute Nacht!

Andreas