Microsoft Excel

Herbers Excel/VBA-Archiv

Formellösung Summenprodukt - nochmal | Herbers Excel-Forum


Betrifft: Formellösung Summenprodukt - nochmal von: WalterK
Geschrieben am: 29.07.2012 19:33:33

Hallo,

nachdem mir gestern von Boris so hervorragend geholfen wurde versuche ich es heute neuerlich: Gestern ging es um eine Formellösung für Zeile 4 und diese passt jetzt genau.

Heute frage ich an zu einer Formellösung für Zeile 5 meines Projekts. Auch dazu habe ich zur besseren Erläuterung eine Tabelle hochgeladen. Die genaue Beschreibung der Vorgabe habe ich in den Zeilen 14 bis 23 versucht dazustellen.

https://www.herber.de/bbs/user/81196.xls

Besten Dank für Eure Hilfe, Servus Walter

  

Betrifft: AW: Formellösung Summenprodukt - nochmal von: {Boris}
Geschrieben am: 29.07.2012 20:52:11

Hi Walter,

ziemlich kniffelig - daher auf die Schnelle erstmal eine Lösung mit Hilfsspalten.

AG26:
=WENN(($E26="A")*(F26<=$J$1)*((T26="")+($T26=30) +(WENN(T26<>"";F26/T26)*30<=$J$1)>0)*F26;$B26&$C26; "")

Nach rechts bis AR und nach unten bis Zeile 110 kopieren.

AS26:
=($E26="B")*(ZÄHLENWENN(AG$26:AG$33;$B26&$C26)>0)

Nach rechts bis BD und ebenfalls runter bis Zeile 110 kopieren.

Formel in F5 wird dadurch zum Knallfrosch:
=SUMMENPRODUKT(($E$26:$E$110="B")*AS26:AS110;F26:F110)

und nach rechts bis Spalte R kopieren.

VG, Boris


  

Betrifft: AW: Formellösung Summenprodukt - nochmal von: WalterK
Geschrieben am: 29.07.2012 21:23:38

Hallo Boris,

Deine Lösung mit Hilfsspalte funktioniert tiptop. Besten Dank dafür.

Dennoch hoffe ich noch auf eine Lösung ohne Hilfsspalten.

Danke für die Hilfe und Servus, Walter


  

Betrifft: AW: Formellösung Summenprodukt - nochmal von: {Boris}
Geschrieben am: 29.07.2012 21:35:01

Hi Walter,

ich schau mal, ob mir noch was einfällt. Aber alle anderen dürfen ja auch gerne!

Falls Du aber am Ende vielleicht doch die Hilfsspaltenlösung benutzen musst / solltest, dann musst Du noch einen winzigen Fehler beseitigen, da mir in der Formel in AG26

=WENN(($E26="A")*(F26<=$J$1)*((T26="")+($T26=30) +(WENN(T26<>"";F26/T26)*30<=$J$1)>0) *F26;$B26&$C26; "")

ein unerlaubtes $-Zeichen bei ($T26=30) reingerutscht ist.

Muss also korrekt lauten:

=WENN(($E26="A")*(F26<=$J$1)*((T26="")+(T26=30) +(WENN(T26<>"";F26/T26)*30<=$J$1)>0) *F26;$B26&$C26; "")

VG, Boris


  

Betrifft: Anfrage beendet von: WalterK
Geschrieben am: 31.07.2012 09:44:29

Hallo,

ich möchte die Anfrag hier schliessen, vermutlich gibt es auch keine Lösung ohne Hilfsspalten.

Dank Boris Hilfe habe ich ja die richtigen Ergebnisse.

Servus, Walter


  

Betrifft: AW: Anfrage beendet von: {Boris}
Geschrieben am: 31.07.2012 11:14:49

Hi Walter,

ich hab mich jetzt noch nicht intensiver mit der Einformel-Lösung befasst, aber das ist schon sehr komplex, weil man hier verschiedene Dimensionen vereinen muss. Fraglich eben, ob das geht.

VG, Boris