Microsoft Excel

Herbers Excel/VBA-Archiv

Formel für Daten aus anderer Zelle | Herbers Excel-Forum


Betrifft: Formel für Daten aus anderer Zelle von: Andy
Geschrieben am: 09.08.2012 21:11:28

Hallo,

ich habe nach einer Abfrage in der Zelle A1zum Beispiel folgende Werte als mögliche Ergebnisse "138:12" oder "72:38:00" stehen.

Jetzt möchte ich gerne den Wert von A1 in die Zelle B1 übernehmen, jedoch soll dort nur max. "1.Zahl : 2. Zahl" stehen. Falls der zweite Doppelpunkt erscheint, soll dieser und die Zahl dahinter nicht in der Zelle B1 erscheinen.

Alle Zellen sind Text formatiert.

Hat jemand von euch eine Formellösung dazu?

Gruß Andy

  

Betrifft: AW: Formel für Daten aus anderer Zelle von: Ramses
Geschrieben am: 09.08.2012 21:35:23

Hallo

Warum als Text und nicht als Uhrzeit ?
Dann kannst du in der Spalte B ganz einfach das benutzerdefinierte Format

[hh]:mm

zuweisen und fertig.
Den Wert kriegst du, wenn du in B1 =A1*1 eingibst.

Gruss Rainer


  

Betrifft: AW: Formel für Daten aus anderer Zelle von: Andy
Geschrieben am: 09.08.2012 21:41:58

Hallo Rainer,

Uhrzeit ist leider nicht möglich, da es sich um Torverhältnisse handelt und es vorkommen kann, dass die Gegentore mehr als 60 Minuten ergeben.

Bei Deiner Lösung kommt bei A1=49:70 in B1= #Wert! (benutzerdefinierte Format)

Vielleicht noch eine Idee?


  

Betrifft: AW: Formel für Daten aus anderer Zelle von: Uwe (:o)
Geschrieben am: 09.08.2012 21:39:55

Hallo Andy,
teste mal:

=WENNFEHLER(LINKS(A1;FINDEN(":";A1;FINDEN(":";A1)+1)-1);A1)

Klappt es?

Gruß
Uwe
(:o)


  

Betrifft: AW: Formel für Daten aus anderer Zelle von: Andy
Geschrieben am: 10.08.2012 00:10:26

Danke!

habe es mit beiden Tipps lösen können:

=WENNFEHLER(LINKS(A1;FINDEN(":";A1;FINDEN(":";A1)+1)-1);A1)
bei [hh]:mm Zellformtierung.


Beiträge aus den Excel-Beispielen zum Thema "Formel für Daten aus anderer Zelle"