Microsoft Excel

Herbers Excel/VBA-Archiv

Werte suchen | Herbers Excel-Forum


Betrifft: Werte suchen von: Britta
Geschrieben am: 13.08.2012 18:58:20

Hallo Excelprofis,

ich habe folgenes Problem und hoffe Ihr könnt mir helfen.
Ich habe eine Tabelle die wie folgt aufgebaut ist:

Name, Ort1, Ort2, Ort3, Projekt1, Stundensatz1, Projekt2, Stundensatz2, Projekt3, Stundensatz3

Ich benötige ein Formel die mir anhand des Namen und eines Ortes sagen muss ob der Ort unter dem Namen bei Ort1-3 eingetragen ist oder nicht.
Des weiteren benötige ich eine Formel die anhand eines Namen und eines Projektes prüft ob bei dem Namen dieses Projekt bei Projekt1-3 hinterlegt ist und mir dann den zugehörigen Stundensatz liefert.

Ich hoffe Ihr könnt mir helfen.
Gruß
Britta

  

Betrifft: AW: Werte suchen von: Josef Ehrensberger
Geschrieben am: 13.08.2012 19:00:58


Hallo Britta,

sicher können wir die helfen, wenn du eine Beispieldatei mit Beschreibung hoch lädst.




« Gruß Sepp »



  

Betrifft: AW: Werte suchen von: Britta
Geschrieben am: 13.08.2012 22:07:44

Hallo zusammen,

ich habe mal eine Beispieldatei erstellt.
Für die grünen Felder benötige ich die Formeln.
https://www.herber.de/bbs/user/81399.xls

Ich hoffe es wird anhand der Datei deutlicher was ich benötige.

Schöne Grüße
Britta


  

Betrifft: AW: Werte suchen von: Ramses
Geschrieben am: 13.08.2012 23:02:33

Hallo

Meinst du so ?

Tabelle1

 ABCDEFGHIJK
1NameOrt1Ort2Ort3Projekt1Stundensatz1Projekt2Stundensatz2Projekt3Stundensatz3 
2BrittaDüsseldorf  Keller10Dach50   
3HeinzEssenDüsseldorf Dach20     
4OttoKölnAachenEssenPool30     
5KarlAachen  Garten40Keller60Dach70 
6           
7           
8           
9           
10           
11 zu suchender Name zu suchender Ort  ist der Ort beim zu suchenden Namen hinterlegt (A-D)    
12 Otto Aachen  JA    
13 Britta Essen  NEIN    
14           
15           
16 zu suchender Name zu suchendes Projekt  Stundensatz    
17 Heinz Dach  20    
18 Karl Keller  60    
19           
20           

Formeln der Tabelle
ZelleFormel
G12=WENN(SVERWEIS(B12;$A$2:$D$5;2;0)=D12;"JA";WENN(SVERWEIS(B12;$A$2:$D$5;3;0)=D12;"JA";WENN(SVERWEIS(B12;$A$2:$D$5;4;0)=D12;"JA";"NEIN")))
G13=WENN(SVERWEIS(B13;$A$2:$D$5;2;0)=D13;"JA";WENN(SVERWEIS(B13;$A$2:$D$5;3;0)=D13;"JA";WENN(SVERWEIS(B13;$A$2:$D$5;4;0)=D13;"JA";"NEIN")))
G17=WENN(SVERWEIS(B17;$A$2:$J$5;5;0)=D17;INDEX($A$2:$J$5;VERGLEICH(B17;$A$2:$A$5;0); 6); WENN(SVERWEIS(B17;$A$2:$J$5;7;0)=D17;INDEX($A$2:$J$5;VERGLEICH(B17;$A$2:$A$5;0); 8); WENN(SVERWEIS(B17;$A$2:$J$5;9;0)=D17;INDEX($A$2:$J$5;VERGLEICH(B17;$A$2:$A$5;0); 10); "Nicht gefunden")))
G18=WENN(SVERWEIS(B18;$A$2:$J$5;5;0)=D18;INDEX($A$2:$J$5;VERGLEICH(B18;$A$2:$A$5;0); 6); WENN(SVERWEIS(B18;$A$2:$J$5;7;0)=D18;INDEX($A$2:$J$5;VERGLEICH(B18;$A$2:$A$5;0); 8); WENN(SVERWEIS(B18;$A$2:$J$5;9;0)=D18;INDEX($A$2:$J$5;VERGLEICH(B18;$A$2:$A$5;0); 10); "Nicht gefunden")))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruss Rainer


  

Betrifft: AW: Werte suchen von: Britta
Geschrieben am: 14.08.2012 10:30:20

Hallo Rainer,

danke für die schnelle Hilfe.

Gruß
Britta


Beiträge aus den Excel-Beispielen zum Thema "Werte suchen"