Microsoft Excel

Herbers Excel/VBA-Archiv

Falsche Formel eingetragen | Herbers Excel-Forum


Betrifft: Falsche Formel eingetragen von: Heinz H
Geschrieben am: 15.08.2012 22:57:44

Hallo Leute

In Spalte "K" sollte folgende Formel eingetragen werden:

=WENN($B1706<>"";"";KÜRZEN(($A1706-DATUM(JAHR($A1706+3-REST($A1706-2;7));1;REST($A1706-2;7)-9))/7)) 
Es wird aber diese Formel eingetragen:
=WENN(RC2<>"";"";KÜRZEN((RC1-DATUM(JAHR(RC1+3-REST(RC1-2;7));1;REST(RC1-2;7)-9))/7))
Die Formel wird automatisch bei doppelklick eingetragen:
Cells(Target.Row - 1, 11).Formula = "=IF(RC2<>"""","""",TRUNC((RC1-DATE(YEAR(RC1+3-MOD(RC1-2,7)),1,MOD(RC1-2,7)-9))/7))" 'Kalenderwoche anzeigen in K
Wo liegt bitte der Fehler ?
Gruß Heinz7

  

Betrifft: .FormulaR1C1 = "=... o.T. von: Josef Ehrensberger
Geschrieben am: 15.08.2012 22:59:25

« Gruß Sepp »



  

Betrifft: AW: .FormulaR1C1 = "=... o.T. von: Heinz H
Geschrieben am: 15.08.2012 23:03:49

Hallo Josef

Recht herzlichen D A N K !!
Funktioniert wie gewünscht.
Gruß Heinz


Beiträge aus den Excel-Beispielen zum Thema "Falsche Formel eingetragen"