Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zahlen aus 2 Spalten in 1 Spalte auflisten

Zahlen aus 2 Spalten in 1 Spalte auflisten
15.10.2012 13:30:40
WalterK
Hallo,
ich suche im nachfolgenden Beispiel eine Formel ab F2: Es sollen die beiden Spalten A und D ab F2 untereinander aufgelistet werden.
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGH
1Erste Nummernxy1xy2Zweite Nummern Alle Nummern  
21000115 20001 10001 Spalte A enthält Zahlen bis ?
3100022000 20003 10002 Spalte B enthält Zahlen bis ?
410005 2000020004 10005  
510008  20008 10008  
610009700   10009 Ich suche eine Formel ab F2:F?:
7     20001 zuerst sollen die Zahlen aus Spalte A
8     20003 und gleich anschließend die Zahlen
9     20004 aus Spalte D untereinander
10     20008 geschrieben werden.
11        

Die Datei https://www.herber.de/bbs/user/82128.xls wurde aus Datenschutzgründen gelöscht


Besten Dank für die Hilfe
Servus, Walter

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Besten Dank, beide Varianten funktionieren.
15.10.2012 14:22:36
WalterK
Servus, Walter

Geänderte Aufgabenstellung!
15.10.2012 14:53:41
WalterK
Hallo,
wie sich herausgestellt hat, können in Spalte D auch Leerzellen (also Zellen mit dem Formelergebnis "") vorkommen. In der Spalte F dürfen aber keine Leerzellen vorhanden sein.
In Spalte A kommen nie Leerzellen dazwischen vor.
Vielleicht gibt es ja dafür auch eine Lösung.
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGH
1Erste Nummernxy1xy2Zweite Nummern Alle Nummern  
21000115 20001 10001 Spalte A enthält Zahlen bis ?
3100022000 20003 10002 Spalte B enthält Zahlen bis ?
410005 20000  10005  
510008    10008  
610009700   10009 Ich suche eine Formel ab F2:F?:
7   2004 20001 zuerst sollen die Zahlen aus Spalte A
8     20003 und gleich anschließend die Zahlen
9     20004 aus Spalte D untereinander
10   2008 20008 geschrieben werden.
11        

https://www.herber.de/bbs/user/82133.xls
Danke und Servus, Walter

Anzeige
AW: Geänderte Aufgabenstellung!
15.10.2012 15:53:17
Christian
Hallo Walter,
ein Ansatz:
 ABCDEF
1Erste Nummernxy1xy2Zweite Nummern Alle Nummern
21000115 20001 10001
3100022000 20003 10002
410005 20000  10005
510008    10008
610009700   10009
710010  2004 10010
8     20001
9     20003
10   2008 2004
11     2008
12   2009 2009
13     2010
14   2010 2012
15      

Formeln der Tabelle
ZelleFormel
F2{=WENN(ZEILE(A1)>ANZAHL(A:A)+ANZAHL(D:D); "";INDEX($A$2:$D$200;WENN(ZEILE(A1)<=ANZAHL(A:A); ZEILE(A1); KKLEINSTE(WENN($D$2:$D$200<>"";ZEILE($1:$199)); ZEILE(A1)-ANZAHL(A:A))); WENN(ZEILE(A1)<=ANZAHL(A:A); 1;4)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
MfG Christian

Anzeige
Danke Christian, so gehts. Servus, Walter
15.10.2012 16:08:57
WalterK

369 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige