Live-Forum - Die aktuellen Beiträge
Datum
Titel
25.06.2024 22:07:02
25.06.2024 21:01:55
25.06.2024 19:21:44
Anzeige
Archiv - Navigation
1280to1284
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Doppelte Eintrage finden bei bestimmten Kriterien

Doppelte Eintrage finden bei bestimmten Kriterien
26.10.2012 12:08:47
Tim
Hallo liebes Forum,
ich bin am verzweifeln. Suche seit 2 Tagen die passende Formeln aber immer stimmt irgendwas nicht.
Also ich habe eine riesen Exceltabelle und ich will das er Spalte A (von A2-A997) überprüft und mir die Anzahl der doppelten Einträge ausgibt. In Spalte A stehen Datumsangaben.
Aber er soll nur Datensätze berücksichtigen, wo in Spalte B "ETK" und in Spalte C "MSW" steht.
Wie soll das gehen?
Wäre euch wirklich Dankbar

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Doppelte Eintrage finden bei bestimmten Kriterien
26.10.2012 12:36:49
Marc
Mahlzeit!
IN D2 folgende Formel eingeben =SUMMENPRODUKT(($A$2:$A$997=A3)*($B$2:B$997="ETK")*($C$2:C$997="MSW"))
, dann runterziehen bis zum Ende.
Einträge größer 1 sind mehrfach vorhanden
Gruß, MCO

AW: Doppelte Eintrage finden bei bestimmten Kriterien
26.10.2012 12:49:12
Matze,Matthias
Hi,
=SUMMENPRODUKT(($A$2:$A$997=A3)*($B$2:B$997="ETK")*($C$2:C$997="MSW"))
muss da nicht $A$2:$A$997=A2 stehen?
Matze

AW: Doppelte Eintrage finden bei bestimmten Kriterien
26.10.2012 13:02:15
Tim
Ich will die Formel nicht runterziehen. Er soll alles vergleichen und mir einfach ein gesamtergebnis liefern, wieviele Werte gleich sind.
z.B. steht 01.02.2012 3x und 03.02.2012 steht 4x da. Also müsste das ergebnis 5 sein, da er die werte nur einmal berücksichtigen soll.

Anzeige
AW: Doppelte Eintrage finden bei bestimmten Kriterien
26.10.2012 13:57:45
Tim
Also, nochmal zur Info
Ich will nur in einer Zelle die doppelten Datumsanaben ausgeben bzw. die Anzahl davon. Hilfstabellen wären auch okay. Und das ganze Monat für Monat

AW: Doppelte Eintrage finden bei bestimmten Kriterien
26.10.2012 16:35:06
Matze,Matthias
Hi Tim,
ich "will" auch immer alles:
 ABCDEF
1DatumWert1 Formel1Anzahl7
201.01.2012ETKMSW01.01.20121 
301.01.2012ETKMSW02.01.20122 
402.01.2012ETKMSW03.01.20122 
502.01.2012ETKMSW04.01.20122 
602.01.2012ETKMSW06.01.20120 
703.01.2012ETKMSW08.01.20120 
803.01.2012ETKMSW09.01.20120 
903.01.2012ETKMSW   
1004.01.2012ETKMSW   
1104.01.2012ETKMSW   
1204.01.2012ETKMSW   
1306.01.2012ETKMSW   
1408.01.2012ETKMSW   
1509.01.2012ETKMSW   

Formeln der Tabelle
ZelleFormel
F1=SUMME(E:E)
D2{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A2)));"")}
E2=WENN(D2="";"";ZÄHLENWENN(A:A;D2)-1)
D3{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A3)));"")}
E3=WENN(D3="";"";ZÄHLENWENN(A:A;D3)-1)
D4{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A4)));"")}
E4=WENN(D4="";"";ZÄHLENWENN(A:A;D4)-1)
D5{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A5)));"")}
E5=WENN(D5="";"";ZÄHLENWENN(A:A;D5)-1)
D6{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A6)));"")}
E6=WENN(D6="";"";ZÄHLENWENN(A:A;D6)-1)
D7{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A7)));"")}
E7=WENN(D7="";"";ZÄHLENWENN(A:A;D7)-1)
D8{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A8)));"")}
E8=WENN(D8="";"";ZÄHLENWENN(A:A;D8)-1)
D9{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A9)));"")}
E9=WENN(D9="";"";ZÄHLENWENN(A:A;D9)-1)
D10{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A10)));"")}
E10=WENN(D10="";"";ZÄHLENWENN(A:A;D10)-1)
D11{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A11)));"")}
E11=WENN(D11="";"";ZÄHLENWENN(A:A;D11)-1)
D12{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A12)));"")}
E12=WENN(D12="";"";ZÄHLENWENN(A:A;D12)-1)
D13{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A13)));"")}
E13=WENN(D13="";"";ZÄHLENWENN(A:A;D13)-1)
D14{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A14)));"")}
E14=WENN(D14="";"";ZÄHLENWENN(A:A;D14)-1)
D15{=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A15)));"")}
E15=WENN(D15="";"";ZÄHLENWENN(A:A;D15)-1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Rückmeldung wäre nett.
Matze

Anzeige
AW: Doppelte Eintrage finden bei bestimmten Kriterien
26.10.2012 16:36:58
Matze,Matthias
jetzt muss da noch das mit dem ETk und MSW rein....

Profi gesucht :-) - und Rückfrage?
27.10.2012 10:37:04
Matze,Matthias
Moin zusammen,
...kann sich das mal einer ansehen von euch Profis? - Danke
Rückfrage : @ Tim ,...war doch so eilig? Warum kommt keine Antwort?
gruß Matze

AW: Doppelte Eintrage finden bei bestimmten Kriterien
27.10.2012 15:27:45
Christian
Hallo Tim,
Vorschlag mit Hilfsspalten:
 ABCDEFGH
1DatumWert1    Formel1Anzahl
201.01.2012ETKMSX  ETK01.01.20123
301.01.2012ETKMSX  MSW02.01.20122
401.01.2012ETTMSW   03.01.20123
501.01.2012ETKMSW40909ETKMSW1 04.01.20124
601.01.2012ETKMSL   05.01.20122
701.01.2012PTKMSW   06.01.20123
801.01.2012ETKMSL   07.01.20123
901.01.2012ETPMSW   08.01.20123
1001.01.2012ETKMSW40909ETKMSW  09.01.20122
1101.01.2012ETKASW   10.01.20123
1201.01.2012ETKMSW40909ETKMSW  11.01.20124
1302.01.2012ETKMRW     
1402.01.2012ETKMSW40910ETKMSW2   
1502.01.2012ETKMSN     
1602.01.2012ETFMSW     
1702.01.2012ETKMSX     
1802.01.2012ETTMSW     
1902.01.2012ETKMSW40910ETKMSW    
2002.01.2012ETKMSL     
2102.01.2012PTKMSW     
2202.01.2012ETKMSL     
2303.01.2012ETPMSW     
2403.01.2012ETKMSW40911ETKMSW3   

Formeln der Tabelle
ZelleFormel
D2=WENN(UND(B2=$F$2;C2=$F$3); A2&B2&C2;"")
E2=WENN(D2="";"";WENN(ZÄHLENWENN($D$2:D2;D2)=1;MAX($E$1:E1)+1;""))
G2=WENN(ZEILE(A1)>MAX(E:E); "";INDEX(A:A;VERGLEICH(ZEILE(A1); E:E;0)))
H2=WENN(G2="";"";ZÄHLENWENN(D:D;G2&$F$2&$F$3))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
MfG Christian

Anzeige
AW: Doppelte Eintrage finden bei bestimmten Kriterien
29.10.2012 07:28:37
Tim
Hallo zusammen,
alle eure Antworten haben mir weiter geholfen. Nochmal vielen Dank ihr seid echt Klasse! :)
Sorry für die verspätete Rückmeldung

305 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige