Microsoft Excel

Herbers Excel/VBA-Archiv

Datensätze filtern unter Angabe Bedingungen

Betrifft: Datensätze filtern unter Angabe Bedingungen von: JAT
Geschrieben am: 28.10.2012 19:35:27

Hallo liebes Forum,

ich möchte eine Liste (=Quelldaten) automatisiert filtern lassen.
Die Liste hat je Datensatz-Zeile eine fortlaufende Nummer sowie je Datensatz eine Bedingung ja/nein.

In einem neuen Sheet soll nun als Bedingung ein Korridor für die lfd. Nummer vorgegeben werden sowie zwei weitere Bedingungen, welche Datensätze mit einer Zahl 1/2/3/... beachtet werden sollen.
Die übrig gebliebenen Datensätze sollen dann automatisch untereinander angezeigt werden.

Zum besseren Verständnis als Screenshot - Quelldaten:


Filterung (mit Eingabe Filterbedingungen):


https://www.herber.de/bbs/user/82357.xls

Hat jemand eine Idee für einen Ansatz? (ohne VBA wäre super, da ich selbst noch anpassen muss)

Viele Grüße
Joerschi

  

Betrifft: AW: Datensätze filtern unter Angabe Bedingungen von: KlausF
Geschrieben am: 28.10.2012 19:44:48

Hallo Joerschi,
das machst Du am besten mit dem Spezialfilter
(Daten / Filtern / Spezialfilter)

Im Anhang eine Datei aus meiner Sammlung. Beliebige Seite öffnen und Spezialfilter anwählen.
Rest dürfte selbsterklärend sein.

https://www.herber.de/bbs/user/82358.xls

Gruß
Klaus


  

Betrifft: AW: Datensätze filtern unter Angabe Bedingungen von: JAT
Geschrieben am: 28.10.2012 20:02:04

Hallo Klaus,

danke für die Datei. Bin mir nur nicht sicher, ob das dann weiterhilft... (peinlichschau).

An jede Zeile der gefilterten Datenn soll später noch eine Berechnung angehängt werden, welche z. B. jeweils auf eine Zahl (Summe) des vorherigen Datensatzes zurückgreift. Lässt sich das mit der Datei ggf. auch bewerkstelligen (bisher nur überflogen).

Viele Grüße
Joerschi


  

Betrifft: AW: Datensätze filtern unter Angabe Bedingungen von: Christian
Geschrieben am: 28.10.2012 20:09:38

Hallo Joerschi,

ein Ansatz:

 ABCDEF
1Bedingung:2Gelb=Eingabe   
2Geschlecht:m    
3Beginne ab Datensatz:4    
4Ende bei Datensatz:15    
5      
6Ergebnis:     
7lfd. Nr.NameVornameGeburtstagGeschlechtBedingung
86NeuerManuel06.01.1978m2
911SchlingelRonny11.01.1978m2
1014GroßBarti14.01.1978m2
11      
12      
13      
14      
15      
16      
17      

Formeln der Tabelle
ZelleFormel
A8{=WENN(ZEILE(A1)>SUMMENPRODUKT((li_bed=$B$1)*(li_ges=$B$2)); "";INDEX(li_1;KKLEINSTE(WENN((li_bed=$B$1)*(li_ges=$B$2); ZEILE(li_zeile)); ZEILE(A1))))}
B8=WENN($A8="";"";SVERWEIS($A8;Quelldaten!$A:$F;SPALTE(); 0))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen
Namen in Formeln
ZelleNameBezieht sich auf
A8li_1=INDEX(Quelldaten!$A$2:$A$1000;Anordnung!$B$3):INDEX(Quelldaten!$A$2:$A$1000;Anordnung!$B$4)
A8li_bed=INDEX(Quelldaten!$F$2:$F$1000;Anordnung!$B$3):INDEX(Quelldaten!$F$2:$F$1000;Anordnung!$B$4)
A8li_ges=INDEX(Quelldaten!$E$2:$E$1000;Anordnung!$B$3):INDEX(Quelldaten!$E$2:$E$1000;Anordnung!$B$4)
A8li_zeile=INDEX(Quelldaten!$A:$A;1):INDEX(Quelldaten!$A:$A;Anordnung!$B$4-Anordnung!$B$3)
Namen verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

MfG Christian


  

Betrifft: kleine Korrektur von: Christian
Geschrieben am: 28.10.2012 20:19:36

Hallo Joerschi,

beim Testen noch einen kleinen Fehler entdeckt!

 ABCDEF
1Bedingung:2Gelb=Eingabe   
2Geschlecht:m    
3Beginne ab Datensatz:4    
4Ende bei Datensatz:15    
5      
6Ergebnis:     
7lfd. Nr.NameVornameGeburtstagGeschlechtBedingung
86NeuerManuel06.01.1978m2
911SchlingelRonny11.01.1978m2
1014GroßBarti14.01.1978m2
11      
12      
13      
14      
15      
16      
17      

Formeln der Tabelle
ZelleFormel
A8{=WENN(ZEILE(A1)>SUMMENPRODUKT((li_bed=bed)*(li_ges=ges)); "";INDEX(li_1;KKLEINSTE(WENN((li_bed=bed)*(li_ges=ges); ZEILE(li_zeile)); ZEILE(A1))))}
B8=WENN($A8="";"";SVERWEIS($A8;Quelldaten!$A:$F;SPALTE(); 0))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen
Namen in Formeln
ZelleNameBezieht sich auf
A8bed=Anordnung!$B$1
A8ges=Anordnung!$B$2
A8li_1=INDEX(Quelldaten!$A$2:$A$1000;Anordnung!$B$3):INDEX(Quelldaten!$A$2:$A$1000;Anordnung!$B$4)
A8li_bed=INDEX(Quelldaten!$F$2:$F$1000;Anordnung!$B$3):INDEX(Quelldaten!$F$2:$F$1000;Anordnung!$B$4)
A8li_ges=INDEX(Quelldaten!$E$2:$E$1000;Anordnung!$B$3):INDEX(Quelldaten!$E$2:$E$1000;Anordnung!$B$4)
A8li_zeile=INDEX(Quelldaten!$A:$A;1):INDEX(Quelldaten!$A:$A;Anordnung!$B$4-Anordnung!$B$3+1)
Namen verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

MfG Christian


  

Betrifft: AW: Datensätze filtern unter Angabe Bedingungen von: KlausF
Geschrieben am: 28.10.2012 22:25:55

Hallo Joerschi,

[An jede Zeile der gefilterten Datenn soll später noch eine Berechnung angehängt werden, welche z. B. jeweils auf eine Zahl (Summe)
des vorherigen Datensatzes zurückgreift. Lässt sich das mit der Datei ggf. auch bewerkstelligen (bisher nur überflogen).]


Da Excel rechnen kann lässt sich das aller Wahrscheinlichkeit nach bewerkstelligen. Davon war aber in Deiner Ausgangsfrage keine Rede.
Mit dem Spezialfilter kannst Du sehr leicht den von Dir geposteten Screenshot herbei führen. Zu allem anderen fehlt die nötige Info.

Gruß
Klaus


  

Betrifft: Beispiel von: KlausF
Geschrieben am: 29.10.2012 14:42:51

Hallo Joerschi,
anbei mal ein Beispiel mit VBA. Die Bedingungen kannst du im Sheet leicht anpassen,
die Auswertungsformel auch.

https://www.herber.de/bbs/user/82368.xls

Gruß
Klaus


 

Beiträge aus den Excel-Beispielen zum Thema "Datensätze filtern unter Angabe Bedingungen"