Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen im Datumsintervall

Betrifft: Zählen im Datumsintervall von: Marek Pe
Geschrieben am: 31.10.2012 15:46:04

Hallo zusammen,

in angehängter Tabelle habe ich folgendes Problem:

Spalte D ist die Basis für die x-Achse einer Grafik, mit der ich für jeden Tag im Jahr die Anzahl der in Umlauf befindlichen Ausgänge für den Ausgangstag darstellen möchte.

Für Zeile 2 sind es 3 (der Ausgang der Zeile 2 selbst, Ausgänge der Zeilen 3 und 4 gehen über den Ausgangstag hinaus). Für Zeile 3 ist es nur der Ausgang selbst, da die Ausgänge der Zeilen 2 und 4 später beginnen.

Zusätzliche Schwierigkeit ist der Jahreswechsel.

Weiß jemand eine Formel? Oder ist VBA vonnöten?

https://www.herber.de/bbs/user/82414.xlsx

Gruß
Marek

  

Betrifft: unklar von: Erich G.
Geschrieben am: 01.11.2012 01:05:46

Hi Marek,
aus deiner Beschreibung und auch aus den Beispielen ist mir die Aufgabe nicht klar geworden.

Welche Rolle spielen die (wegen des Zellformats nicht angezeigten) Uhrzeiten in Spalte B?
Würde ein Ausgang mitgezählt, der am selben Tag wieder eingeht?

Ich habs mal so versucht, wobei die Spalte E nicht gebraucht wird:

 ABCDE
1Datum AusgangDatum EingangAnz. draußen Tage
227.12.12  00:0028.12.12  11:003 1
322.12.12  00:0028.12.12  16:301 7
427.12.12  00:0002.01.13  08:003 6

Formeln der Tabelle
ZelleFormel
C2=SUMMENPRODUKT((A$2:A$99<=A2)*(A2<=B$2:B$99))
E2=RUNDEN(B2;0)-A2


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: Sieht gut aus; und noch eine Frage von: Marek Pe
Geschrieben am: 02.11.2012 09:47:22

Hallo Erich,

Ausgang und Eingang am selben Tag bedeutet einen Tag Laufzeit; deshalb die Uhrzeiten.

Deine Formel sieht gut aus. Könntest du kurz beschreiben, was gerechnet wird? So richtig schlau werde ich daraus nicht.

Besten Dank schon mal und Gruß aus Wien

Marek


  

Betrifft: SUMMENPRODUKT von: Erich G.
Geschrieben am: 02.11.2012 20:01:09

Hi Marek,
das mit dem "kurz beschreiben" ist nicht ganz so einfach.
Wo anfangen? Mit "Wie geht SUMMENPRODUKT?"? Da wäre erst mal die Excel-Hilfe zu SUMMENPRODUKT.

Schau mal z. B. hier, da ist es gut erklärt, auch die jetzige Anwendung:
http://www.online-excel.de/excel/singsel.php?f=53

Hilft dir das weiter?

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: SUMMENPRODUKT von: Marek Pe
Geschrieben am: 05.11.2012 17:09:23

Hallo Erich,

SUMMENPRODUKT habe ich in der Form noch nicht verwendet, deshalb die Frage.

Vielen Dank noch mal und Gruß aus Wien

Marek


 

Beiträge aus den Excel-Beispielen zum Thema "Zählen im Datumsintervall"