Microsoft Excel

Herbers Excel/VBA-Archiv

Nur jede 2te Spalte summieren

Betrifft: Nur jede 2te Spalte summieren von: Peter
Geschrieben am: 11.11.2012 18:58:32

Hallo,

ich habe ein recht nerviges Problem.

Ich muss in einer Tabelle mit 90 Spalten in der 91sten Spalte die Summe berechnen - allerdings soll die Summe nur jede 2te Spalte beinhalten. Die Formel ist eigentlich einfach aber meterlang (Summe(B4;D4;F4...)).
Da dieses Problem öfter auftritt nun die Frage:
Kann ich die Argumente der Summenfunktion so steuern, dass nur jede 2te Spalte einbezogen und die Formel dadurch kürzer wird?

MfG
Peter

  

Betrifft: AW: Nur jede 2te Spalte summieren von: EtoPHG
Geschrieben am: 11.11.2012 19:06:39

Hallo Peter,

=SUMMENPRODUKT((NICHT(REST(SPALTE($B4:CL4);2)))*($B4:CL4))

Gruess Hansueli


  

Betrifft: AW: Nur jede 2te Spalte summieren von: Peter
Geschrieben am: 11.11.2012 19:18:46

Cool, das war ja schnell.

Danke!


 

Beiträge aus den Excel-Beispielen zum Thema "Nur jede 2te Spalte summieren"