Tage im Monat ohne Samstag und Sonntag listen



Excel-Version: Ab 8.0
nach unten

Betrifft: Tage im Monat ohne Samstag und Sonntag listen
von: Sabine
Geschrieben am: 17.06.2002 - 23:41:42

Hallo wer kann mir helfen ich würde gerne eine Liste mit Datum erhalten die ohne Samstage und Sontage.
Also z.B. Steht in Zelle A1 01.06.2002 das bruch ich für andere Mappen nun würd ich gerne in Zelle C5-C?? eine liste mit Den Tagen im Monat haben ohne Samsatg und Sonntag und ohne lerzeilen dazwischen wie geht das?????

MfG


nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Ramses
Geschrieben am: 17.06.2002 - 23:55:58

Hallo Sabine,

setze diese Formel in A2 und kopiere sie bis A30:

=WENN(WOCHENTAG(A1;2)=5;A1+3;WENN(WOCHENTAG(A1;2)=6;A1+2;WENN(WOCHENTAG(A1;2)=7;A1+1;A1+1)))

Anschliessend musst du die Zellen noch im Datumsformat formatieren.

Gruss Rainer

nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Sabine
Geschrieben am: 18.06.2002 - 00:10:02

Schon ganz gut nur wie mach ich es damit ich die Tage des neuen Monats nicht habe also beim 28.6. aufhört?

nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Ramses
Geschrieben am: 18.06.2002 - 00:22:44

Hallo Sabine,

dann wird die Formel etwas grösser :-))

In A2 und nach unten kopieren:

=WENN(A22="";"";WENN(ODER(MONAT(A22)<>MONAT(A22+1);MONAT(A22)<>MONAT(A22+2);MONAT(A22)<>MONAT(A22+3));"";WENN(WOCHENTAG(A22;2)=5;A22+3;WENN(WOCHENTAG(A22;2)=6;A22+2;WENN(WOCHENTAG(A22;2)=7;A22+1;A22+1)))))

Gruss Rainer

nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Heinz
Geschrieben am: 18.06.2002 - 07:36:00

Hallo Rainer,

deine Formeln arbeiten prima. Ich habe sie nachvollzogen weil ich bisher immer eine Wenn zur Feststellung von Sa / So benutzte und dann eine Zählfolge aufgebaut habe um die restlichen Tage in eine Reihe zu bekommen. Diese Reihe habe ich dann als S-Verweis-Suchspalte benutzt und in einer 2. Mappe die Tage ohne Sa/So aufgelistet. Ein bischen kompliziert, aber als einmal das Muster fertig war schnell in andere Mappen einzubauen.

Nun zu meiner Frage:

Warum kommen bei mir immer 2/3 Montage hintereinander?
Beginn in A1
01.06.02 ist Sa nach deiner Formel Mo
02.06.02 ist So nach deiner Formel Mo
03.06.02 ist Mo nach deiner Formel Di und so weiter
Ist nicht der Anfang =Wenn(wochentag(A1;2)=5;a1+3; .... zuviel?
Das ist ja ein Freitag und wird zum Montag wie Sa und So.

Gruß Heinz

PS: Was bedeuter die 2 bei Wochentag(a1;2)?

nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Hajo
Geschrieben am: 18.06.2002 - 07:49:00

Hallo Heinz

wennn ich mal einklinken darf. Ich löse es immer mit zwei Formel.

Der Monatserste steht in A2 und Monnatsende in B2

folgende Formel für ermittlung des ersten Arbeitstages in A10
=WENN(WOCHENTAG(B1;2)=5;B1+3;WENN(WOCHENTAG(B1;2)=6;B1+2;WENN(WOCHENTAG(B1;2)=7;B1+1;B1)))

und in A11 folgende Formel und runterziehen
=WENN(A10>=$B$2;"";WENN(A10=0;;WENN(WOCHENTAG(A10;2)=5;A10+3;A10+1)))

Gruß Hajo


nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Heinz
Geschrieben am: 18.06.2002 - 08:17:24

Hallo Hajo,

Danke für deine Info, es wird dieFormel langsam klarer. Ich muss sie mal nachher in Ruhe probieren.

Du hast aber für mich nit diesem Aufbau ein anderes Problem unabsichtlich gelöst und zwar das Bestimmen des Monatsletzten für manche Kalenderfunktionen.

Danke
Gruß Heinz


nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Heinz
Geschrieben am: 18.06.2002 - 08:17:47

Hallo Hajo,

Danke für deine Info, es wird dieFormel langsam klarer. Ich muss sie mal nachher in Ruhe probieren.

Du hast aber für mich nit diesem Aufbau ein anderes Problem unabsichtlich gelöst und zwar das Bestimmen des Monatsletzten für manche Kalenderfunktionen.

Danke
Gruß Heinz


nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Hajo
Geschrieben am: 18.06.2002 - 08:22:20

Hallo Heinz

zum bestimmen des Monatzletzten hat Excel doch die Funktinon Monatsende hierzu muß aber das ADD In analyse Funktion aktiviert sein. Auf dies Funktion habe ich extra verzichtet weil viele es nicht wollen.

Mann könnte es auch über die Funktion Datum realisieren.

Gruß Hajo


nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Ramses
Geschrieben am: 18.06.2002 - 08:30:14

Hallo Heinz,

so ganz kann ich das Problem nicht nachvollziehen, weil die Formel bei mir funkioniert und auch für den 1.6.2002 als ERgebnis den Samstag bringt.

Die 2 in der Formel bedeutet übrigens, dass die europäische Zählart angewendet wird,... nämlich dass der erste Tag der Woche der Montag ist, also 1.
Beispiel:
Samstag
1.6.2002 =WOCHENTAG(A1) =7

1.6.2002 = WOCHENTAG(A1;2) = 6

Ohne diese 2 erhältst du ein falsches Ergebnis. Offiziell !!!
Allerdings habe ich die Erfahrung gemacht, dass man das prüfen muss und das ERgebnis nicht auf allen Maschinen gleich ist.
Ich habe z.B. 2 Rechner; auf einem erhalte ich das richtige Ergebnis auf einem anderen das falsche.
Warum das so ist,... keine Ahnung. Aber das ist zumindest die offizielle Formel-Version :-))

Gruss Rainer

nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Sabine
Geschrieben am: 18.06.2002 - 11:31:40

Hallo ihr nochmal die Formel funktioniert Klasse aber ich bräuchte auch noch den Anfang mit gelistet weil bei mir in zelle A1 das datum steht und in C5-C?? Soll das datum stehen allso müßte die liste in c5 mit dem 1.beginnen in der formel macht er es aber nur mit dem 2.beginnend
Gruß Sabine

nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Ramses
Geschrieben am: 18.06.2002 - 12:11:11

Hallo Sabine,

habt ihr alle die gleiche Hausaufgabe ?

Sei ein bischen Kreativ.
Wenn du in A1 dein Datum eingibst dann schreibst du in C5 "=A1" dann steht dort das gleiche Datum und die Formel musst du nur noch an die jeweiligen Zellen anpassen.

Gruss Rainer


nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Sabine
Geschrieben am: 18.06.2002 - 13:06:32

Ja ramses aber dann steht da immer der 01.06.2002 ist aber wochenende und solte nicht da stehen sondern es sollte der 03.06.2002 dort stehen

nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Ramses
Geschrieben am: 18.06.2002 - 13:48:28

Hallo Sabine,

dann schreib halt in C5 diese Formel:

=WENN(WOCHENTAG(A1;2)=5;A1+3;WENN(WOCHENTAG(A1;2)=6;A1+2;WENN(WOCHENTAG(A1;2)=7;A1+1;A1)))

und die andere Formel aus dem anderen Beitrag in C6

Gruss Rainer

nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Horst
Geschrieben am: 19.06.2002 - 13:44:45

Hallo Sabine,
ich habe das Probelm wie folgt gelöst, bin allerdings eher ein Anfänger auf dem Gebiet. Meine Beschreibeung;

1) das Datum 1. 6. 2002 in eine betreffende Zelle eintragen,
2) eine Anzahl von Zellen darunter markieren,
3) "Bearbeiten" anklicken,
4) dann den Punkt "Ausfüllen" anklicken,
5) dann den Punkt "Reihe" anklicken,
6) dann hast Du die Möglichkeit "Tag" oder "Wochentag" anzuklicken,hier kommt natürlich nur "Wochentag" in Betracht.
7) dann "OK" anklicken,
7) bei mir erscheinen dann die Wochentage 3.6.-7.6. und 1O.6.-14,6. usw.
8) die erstellten Daten markieren,
9) rechte Maustaste anklicken,
1O) Zellen formatieren anklicken,
11) unter Punkt "Zahlen" "benutzerdefiniert" anklicken,
12) Format "TTTT.TT.MM.JJ"erstellen,
13) jetzt müßte vor jedem Datum auch noch der entspechende Wochentag z.B. Montag.3.6.2002 stehen.
Ich hoffe, daß ich Dein Probelm überhaupt erkannt habe bzw. zu einer Lösung beitragen konnte.
Mfg.Horst


nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Horst
Geschrieben am: 19.06.2002 - 13:45:39

Hallo Sabine,
ich habe das Probelm wie folgt gelöst, bin allerdings eher ein Anfänger auf dem Gebiet. Meine Beschreibeung;

1) das Datum 1. 6. 2002 in eine betreffende Zelle eintragen,
2) eine Anzahl von Zellen darunter markieren,
3) "Bearbeiten" anklicken,
4) dann den Punkt "Ausfüllen" anklicken,
5) dann den Punkt "Reihe" anklicken,
6) dann hast Du die Möglichkeit "Tag" oder "Wochentag" anzuklicken,hier kommt natürlich nur "Wochentag" in Betracht.
7) dann "OK" anklicken,
7) bei mir erscheinen dann die Wochentage 3.6.-7.6. und 1O.6.-14,6. usw.
8) die erstellten Daten markieren,
9) rechte Maustaste anklicken,
1O) Zellen formatieren anklicken,
11) unter Punkt "Zahlen" "benutzerdefiniert" anklicken,
12) Format "TTTT.TT.MM.JJ"erstellen,
13) jetzt müßte vor jedem Datum auch noch der entspechende Wochentag z.B. Montag.3.6.2002 stehen.
Ich hoffe, daß ich Dein Probelm überhaupt erkannt habe bzw. zu einer Lösung beitragen konnte.
Mfg.Horst


nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Sabine
Geschrieben am: 20.06.2002 - 00:21:43

ich hab die formelna nangepasst es haut auch bis zu 29. hin aber wenn das datum zum beispiel 07.2002 hört bei mit mit dem 29 die liste auf aber es geht bis zum 29 wo liegt der fewhler in der formel
Datum des monatsersten steht in A1
diese Formel steht in E1
=WENN(WOCHENTAG(A1;2)=5;A1+3;WENN(WOCHENTAG(A1;2)=6;A1+2;WENN(WOCHENTAG(A1;2)=7;A1+1;A1)))
Ab E2 Steht diese formel Abwärts kopiert
=WENN(E1="";"";WENN(ODER(MONAT(E1)<>MONAT(E1+1);MONAT(E1)<>MONAT(E1+2);MONAT(E1)<>MONAT(E1+3));"";WENN(WOCHENTAG(E1;2)=5;E1+3;WENN(WOCHENTAG(E1;2)=6;E1+2;WENN(WOCHENTAG(E1;2)=7;E1+1;E1+1)))))

Wer kann mir helfen


nach oben   nach unten

Re: Tage im Monat ohne Samstag und Sonntag listen
von: Horst
Geschrieben am: 20.06.2002 - 23:32:38


Hallo,
kann das Problem irgendwie mit den nachfolgenden Ausführungen zu tun haben??
Habe ich bei Excelformeln de gefunden!
die Funktion die Du suchst heißt WAHL().
Aber man kann auch mehr als 7 WENNs nutzen. hier wirst Du fündig:
http://www.excelformeln.de/formeln.html?welcher=128
Alternative 2
=wahl(A1;1;2;3....;29) Index von 1 bis 29 möglich
MFG Horst
 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Tage im Monat ohne Samstag und Sonntag listen"