ZahlenCode -> Text



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: ZahlenCode -> Text
von: Christian
Geschrieben am: 25.06.2002 - 13:33:27

Hallo,
wie kann ich am schnellsten im VBA, Codes wie
z.B. nach dem SchulnotenBeispiel einen bestimmten Text zuweisen ?

1 -> "sehr gut"
etc.
danke & grüsse,Christian


nach oben   nach unten

Re: ZahlenCode -> Text
von: Rainer
Geschrieben am: 25.06.2002 - 13:38:31

Lieber Christion!

Ohne VBA verwende SVERWEIS.
Mit z.B.:


Function schulnote(Note As Integer) As String

    Select Case Note
        Case 1: schulnote = "Sehr gut"
        Case 2: schulnote = "Gut"
        Case 3: schulnote = "Befriedigend"
        '...
    End Select

End Function

Lieben Gruß
Rainer

nach oben   nach unten

Re: ZahlenCode -> Text
von: Stefan
Geschrieben am: 27.06.2002 - 12:09:23

Ich habe mir den Functionscode angesehen. Leider habe ich noch nicht viel Excel-Scripe eingesetzt.
Daher: Kann mir jemand genau beschreiben, wie und wo ich oben angefügtes Beispiel in Excel integriere.
(Ich habe ca. 85 verschiedene Codezahlen die ich in einer Tabelle mit 610 und 5100 Datensätzen einsetzen möchte.)
z.B. 0100 = Musterstadt 0234= Musterdorf etc.

Danke im Voraus
Stefan

nach oben   nach unten

Re: ZahlenCode -> Text
von: Rainer
Geschrieben am: 27.06.2002 - 13:09:31

Lieber Stefan!

Wenn du soviele Codezahlen hast, erstelle eine eigene (Referenz-)Tabelle und schreibe in die 1. Spalte deine Codezahlen und in die jeweiligen Zellen daneben die entsprechenden Städtenamen oder sonst was. (Es können auch mehrere Spalten sein, wichtig ist die 1. Spalte.)

Willst du nun für deine bestehenden Datentabellen die den Code entsprechenden Städte haben, füge in eine leere Zelle des Datensatzes die Funktion SVERWEIS ein. Diese durchläuft die Referenz-Tabelle(=Matrix) nach dem Suchtext (Deine CodeZahl) in der Spalte1 der Referenz-Tabelle und falls er gefunden wird, gibt sie dir den Wert, der in der angegebenen Spaltenummer (in deinem Beispiel Spalte 2 (=Städtenamen), zurück. Mehr dazu und ein Beispiel findest du in der Hilfe. Die SVERWEIS-Funktion ist sicherlich eine sehr nützliche und daher viel verwendete Funktion.

Beispiel:
A3: '0234'
Formel in Zelle B3: =SVERWEIS(A3;Tabelle2!A1:E20;2)

Sucht den Wert, der in Zelle A3 steht ('0234'), in der Referenztabelle ('Tabelle2!A1:E20'); findet er ihn, schreibt er in B3 den Inhalt der 2.Spalte neben der Fundstelle (z.B. "Musterdorf"). Wenn der Wert nicht gefunden wird, gibt er #NV aus.

Lieben Gruß
Rainer

nach oben   nach unten

Re: ZahlenCode -> Text
von: Stefan
Geschrieben am: 27.06.2002 - 13:33:06

Hallo Rainer,

vielen, vielen Dank für die schnelle Hilfe.
Ich habe es gleich probiert.
Die korekte Formel lautet bei mir =SVERWEIS(O4;'Daten-Zuordnung'!$A$1:$B$71;2) die "$" müssen ja sein um beim Kopieren nicht falsche Werte zu suchen/zu erzeugen.

Also noch einmal vielen Dank
und einen
lieben Gruß
Stefan

nach oben   nach unten

Re: ZahlenCode -> Text
von: Stefan
Geschrieben am: 27.06.2002 - 15:47:48

Hallo Rainer,

vielen, vielen Dank für die schnelle Hilfe.
Ich habe es gleich probiert.
Die korekte Formel lautet bei mir =SVERWEIS(O4;'Daten-Zuordnung'!$A$1:$B$71;2) die "$" müssen ja sein um beim Kopieren nicht falsche Werte zu suchen/zu erzeugen.

Also noch einmal vielen Dank
und einen
lieben Gruß
Stefan

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Verweis auf Kalendersteuerelement per VBA"